summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHans-Christoph Steiner <hans@eds.org>2013-01-17 14:18:26 -0500
committerHans-Christoph Steiner <hans@eds.org>2013-01-17 14:18:26 -0500
commit1b5ba8e022836fa8ab93bc90df1b34a29ea6e134 (patch)
treee2a832468ccbf52965f18c37b3c4e692fe97ed06 /configure.ac
parent487e15dc239ccdb3344d1c99ce120e872bab4a74 (diff)
Imported Upstream version 2.1.1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 10 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index aac1d47..882c3cc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -388,14 +388,16 @@ if test "${use_tcl}" = "yes" ; then
fi
# Start autosearch by asking tclsh
- if test x"$cross_compiling" = xno; then
- for i in `echo 'puts stdout $auto_path' | ${TCLSH_CMD}`
- do
- if test -f "$i/tclConfig.sh" ; then
- ac_cv_c_tclconfig="$i"
- break
- fi
- done
+ if test x"${ac_cv_c_tclconfig}" = x ; then
+ if test x"$cross_compiling" = xno; then
+ for i in `echo 'puts stdout $auto_path' | ${TCLSH_CMD}`
+ do
+ if test -f "$i/tclConfig.sh" ; then
+ ac_cv_c_tclconfig="$i"
+ break
+ fi
+ done
+ fi
fi
# then check for a private Tcl installation