summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules29
1 files changed, 29 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..31da045
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,29 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+ifeq ($(DEB_BUILD_ARCH_OS), kfreebsd)
+ DO_TEST = no
+endif
+
+override_dh_auto_configure:
+ dh_auto_configure -- --with-system-pgm
+
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+ifneq ($(DO_TEST), no)
+ dh_auto_test
+else
+ -dh_auto_test
+endif
+endif
+
+override_dh_strip:
+ dh_strip --dbg-package=libzmq3-dbg
+
+%:
+ dh $@ --with=autoreconf
+
+.PHONY: override_dh_auto_configure override_dh_strip