summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 11 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 529ff2c..7ac37f7 100644
--- a/setup.py
+++ b/setup.py
@@ -123,6 +123,17 @@ extra_args = { }
if 'py2exe' in sys.argv:
# Tells the py2exe executable what module to actually execute.
extra_args["console"] = ['lib/thandy/ClientCLI.py']
+ # The following options tell py2exe to create a single exeutable file instead
+ # of a directory of dependencies or exe and zip library.
+ # Some additional modules are specified explicitly because the way they are
+ # loaded prevents py2exe from tracing the dependencies automagically.
+ extra_args["zipfile"] = None
+ extra_args["options"] = {
+ 'py2exe': {
+ 'bundle_files': 1,
+ 'includes': ["linecache", "getopt", "json"]
+ }
+ }
setup(name='Thandy',
version=VERSION,