summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py15
1 files changed, 1 insertions, 14 deletions
diff --git a/setup.py b/setup.py
index 10eca8f..b936db7 100644
--- a/setup.py
+++ b/setup.py
@@ -14,20 +14,6 @@ VERSION = '0.0.2-alpha'
VERSION_INFO = (0,0,2)
-try:
- import Crypto
-except ImportError:
- print "Missing support for module Crypto"
- sys.exit(1)
-
-try:
- import json
-except ImportError:
- try:
- import simplejson
- except ImportError:
- print "Missing support for module simplejson"
-
import os, re, shutil, string, struct, sys
os.umask(022)
@@ -155,6 +141,7 @@ setup(name='Thandy',
package_dir=pkg_dir,
packages=pkgs,
scripts=SCRIPTS,
+ install_requires=["json", "pycrypto"],
cmdclass={'install': InstallCommand},
**extra_args
)