summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2008-11-27 01:56:44 +0000
committerNick Mathewson <nickm@torproject.org>2008-11-27 01:56:44 +0000
commitbd2a8dad04994c28086c7c30636273a40be01243 (patch)
tree9393c573f984110973a49256b0c4138a3d6ea7a3 /setup.py
parentf9fa588dac58aa291885096018ccc7a697227228 (diff)
Add mysterious commands suggested by coderman. He says they will make py2exe work. They don't _look_ like a backdoor to me, so in they go! :)
git-svn-id: file:///home/or/svnrepo/updater/trunk@17398 55e972cd-5a19-0410-ae62-a4d7a52db4cd
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 6 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 415fc10..8d18db6 100644
--- a/setup.py
+++ b/setup.py
@@ -3,6 +3,10 @@
# $Id: setup.py,v 1.103 2007-09-15 19:06:37 nickm Exp $
import sys
+try:
+ import py2exe
+except ImportError:
+ pass
#
# Current Thandy version
@@ -127,5 +131,7 @@ setup(name='Thandy',
packages=['thandy', 'thandy.packagesys'],
scripts=SCRIPTS,
cmdclass={'install': InstallCommand},
+ # Tells the py2exe executable what module to actually execute
+ console=['lib/thandy/ClientCLI.py'],
)