summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2008-12-01 16:01:59 +0000
committerNick Mathewson <nickm@torproject.org>2008-12-01 16:01:59 +0000
commit5cf4885e09fddfd0649bef62447517f802de8895 (patch)
treee8e32af1687f7fbcaa0d994434f00829718f9779 /setup.py
parent8519bcad8db1af803d00a0e439a8860fc2d6c631 (diff)
Only pass the console argument to distutils if it knows how to cope with it. Otherwise, distutils warns.
git-svn-id: file:///home/or/svnrepo/updater/trunk@17430 55e972cd-5a19-0410-ae62-a4d7a52db4cd
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 9 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 8d18db6..1f96fa2 100644
--- a/setup.py
+++ b/setup.py
@@ -11,9 +11,9 @@ except ImportError:
#
# Current Thandy version
#
-VERSION = '0.0.1-alpha'
-# System: 0==alpha, 50==beta, 98=pre, 99==release candidate, 100==release
-VERSION_INFO = (0,0,1)
+VERSION = '0.0.2-alpha'
+
+VERSION_INFO = (0,0,2)
try:
import Crypto
@@ -119,6 +119,11 @@ class InstallCommand(distutils.command.install.install):
distutils.command.install.install.run(self)
+extra_args = { }
+if 'py2exe' in sys.argv:
+ # Tells the py2exe executable what module to actually execute.
+ extra_args["console"] = 'lib/thandy/ClientCLI.py'
+
setup(name='Thandy',
version=VERSION,
license="3-clause BSD",
@@ -131,7 +136,6 @@ setup(name='Thandy',
packages=['thandy', 'thandy.packagesys'],
scripts=SCRIPTS,
cmdclass={'install': InstallCommand},
- # Tells the py2exe executable what module to actually execute
- console=['lib/thandy/ClientCLI.py'],
+ **extra_args
)