summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/10-520466-libsqlite3-depends-on-libdl.patch43
-rw-r--r--debian/patches/10-520478-squash-bad-deps.patch25
-rw-r--r--debian/patches/10-665363-disable-malloc-usable-size.patch17
-rw-r--r--debian/patches/20-change-name-to-sqlcipher.patch7
-rw-r--r--debian/patches/20-hurd-locking-style.patch38
-rw-r--r--debian/patches/31-increase_SQLITE_MAX_DEFAULT_PAGE_SIZE_to_32k.patch23
-rw-r--r--debian/patches/32-fix-pkgconfig-libname.patch11
-rw-r--r--debian/patches/series7
8 files changed, 171 insertions, 0 deletions
diff --git a/debian/patches/10-520466-libsqlite3-depends-on-libdl.patch b/debian/patches/10-520466-libsqlite3-depends-on-libdl.patch
new file mode 100644
index 0000000..150b8bd
--- /dev/null
+++ b/debian/patches/10-520466-libsqlite3-depends-on-libdl.patch
@@ -0,0 +1,43 @@
+Index: sqlite3-3.7.17/configure.ac
+===================================================================
+--- sqlite3-3.7.17.orig/configure.ac 2013-05-20 12:56:30.000000000 +0200
++++ sqlite3-3.7.17/configure.ac 2013-05-21 22:20:46.000000000 +0200
+@@ -233,6 +233,38 @@
+ AC_SUBST(BUILD_CC)
+
+ ##########
++# Do we want to support load_extension()?
++#
++AC_ARG_ENABLE(load-extension,
++AC_HELP_STRING([--enable-load-extension],
++ [Include SQL functions for loading extension libraries]),,
++ enable_load_extension=auto)
++
++if test "x$enable_load_extension" = xyes ||
++ test "x$enable_load_extension" = xauto; then
++
++ can_load_extension=yes
++ # libtool will already have looked for <dlfcn.h>
++ if test $ac_cv_header_dlfcn_h = no; then
++ can_load_extension=no
++ else
++ AC_SEARCH_LIBS(dlopen, dl, , [can_load_extension=no])
++ fi
++elif test "x$enable_load_extension" = xno; then
++ can_load_extension=no
++else
++ AC_MSG_ERROR([invalid argument to --enable-load-extension])
++fi
++
++if test $can_load_extension = no; then
++ if test "x$enable_load_extension" = xyes; then
++ AC_MSG_ERROR([<dlfcn.h> routines missing, load_extension() not supported])
++ fi
++ AC_DEFINE(SQLITE_OMIT_LOAD_EXTENSION, 1,
++ [Define if the load_extension() sql function should be omitted.])
++fi
++
++##########
+ # Do we want to support multithreaded use of sqlite
+ #
+ AC_ARG_ENABLE(threadsafe,
diff --git a/debian/patches/10-520478-squash-bad-deps.patch b/debian/patches/10-520478-squash-bad-deps.patch
new file mode 100644
index 0000000..62262d3
--- /dev/null
+++ b/debian/patches/10-520478-squash-bad-deps.patch
@@ -0,0 +1,25 @@
+--- sqlcipher-2.2.1.orig/Makefile.in
++++ sqlcipher-2.2.1/Makefile.in
+@@ -521,18 +521,20 @@ sqlcipher.pc: $(TOP)/sqlcipher.pc.in
+ libsqlcipher.la: $(LIBOBJ)
+ $(LTLINK) -o $@ $(LIBOBJ) $(TLIBS) \
+ ${ALLOWRELEASE} -rpath "$(libdir)" -version-info "8:6:8"
++ sed -i "/dependency_libs/s/'.*'/''/" $@
+
+ libtclsqlite3.la: tclsqlite.lo libsqlcipher.la
+ $(LTLINK) -o $@ tclsqlite.lo \
+- libsqlcipher.la @TCL_STUB_LIB_SPEC@ $(TLIBS) \
++ libsqlcipher.la @TCL_STUB_LIB_SPEC@ \
+ -rpath "$(TCLLIBDIR)" \
+ -version-info "8:6:8" \
+ -avoid-version
++ sed -i "/dependency_libs/s/'.*'/''/" $@
+
+ sqlcipher$(TEXE): $(TOP)/src/shell.c libsqlcipher.la sqlite3.h
+ $(LTLINK) $(READLINE_FLAGS) \
+ -o $@ $(TOP)/src/shell.c libsqlcipher.la \
+- $(LIBREADLINE) $(TLIBS) -rpath "$(libdir)"
++ $(LIBREADLINE) -rpath "$(libdir)"
+
+ mptester$(EXE): sqlite3.c $(TOP)/mptest/mptest.c
+ $(LTLINK) -o $@ -I. $(TOP)/mptest/mptest.c sqlite3.c \
diff --git a/debian/patches/10-665363-disable-malloc-usable-size.patch b/debian/patches/10-665363-disable-malloc-usable-size.patch
new file mode 100644
index 0000000..6d6f49d
--- /dev/null
+++ b/debian/patches/10-665363-disable-malloc-usable-size.patch
@@ -0,0 +1,17 @@
+Description: Disable malloc_usable_size
+ Disable code introduced in sqlite 3.7.10 using malloc_usable_size, as it caused
+ a regression on 64-bit platforms.
+Author: Steven Chamberlain <steven@pyro.eu.org>
+Bug-Debian: http://bugs.debian.org/665363
+
+--- sqlite3-3.7.11.orig/configure.ac
++++ sqlite3-3.7.11/configure.ac
+@@ -127,7 +127,7 @@
+ #########
+ # Figure out whether or not we have these functions
+ #
+-AC_CHECK_FUNCS([usleep fdatasync localtime_r gmtime_r localtime_s utime malloc_usable_size])
++AC_CHECK_FUNCS([usleep fdatasync localtime_r gmtime_r localtime_s utime])
+
+ #########
+ # By default, we use the amalgamation (this may be changed below...)
diff --git a/debian/patches/20-change-name-to-sqlcipher.patch b/debian/patches/20-change-name-to-sqlcipher.patch
new file mode 100644
index 0000000..934e1c8
--- /dev/null
+++ b/debian/patches/20-change-name-to-sqlcipher.patch
@@ -0,0 +1,7 @@
+diff --git a/VERSION b/VERSION
+index c77a7de..50ffc5a 100644
+--- a/VERSION
++++ b/VERSION
+@@ -1 +1 @@
+-3.7.17
++2.2.1
diff --git a/debian/patches/20-hurd-locking-style.patch b/debian/patches/20-hurd-locking-style.patch
new file mode 100644
index 0000000..73e72a3
--- /dev/null
+++ b/debian/patches/20-hurd-locking-style.patch
@@ -0,0 +1,38 @@
+--- a/src/os_unix.c
++++ b/src/os_unix.c
+@@ -131,7 +131,7 @@
+ #endif
+
+
+-#if SQLITE_ENABLE_LOCKING_STYLE
++#if SQLITE_ENABLE_LOCKING_STYLE || defined(__GNU__)
+ # include <sys/ioctl.h>
+ # if OS_VXWORKS
+ # include <semaphore.h>
+@@ -2198,7 +2198,7 @@
+ ** Omit this section if SQLITE_ENABLE_LOCKING_STYLE is turned off or if
+ ** compiling for VXWORKS.
+ */
+-#if SQLITE_ENABLE_LOCKING_STYLE && !OS_VXWORKS
++#if (SQLITE_ENABLE_LOCKING_STYLE && !OS_VXWORKS) || defined(__GNU__)
+
+ /*
+ ** Retry flock() calls that fail with EINTR
+@@ -4927,7 +4927,7 @@
+ dotlockCheckReservedLock /* xCheckReservedLock method */
+ )
+
+-#if SQLITE_ENABLE_LOCKING_STYLE && !OS_VXWORKS
++#if (SQLITE_ENABLE_LOCKING_STYLE && !OS_VXWORKS) || defined(__GNU__)
+ IOMETHODS(
+ flockIoFinder, /* Finder function name */
+ flockIoMethods, /* sqlite3_io_methods object name */
+@@ -7366,6 +7366,8 @@
+ static sqlite3_vfs aVfs[] = {
+ #if SQLITE_ENABLE_LOCKING_STYLE && (OS_VXWORKS || defined(__APPLE__))
+ UNIXVFS("unix", autolockIoFinder ),
++#elif defined(__GNU__)
++ UNIXVFS("unix", flockIoFinder ),
+ #else
+ UNIXVFS("unix", posixIoFinder ),
+ #endif
diff --git a/debian/patches/31-increase_SQLITE_MAX_DEFAULT_PAGE_SIZE_to_32k.patch b/debian/patches/31-increase_SQLITE_MAX_DEFAULT_PAGE_SIZE_to_32k.patch
new file mode 100644
index 0000000..bd0360e
--- /dev/null
+++ b/debian/patches/31-increase_SQLITE_MAX_DEFAULT_PAGE_SIZE_to_32k.patch
@@ -0,0 +1,23 @@
+Description: increase the maximum possible value of the page size
+ Firefox/Iceweasel uses a page size of 32k, but sqlite won't allow it
+ because the maximum it allows by default is 8k (through the
+ SQLITE_MAX_DEFAULT_PAGE_SIZE define). This patch increases this limit.
+ .
+Author: Laszlo Boszormenyi (GCS) <gcs@debian.hu>
+Bug-Debian: http://bugs.debian.org/672573
+
+---
+Forwarded: <not-needed>
+Last-Update: <2012-05-16>
+
+--- sqlite3-3.7.12.orig/src/sqliteLimit.h
++++ sqlite3-3.7.12/src/sqliteLimit.h
+@@ -169,7 +169,7 @@
+ ** SQLite will choose on its own.
+ */
+ #ifndef SQLITE_MAX_DEFAULT_PAGE_SIZE
+-# define SQLITE_MAX_DEFAULT_PAGE_SIZE 8192
++# define SQLITE_MAX_DEFAULT_PAGE_SIZE 32768
+ #endif
+ #if SQLITE_MAX_DEFAULT_PAGE_SIZE>SQLITE_MAX_PAGE_SIZE
+ # undef SQLITE_MAX_DEFAULT_PAGE_SIZE
diff --git a/debian/patches/32-fix-pkgconfig-libname.patch b/debian/patches/32-fix-pkgconfig-libname.patch
new file mode 100644
index 0000000..eaad182
--- /dev/null
+++ b/debian/patches/32-fix-pkgconfig-libname.patch
@@ -0,0 +1,11 @@
+--- a/sqlcipher.pc.in
++++ b/sqlcipher.pc.in
+@@ -8,6 +8,6 @@ includedir=@includedir@
+ Name: SQLite
+ Description: SQL database engine
+ Version: @RELEASE@
+-Libs: -L${libdir} -lsqlite3
++Libs: -L${libdir} -lsqlcipher
+ Libs.private: @LIBS@
+-Cflags: -I${includedir}
++Cflags: -I${includedir}/sqlcipher
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..d61f349
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,7 @@
+10-520466-libsqlite3-depends-on-libdl.patch
+10-520478-squash-bad-deps.patch
+10-665363-disable-malloc-usable-size.patch
+20-change-name-to-sqlcipher.patch
+20-hurd-locking-style.patch
+31-increase_SQLITE_MAX_DEFAULT_PAGE_SIZE_to_32k.patch
+32-fix-pkgconfig-libname.patch