summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/10-520466-libsqlite3-depends-on-libdl.patch41
-rw-r--r--debian/patches/10-520478-squash-bad-deps.patch25
-rw-r--r--debian/patches/10-665363-disable-malloc-usable-size.patch17
-rw-r--r--debian/patches/10-sqlcipher-man-page.patch464
-rw-r--r--debian/patches/20-change-name-to-sqlcipher.patch209
-rw-r--r--debian/patches/20-hurd-locking-style.patch38
-rw-r--r--debian/patches/31-increase_SQLITE_MAX_DEFAULT_PAGE_SIZE_to_32k.patch23
-rw-r--r--debian/patches/series7
8 files changed, 824 insertions, 0 deletions
diff --git a/debian/patches/10-520466-libsqlite3-depends-on-libdl.patch b/debian/patches/10-520466-libsqlite3-depends-on-libdl.patch
new file mode 100644
index 0000000..5ed0d04
--- /dev/null
+++ b/debian/patches/10-520466-libsqlite3-depends-on-libdl.patch
@@ -0,0 +1,41 @@
+--- sqlite3-3.6.11.orig/configure.ac 2009-03-20 16:15:10.000000000 -0700
++++ sqlite3-3.6.11/configure.ac 2009-03-20 16:37:59.000000000 -0700
+@@ -233,6 +233,38 @@
+ AC_SUBST(BUILD_CC)
+
+ ##########
++# Do we want to support load_extension()?
++#
++AC_ARG_ENABLE(load-extension,
++AC_HELP_STRING([--enable-load-extension],
++ [Include SQL functions for loading extension libraries]),,
++ enable_load_extension=auto)
++
++if test "x$enable_load_extension" = xyes ||
++ test "x$enable_load_extension" = xauto; then
++
++ can_load_extension=yes
++ # libtool will already have looked for <dlfcn.h>
++ if test $ac_cv_header_dlfcn_h = no; then
++ can_load_extension=no
++ else
++ AC_SEARCH_LIBS(dlopen, dl, , [can_load_extension=no])
++ fi
++elif test "x$enable_load_extension" = xno; then
++ can_load_extension=no
++else
++ AC_MSG_ERROR([invalid argument to --enable-load-extension])
++fi
++
++if test $can_load_extension = no; then
++ if test "x$enable_load_extension" = xyes; then
++ AC_MSG_ERROR([<dlfcn.h> routines missing, load_extension() not supported])
++ fi
++ AC_DEFINE(SQLITE_OMIT_LOAD_EXTENSION, 1,
++ [Define if the load_extension() sql function should be omitted.])
++fi
++
++##########
+ # Do we want to support multithreaded use of sqlite
+ #
+ AC_ARG_ENABLE(threadsafe,
diff --git a/debian/patches/10-520478-squash-bad-deps.patch b/debian/patches/10-520478-squash-bad-deps.patch
new file mode 100644
index 0000000..71f6362
--- /dev/null
+++ b/debian/patches/10-520478-squash-bad-deps.patch
@@ -0,0 +1,25 @@
+--- sqlite3-3.6.11.orig/Makefile.in 2009-03-24 11:40:55.000000000 -0700
++++ sqlite3-3.6.11/Makefile.in 2009-03-24 11:42:36.000000000 -0700
+@@ -487,18 +487,20 @@
+ libsqlite3.la: $(LIBOBJ)
+ $(LTLINK) -o $@ $(LIBOBJ) $(TLIBS) \
+ ${ALLOWRELEASE} -rpath "$(libdir)" -version-info "8:6:8"
++ sed -i "/dependency_libs/s/'.*'/''/" $@
+
+ libtclsqlite3.la: tclsqlite.lo libsqlite3.la
+ $(LTLINK) -o $@ tclsqlite.lo \
+- libsqlite3.la @TCL_STUB_LIB_SPEC@ $(TLIBS) \
++ libsqlite3.la @TCL_STUB_LIB_SPEC@ \
+ -rpath "$(TCLLIBDIR)" \
+ -version-info "8:6:8" \
+ -avoid-version
++ sed -i "/dependency_libs/s/'.*'/''/" $@
+
+ sqlite3$(TEXE): $(TOP)/src/shell.c libsqlite3.la sqlite3.h
+ $(LTLINK) $(READLINE_FLAGS) \
+ -o $@ $(TOP)/src/shell.c libsqlite3.la \
+- $(LIBREADLINE) $(TLIBS) -rpath "$(libdir)"
++ $(LIBREADLINE) -rpath "$(libdir)"
+
+ # This target creates a directory named "tsrc" and fills it with
+ # copies of all of the C source code and header files needed to
diff --git a/debian/patches/10-665363-disable-malloc-usable-size.patch b/debian/patches/10-665363-disable-malloc-usable-size.patch
new file mode 100644
index 0000000..6d6f49d
--- /dev/null
+++ b/debian/patches/10-665363-disable-malloc-usable-size.patch
@@ -0,0 +1,17 @@
+Description: Disable malloc_usable_size
+ Disable code introduced in sqlite 3.7.10 using malloc_usable_size, as it caused
+ a regression on 64-bit platforms.
+Author: Steven Chamberlain <steven@pyro.eu.org>
+Bug-Debian: http://bugs.debian.org/665363
+
+--- sqlite3-3.7.11.orig/configure.ac
++++ sqlite3-3.7.11/configure.ac
+@@ -127,7 +127,7 @@
+ #########
+ # Figure out whether or not we have these functions
+ #
+-AC_CHECK_FUNCS([usleep fdatasync localtime_r gmtime_r localtime_s utime malloc_usable_size])
++AC_CHECK_FUNCS([usleep fdatasync localtime_r gmtime_r localtime_s utime])
+
+ #########
+ # By default, we use the amalgamation (this may be changed below...)
diff --git a/debian/patches/10-sqlcipher-man-page.patch b/debian/patches/10-sqlcipher-man-page.patch
new file mode 100644
index 0000000..66d5d1b
--- /dev/null
+++ b/debian/patches/10-sqlcipher-man-page.patch
@@ -0,0 +1,464 @@
+--- a/sqlite3.1 2012-03-30 20:53:11.000000000 -0400
++++ /dev/null 2012-03-31 10:49:42.330855572 -0400
+@@ -1,229 +0,0 @@
+-.\" Hey, EMACS: -*- nroff -*-
+-.\" First parameter, NAME, should be all caps
+-.\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
+-.\" other parameters are allowed: see man(7), man(1)
+-.TH SQLITE3 1 "Mon Apr 15 23:49:17 2002"
+-.\" Please adjust this date whenever revising the manpage.
+-.\"
+-.\" Some roff macros, for reference:
+-.\" .nh disable hyphenation
+-.\" .hy enable hyphenation
+-.\" .ad l left justify
+-.\" .ad b justify to both left and right margins
+-.\" .nf disable filling
+-.\" .fi enable filling
+-.\" .br insert line break
+-.\" .sp <n> insert n+1 empty lines
+-.\" for manpage-specific macros, see man(7)
+-.SH NAME
+-.B sqlite3
+-\- A command line interface for SQLite version 3
+-
+-.SH SYNOPSIS
+-.B sqlite3
+-.RI [ options ]
+-.RI [ databasefile ]
+-.RI [ SQL ]
+-
+-.SH SUMMARY
+-.PP
+-.B sqlite3
+-is a terminal-based front-end to the SQLite library that can evaluate
+-queries interactively and display the results in multiple formats.
+-.B sqlite3
+-can also be used within shell scripts and other applications to provide
+-batch processing features.
+-
+-.SH DESCRIPTION
+-To start a
+-.B sqlite3
+-interactive session, invoke the
+-.B sqlite3
+-command and optionally provide the name of a database file. If the
+-database file does not exist, it will be created. If the database file
+-does exist, it will be opened.
+-
+-For example, to create a new database file named "mydata.db", create
+-a table named "memos" and insert a couple of records into that table:
+-.sp
+-$
+-.B sqlite3 mydata.db
+-.br
+-SQLite version 3.1.3
+-.br
+-Enter ".help" for instructions
+-.br
+-sqlite>
+-.B create table memos(text, priority INTEGER);
+-.br
+-sqlite>
+-.B insert into memos values('deliver project description', 10);
+-.br
+-sqlite>
+-.B insert into memos values('lunch with Christine', 100);
+-.br
+-sqlite>
+-.B select * from memos;
+-.br
+-deliver project description|10
+-.br
+-lunch with Christine|100
+-.br
+-sqlite>
+-.sp
+-
+-If no database name is supplied, the ATTACH sql command can be used
+-to attach to existing or create new database files. ATTACH can also
+-be used to attach to multiple databases within the same interactive
+-session. This is useful for migrating data between databases,
+-possibly changing the schema along the way.
+-
+-Optionally, a SQL statement or set of SQL statements can be supplied as
+-a single argument. Multiple statements should be separated by
+-semi-colons.
+-
+-For example:
+-.sp
+-$
+-.B sqlite3 -line mydata.db 'select * from memos where priority > 20;'
+-.br
+- text = lunch with Christine
+-.br
+-priority = 100
+-.br
+-.sp
+-
+-.SS SQLITE META-COMMANDS
+-.PP
+-The interactive interpreter offers a set of meta-commands that can be
+-used to control the output format, examine the currently attached
+-database files, or perform administrative operations upon the
+-attached databases (such as rebuilding indices). Meta-commands are
+-always prefixed with a dot (.).
+-
+-A list of available meta-commands can be viewed at any time by issuing
+-the '.help' command. For example:
+-.sp
+-sqlite>
+-.B .help
+-.nf
+-.cc |
+-.databases List names and files of attached databases
+-.dump ?TABLE? ... Dump the database in an SQL text format
+-.echo ON|OFF Turn command echo on or off
+-.exit Exit this program
+-.explain ON|OFF Turn output mode suitable for EXPLAIN on or off.
+-.header(s) ON|OFF Turn display of headers on or off
+-.help Show this message
+-.import FILE TABLE Import data from FILE into TABLE
+-.indices TABLE Show names of all indices on TABLE
+-.mode MODE ?TABLE? Set output mode where MODE is one of:
+- csv Comma-separated values
+- column Left-aligned columns. (See .width)
+- html HTML <table> code
+- insert SQL insert statements for TABLE
+- line One value per line
+- list Values delimited by .separator string
+- tabs Tab-separated values
+- tcl TCL list elements
+-.nullvalue STRING Print STRING in place of NULL values
+-.output FILENAME Send output to FILENAME
+-.output stdout Send output to the screen
+-.prompt MAIN CONTINUE Replace the standard prompts
+-.quit Exit this program
+-.read FILENAME Execute SQL in FILENAME
+-.schema ?TABLE? Show the CREATE statements
+-.separator STRING Change separator used by output mode and .import
+-.show Show the current values for various settings
+-.tables ?PATTERN? List names of tables matching a LIKE pattern
+-.timeout MS Try opening locked tables for MS milliseconds
+-.width NUM NUM ... Set column widths for "column" mode
+-sqlite>
+-|cc .
+-.sp
+-.fi
+-
+-.SH OPTIONS
+-.B sqlite3
+-has the following options:
+-.TP
+-.BI \-init\ file
+-Read and execute commands from
+-.I file
+-, which can contain a mix of SQL statements and meta-commands.
+-.TP
+-.B \-echo
+-Print commands before execution.
+-.TP
+-.B \-[no]header
+-Turn headers on or off.
+-.TP
+-.B \-column
+-Query results will be displayed in a table like form, using
+-whitespace characters to separate the columns and align the
+-output.
+-.TP
+-.B \-html
+-Query results will be output as simple HTML tables.
+-.TP
+-.B \-line
+-Query results will be displayed with one value per line, rows
+-separated by a blank line. Designed to be easily parsed by
+-scripts or other programs
+-.TP
+-.B \-list
+-Query results will be displayed with the separator (|, by default)
+-character between each field value. The default.
+-.TP
+-.BI \-separator\ separator
+-Set output field separator. Default is '|'.
+-.TP
+-.BI \-nullvalue\ string
+-Set string used to represent NULL values. Default is ''
+-(empty string).
+-.TP
+-.B \-version
+-Show SQLite version.
+-.TP
+-.B \-help
+-Show help on options and exit.
+-
+-
+-.SH INIT FILE
+-.B sqlite3
+-reads an initialization file to set the configuration of the
+-interactive environment. Throughout initialization, any previously
+-specified setting can be overridden. The sequence of initialization is
+-as follows:
+-
+-o The default configuration is established as follows:
+-
+-.sp
+-.nf
+-.cc |
+-mode = LIST
+-separator = "|"
+-main prompt = "sqlite> "
+-continue prompt = " ...> "
+-|cc .
+-.sp
+-.fi
+-
+-o If the file
+-.B ~/.sqliterc
+-exists, it is processed first.
+-can be found in the user's home directory, it is
+-read and processed. It should generally only contain meta-commands.
+-
+-o If the -init option is present, the specified file is processed.
+-
+-o All other command line options are processed.
+-
+-.SH SEE ALSO
+-http://www.sqlite.org/
+-.br
+-The sqlite-doc package
+-.SH AUTHOR
+-This manual page was originally written by Andreas Rottmann
+-<rotty@debian.org>, for the Debian GNU/Linux system (but may be used
+-by others). It was subsequently revised by Bill Bumgarner <bbum@mac.com>.
+--- /dev/null 2012-03-31 10:49:42.330855572 -0400
++++ b/sqlcipher.1 2012-03-31 20:07:20.000000000 -0400
+@@ -0,0 +1,229 @@
++.\" Hey, EMACS: -*- nroff -*-
++.\" First parameter, NAME, should be all caps
++.\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
++.\" other parameters are allowed: see man(7), man(1)
++.TH SQLCIPHER 1 "Mon Apr 15 23:49:17 2002"
++.\" Please adjust this date whenever revising the manpage.
++.\"
++.\" Some roff macros, for reference:
++.\" .nh disable hyphenation
++.\" .hy enable hyphenation
++.\" .ad l left justify
++.\" .ad b justify to both left and right margins
++.\" .nf disable filling
++.\" .fi enable filling
++.\" .br insert line break
++.\" .sp <n> insert n+1 empty lines
++.\" for manpage-specific macros, see man(7)
++.SH NAME
++.B sqlcipher
++\- A command line interface for SQLCipher version 2
++
++.SH SYNOPSIS
++.B sqlcipher
++.RI [ options ]
++.RI [ databasefile ]
++.RI [ SQL ]
++
++.SH SUMMARY
++.PP
++.B sqlcipher
++is a terminal-based front-end to the SQLCipher library that can evaluate
++queries interactively and display the results in multiple formats.
++.B sqlcipher
++can also be used within shell scripts and other applications to provide
++batch processing features.
++
++.SH DESCRIPTION
++To start a
++.B sqlcipher
++interactive session, invoke the
++.B sqlcipher
++command and optionally provide the name of a database file. If the
++database file does not exist, it will be created. If the database file
++does exist, it will be opened.
++
++For example, to create a new database file named "mydata.db", create
++a table named "memos" and insert a couple of records into that table:
++.sp
++$
++.B sqlcipher mydata.db
++.br
++SQLite version 2.0.3
++.br
++Enter ".help" for instructions
++.br
++sqlite>
++.B create table memos(text, priority INTEGER);
++.br
++sqlite>
++.B insert into memos values('deliver project description', 10);
++.br
++sqlite>
++.B insert into memos values('lunch with Christine', 100);
++.br
++sqlite>
++.B select * from memos;
++.br
++deliver project description|10
++.br
++lunch with Christine|100
++.br
++sqlite>
++.sp
++
++If no database name is supplied, the ATTACH sql command can be used
++to attach to existing or create new database files. ATTACH can also
++be used to attach to multiple databases within the same interactive
++session. This is useful for migrating data between databases,
++possibly changing the schema along the way.
++
++Optionally, a SQL statement or set of SQL statements can be supplied as
++a single argument. Multiple statements should be separated by
++semi-colons.
++
++For example:
++.sp
++$
++.B sqlcipher -line mydata.db 'select * from memos where priority > 20;'
++.br
++ text = lunch with Christine
++.br
++priority = 100
++.br
++.sp
++
++.SS SQLITE META-COMMANDS
++.PP
++The interactive interpreter offers a set of meta-commands that can be
++used to control the output format, examine the currently attached
++database files, or perform administrative operations upon the
++attached databases (such as rebuilding indices). Meta-commands are
++always prefixed with a dot (.).
++
++A list of available meta-commands can be viewed at any time by issuing
++the '.help' command. For example:
++.sp
++sqlite>
++.B .help
++.nf
++.cc |
++.databases List names and files of attached databases
++.dump ?TABLE? ... Dump the database in an SQL text format
++.echo ON|OFF Turn command echo on or off
++.exit Exit this program
++.explain ON|OFF Turn output mode suitable for EXPLAIN on or off.
++.header(s) ON|OFF Turn display of headers on or off
++.help Show this message
++.import FILE TABLE Import data from FILE into TABLE
++.indices TABLE Show names of all indices on TABLE
++.mode MODE ?TABLE? Set output mode where MODE is one of:
++ csv Comma-separated values
++ column Left-aligned columns. (See .width)
++ html HTML <table> code
++ insert SQL insert statements for TABLE
++ line One value per line
++ list Values delimited by .separator string
++ tabs Tab-separated values
++ tcl TCL list elements
++.nullvalue STRING Print STRING in place of NULL values
++.output FILENAME Send output to FILENAME
++.output stdout Send output to the screen
++.prompt MAIN CONTINUE Replace the standard prompts
++.quit Exit this program
++.read FILENAME Execute SQL in FILENAME
++.schema ?TABLE? Show the CREATE statements
++.separator STRING Change separator used by output mode and .import
++.show Show the current values for various settings
++.tables ?PATTERN? List names of tables matching a LIKE pattern
++.timeout MS Try opening locked tables for MS milliseconds
++.width NUM NUM ... Set column widths for "column" mode
++sqlite>
++|cc .
++.sp
++.fi
++
++.SH OPTIONS
++.B sqlcipher
++has the following options:
++.TP
++.BI \-init\ file
++Read and execute commands from
++.I file
++, which can contain a mix of SQL statements and meta-commands.
++.TP
++.B \-echo
++Print commands before execution.
++.TP
++.B \-[no]header
++Turn headers on or off.
++.TP
++.B \-column
++Query results will be displayed in a table like form, using
++whitespace characters to separate the columns and align the
++output.
++.TP
++.B \-html
++Query results will be output as simple HTML tables.
++.TP
++.B \-line
++Query results will be displayed with one value per line, rows
++separated by a blank line. Designed to be easily parsed by
++scripts or other programs
++.TP
++.B \-list
++Query results will be displayed with the separator (|, by default)
++character between each field value. The default.
++.TP
++.BI \-separator\ separator
++Set output field separator. Default is '|'.
++.TP
++.BI \-nullvalue\ string
++Set string used to represent NULL values. Default is ''
++(empty string).
++.TP
++.B \-version
++Show SQLite version.
++.TP
++.B \-help
++Show help on options and exit.
++
++
++.SH INIT FILE
++.B sqlcipher
++reads an initialization file to set the configuration of the
++interactive environment. Throughout initialization, any previously
++specified setting can be overridden. The sequence of initialization is
++as follows:
++
++o The default configuration is established as follows:
++
++.sp
++.nf
++.cc |
++mode = LIST
++separator = "|"
++main prompt = "sqlite> "
++continue prompt = " ...> "
++|cc .
++.sp
++.fi
++
++o If the file
++.B ~/.sqliterc
++exists, it is processed first.
++can be found in the user's home directory, it is
++read and processed. It should generally only contain meta-commands.
++
++o If the -init option is present, the specified file is processed.
++
++o All other command line options are processed.
++
++.SH SEE ALSO
++http://www.sqlcipher.net/
++.br
++The sqlite-doc package
++.SH AUTHOR
++This manual page was originally written by Andreas Rottmann
++<rotty@debian.org>, for the Debian GNU/Linux system (but may be used
++by others). It was subsequently revised by Bill Bumgarner <bbum@mac.com>.
diff --git a/debian/patches/20-change-name-to-sqlcipher.patch b/debian/patches/20-change-name-to-sqlcipher.patch
new file mode 100644
index 0000000..44e2322
--- /dev/null
+++ b/debian/patches/20-change-name-to-sqlcipher.patch
@@ -0,0 +1,209 @@
+diff --git a/VERSION b/VERSION
+index c77a7de..50ffc5a 100644
+--- a/VERSION
++++ b/VERSION
+@@ -1 +1 @@
+-3.7.14.1
++2.1.1
+diff --git a/configure.ac b/configure.ac
+index 46afeb7..eb69607 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -87,7 +87,7 @@
+ # you don't need (for example BLT) by erasing or commenting out
+ # the corresponding code.
+ #
+-AC_INIT(sqlite, m4_esyscmd([cat VERSION | tr -d '\n']))
++AC_INIT(sqlcipher, 2.1.1)
+
+ dnl Make sure the local VERSION file matches this configure script
+ sqlite_version_sanity_check=`cat $srcdir/VERSION | tr -d '\n'`
+@@ -159,6 +159,8 @@ if test "x${TCLLIBDIR+set}" != "xset" ; then
+ TCLLIBDIR="${TCLLIBDIR}/sqlite3"
+ fi
+
++AC_CHECK_LIB([crypto], [HMAC_Init_ex], ,
++ AC_MSG_ERROR([Library crypto not found. Install openssl!"]))
+
+ #########
+ # Set up an appropriate program prefix
+@@ -698,5 +732,5 @@ AC_CONFIG_HEADERS(config.h)
+ AC_SUBST(BUILD_CFLAGS)
+ AC_OUTPUT([
+ Makefile
+-sqlite3.pc
++sqlcipher.pc
+ ])
+--- a/Makefile.in 2012-03-31 11:10:44.000000000 -0400
++++ b/Makefile.in 2012-03-31 18:02:26.000000000 -0400
+@@ -153,7 +153,7 @@
+ libdir = @libdir@
+ pkgconfigdir = $(libdir)/pkgconfig
+ bindir = @bindir@
+-includedir = @includedir@
++includedir = @includedir@/sqlcipher
+ INSTALL = @INSTALL@
+ LIBTOOL = ./libtool
+ ALLOWRELEASE = @ALLOWRELEASE@
+@@ -489,30 +489,30 @@
+ # This is the default Makefile target. The objects listed here
+ # are what get build when you type just "make" with no arguments.
+ #
+-all: sqlite3.h libsqlite3.la sqlite3$(TEXE) $(HAVE_TCL:1=libtclsqlite3.la)
++all: sqlite3.h libsqlcipher.la sqlcipher$(TEXE) $(HAVE_TCL:1=libtclsqlite3.la)
+
+ Makefile: $(TOP)/Makefile.in
+ ./config.status
+
+-sqlite3.pc: $(TOP)/sqlite3.pc.in
++sqlcipher.pc: $(TOP)/sqlcipher.pc.in
+ ./config.status
+
+-libsqlite3.la: $(LIBOBJ)
++libsqlcipher.la: $(LIBOBJ)
+ $(LTLINK) -o $@ $(LIBOBJ) $(TLIBS) \
+ ${ALLOWRELEASE} -rpath "$(libdir)" -version-info "8:6:8"
+ sed -i "/dependency_libs/s/'.*'/''/" $@
+
+-libtclsqlite3.la: tclsqlite.lo libsqlite3.la
++libtclsqlite3.la: tclsqlite.lo libsqlcipher.la
+ $(LTLINK) -o $@ tclsqlite.lo \
+- libsqlite3.la @TCL_STUB_LIB_SPEC@ \
++ libsqlcipher.la @TCL_STUB_LIB_SPEC@ \
+ -rpath "$(TCLLIBDIR)" \
+ -version-info "8:6:8" \
+ -avoid-version
+ sed -i "/dependency_libs/s/'.*'/''/" $@
+
+-sqlite3$(TEXE): $(TOP)/src/shell.c libsqlite3.la sqlite3.h
++sqlcipher$(TEXE): $(TOP)/src/shell.c libsqlcipher.la sqlite3.h
+ $(LTLINK) $(READLINE_FLAGS) \
+- -o $@ $(TOP)/src/shell.c libsqlite3.la \
++ -o $@ $(TOP)/src/shell.c libsqlcipher.la \
+ $(LIBREADLINE) -rpath "$(libdir)"
+
+ # This target creates a directory named "tsrc" and fills it with
+@@ -790,9 +790,9 @@
+ tclsqlite-stubs.lo: $(TOP)/src/tclsqlite.c $(HDR)
+ $(LTCOMPILE) -DUSE_TCL_STUBS=1 -o $@ -c $(TOP)/src/tclsqlite.c
+
+-tclsqlite3$(TEXE): tclsqlite-shell.lo libsqlite3.la
++tclsqlcipher$(TEXE): tclsqlite-shell.lo libsqlcipher.la
+ $(LTLINK) -o $@ tclsqlite-shell.lo \
+- libsqlite3.la $(LIBTCL)
++ libsqlcipher.la $(LIBTCL)
+
+ # Rules to build opcodes.c and opcodes.h
+ #
+@@ -882,7 +882,7 @@
+ # Rules to build the 'testfixture' application.
+ #
+ # If using the amalgamation, use sqlite3.c directly to build the test
+-# fixture. Otherwise link against libsqlite3.la. (This distinction is
++# fixture. Otherwise link against libsqlcipher.la. (This distinction is
+ # necessary because the test fixture requires non-API symbols which are
+ # hidden when the library is built via the amalgamation).
+ #
+@@ -890,7 +890,7 @@
+ TESTFIXTURE_FLAGS += -DSQLITE_SERVER=1 -DSQLITE_PRIVATE="" -DSQLITE_CORE
+ TESTFIXTURE_FLAGS += -DBUILD_sqlite
+
+-TESTFIXTURE_SRC0 = $(TESTSRC2) libsqlite3.la
++TESTFIXTURE_SRC0 = $(TESTSRC2) libsqlcipher.la
+ TESTFIXTURE_SRC1 = sqlite3.c
+ TESTFIXTURE_SRC = $(TESTSRC) $(TOP)/src/tclsqlite.c $(TESTFIXTURE_SRC$(USE_AMALGAMATION))
+
+@@ -899,13 +899,13 @@
+ -o $@ $(TESTFIXTURE_SRC) $(LIBTCL) $(TLIBS)
+
+
+-fulltest: testfixture$(TEXE) sqlite3$(TEXE)
++fulltest: testfixture$(TEXE) sqlcipher$(TEXE)
+ ./testfixture$(TEXE) $(TOP)/test/all.test
+
+-soaktest: testfixture$(TEXE) sqlite3$(TEXE)
++soaktest: testfixture$(TEXE) sqlcipher$(TEXE)
+ ./testfixture$(TEXE) $(TOP)/test/all.test -soak=1
+
+-test: testfixture$(TEXE) sqlite3$(TEXE)
++test: testfixture$(TEXE) sqlcipher$(TEXE)
+ ./testfixture$(TEXE) $(TOP)/test/veryquick.test
+
+ sqlite3_analyzer.c: sqlite3.c $(TOP)/src/test_stat.c $(TOP)/src/tclsqlite.c $(TOP)/tool/spaceanal.tcl
+@@ -921,18 +921,18 @@
+
+ # Standard install and cleanup targets
+ #
+-lib_install: libsqlite3.la
++lib_install: libsqlcipher.la
+ $(INSTALL) -d $(DESTDIR)$(libdir)
+- $(LTINSTALL) libsqlite3.la $(DESTDIR)$(libdir)
++ $(LTINSTALL) libsqlcipher.la $(DESTDIR)$(libdir)
+
+-install: sqlite3$(BEXE) lib_install sqlite3.h sqlite3.pc ${HAVE_TCL:1=tcl_install}
++install: sqlcipher$(BEXE) lib_install sqlite3.h sqlcipher.pc ${HAVE_TCL:1=tcl_install}
+ $(INSTALL) -d $(DESTDIR)$(bindir)
+- $(LTINSTALL) sqlite3$(BEXE) $(DESTDIR)$(bindir)
++ $(LTINSTALL) sqlcipher$(BEXE) $(DESTDIR)$(bindir)
+ $(INSTALL) -d $(DESTDIR)$(includedir)
+ $(INSTALL) -m 0644 sqlite3.h $(DESTDIR)$(includedir)
+ $(INSTALL) -m 0644 $(TOP)/src/sqlite3ext.h $(DESTDIR)$(includedir)
+ $(INSTALL) -d $(DESTDIR)$(pkgconfigdir)
+- $(INSTALL) -m 0644 sqlite3.pc $(DESTDIR)$(pkgconfigdir)
++ $(INSTALL) -m 0644 sqlcipher.pc $(DESTDIR)$(pkgconfigdir)
+
+ pkgIndex.tcl:
+ echo 'package ifneeded sqlite3 $(RELEASE) [list load $(TCLLIBDIR)/libtclsqlite3.so sqlite3]' > $@
+@@ -943,7 +943,7 @@
+ $(INSTALL) -m 0644 pkgIndex.tcl $(DESTDIR)$(TCLLIBDIR)
+
+ clean:
+- rm -f *.lo *.la *.o sqlite3$(TEXE) libsqlite3.la
++ rm -f *.lo *.la *.o sqlcipher$(TEXE) libsqlcipher.la
+ rm -f sqlite3.h opcodes.*
+ rm -rf .libs .deps
+ rm -f lemon$(BEXE) lempar.c parse.* sqlite*.tar.gz
+@@ -964,7 +966,7 @@ clean:
+ rm -f sqlite-output.vsix
+
+ distclean: clean
+- rm -f config.log config.status libtool Makefile sqlite3.pc
++ rm -f config.log config.status libtool Makefile sqlcipher.pc
+
+ #
+ # Windows section
+diff --git a/sqlite3.pc.in b/sqlite3.pc.in
+deleted file mode 100644
+index c8d0aa9..0000000
+--- a/sqlite3.pc.in
++++ /dev/null
+@@ -1,13 +0,0 @@
+-# Package Information for pkg-config
+-
+-prefix=@prefix@
+-exec_prefix=@exec_prefix@
+-libdir=@libdir@
+-includedir=@includedir@
+-
+-Name: SQLite
+-Description: SQL database engine
+-Version: @RELEASE@
+-Libs: -L${libdir} -lsqlite3
+-Libs.private: @LIBS@
+-Cflags: -I${includedir}
+--- /dev/null 2012-03-31 10:49:42.330855572 -0400
++++ b/sqlcipher.pc.in 2012-03-31 18:07:59.000000000 -0400
+@@ -0,0 +1,13 @@
++# Package Information for pkg-config
++
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: SQLCipher
++Description: encrypted SQL database engine
++Version: @RELEASE@
++Libs: -L${libdir} -lsqlcipher
++Libs.private: @LIBS@
++Cflags: -I${includedir}
diff --git a/debian/patches/20-hurd-locking-style.patch b/debian/patches/20-hurd-locking-style.patch
new file mode 100644
index 0000000..cfb3fde
--- /dev/null
+++ b/debian/patches/20-hurd-locking-style.patch
@@ -0,0 +1,38 @@
+--- a/src/os_unix.c
++++ b/src/os_unix.c
+@@ -131,7 +131,7 @@
+ #endif
+
+
+-#if SQLITE_ENABLE_LOCKING_STYLE
++#if SQLITE_ENABLE_LOCKING_STYLE || defined(__GNU__)
+ # include <sys/ioctl.h>
+ # if OS_VXWORKS
+ # include <semaphore.h>
+@@ -2124,7 +2124,7 @@
+ ** Omit this section if SQLITE_ENABLE_LOCKING_STYLE is turned off or if
+ ** compiling for VXWORKS.
+ */
+-#if SQLITE_ENABLE_LOCKING_STYLE && !OS_VXWORKS
++#if (SQLITE_ENABLE_LOCKING_STYLE && !OS_VXWORKS) || defined(__GNU__)
+
+ /*
+ ** Retry flock() calls that fail with EINTR
+@@ -4531,7 +4531,7 @@
+ dotlockCheckReservedLock /* xCheckReservedLock method */
+ )
+
+-#if SQLITE_ENABLE_LOCKING_STYLE && !OS_VXWORKS
++#if (SQLITE_ENABLE_LOCKING_STYLE && !OS_VXWORKS) || defined(__GNU__)
+ IOMETHODS(
+ flockIoFinder, /* Finder function name */
+ flockIoMethods, /* sqlite3_io_methods object name */
+@@ -6969,6 +6969,8 @@
+ static sqlite3_vfs aVfs[] = {
+ #if SQLITE_ENABLE_LOCKING_STYLE && (OS_VXWORKS || defined(__APPLE__))
+ UNIXVFS("unix", autolockIoFinder ),
++#elif defined(__GNU__)
++ UNIXVFS("unix", flockIoFinder ),
+ #else
+ UNIXVFS("unix", posixIoFinder ),
+ #endif
diff --git a/debian/patches/31-increase_SQLITE_MAX_DEFAULT_PAGE_SIZE_to_32k.patch b/debian/patches/31-increase_SQLITE_MAX_DEFAULT_PAGE_SIZE_to_32k.patch
new file mode 100644
index 0000000..bd0360e
--- /dev/null
+++ b/debian/patches/31-increase_SQLITE_MAX_DEFAULT_PAGE_SIZE_to_32k.patch
@@ -0,0 +1,23 @@
+Description: increase the maximum possible value of the page size
+ Firefox/Iceweasel uses a page size of 32k, but sqlite won't allow it
+ because the maximum it allows by default is 8k (through the
+ SQLITE_MAX_DEFAULT_PAGE_SIZE define). This patch increases this limit.
+ .
+Author: Laszlo Boszormenyi (GCS) <gcs@debian.hu>
+Bug-Debian: http://bugs.debian.org/672573
+
+---
+Forwarded: <not-needed>
+Last-Update: <2012-05-16>
+
+--- sqlite3-3.7.12.orig/src/sqliteLimit.h
++++ sqlite3-3.7.12/src/sqliteLimit.h
+@@ -169,7 +169,7 @@
+ ** SQLite will choose on its own.
+ */
+ #ifndef SQLITE_MAX_DEFAULT_PAGE_SIZE
+-# define SQLITE_MAX_DEFAULT_PAGE_SIZE 8192
++# define SQLITE_MAX_DEFAULT_PAGE_SIZE 32768
+ #endif
+ #if SQLITE_MAX_DEFAULT_PAGE_SIZE>SQLITE_MAX_PAGE_SIZE
+ # undef SQLITE_MAX_DEFAULT_PAGE_SIZE
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..1a059d0
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,7 @@
+10-520466-libsqlite3-depends-on-libdl.patch
+10-520478-squash-bad-deps.patch
+10-665363-disable-malloc-usable-size.patch
+10-sqlcipher-man-page.patch
+20-change-name-to-sqlcipher.patch
+20-hurd-locking-style.patch
+31-increase_SQLITE_MAX_DEFAULT_PAGE_SIZE_to_32k.patch