summaryrefslogtreecommitdiff
path: root/debian/patches/10-520478-squash-bad-deps.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/10-520478-squash-bad-deps.patch')
-rw-r--r--debian/patches/10-520478-squash-bad-deps.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/debian/patches/10-520478-squash-bad-deps.patch b/debian/patches/10-520478-squash-bad-deps.patch
new file mode 100644
index 0000000..62262d3
--- /dev/null
+++ b/debian/patches/10-520478-squash-bad-deps.patch
@@ -0,0 +1,25 @@
+--- sqlcipher-2.2.1.orig/Makefile.in
++++ sqlcipher-2.2.1/Makefile.in
+@@ -521,18 +521,20 @@ sqlcipher.pc: $(TOP)/sqlcipher.pc.in
+ libsqlcipher.la: $(LIBOBJ)
+ $(LTLINK) -o $@ $(LIBOBJ) $(TLIBS) \
+ ${ALLOWRELEASE} -rpath "$(libdir)" -version-info "8:6:8"
++ sed -i "/dependency_libs/s/'.*'/''/" $@
+
+ libtclsqlite3.la: tclsqlite.lo libsqlcipher.la
+ $(LTLINK) -o $@ tclsqlite.lo \
+- libsqlcipher.la @TCL_STUB_LIB_SPEC@ $(TLIBS) \
++ libsqlcipher.la @TCL_STUB_LIB_SPEC@ \
+ -rpath "$(TCLLIBDIR)" \
+ -version-info "8:6:8" \
+ -avoid-version
++ sed -i "/dependency_libs/s/'.*'/''/" $@
+
+ sqlcipher$(TEXE): $(TOP)/src/shell.c libsqlcipher.la sqlite3.h
+ $(LTLINK) $(READLINE_FLAGS) \
+ -o $@ $(TOP)/src/shell.c libsqlcipher.la \
+- $(LIBREADLINE) $(TLIBS) -rpath "$(libdir)"
++ $(LIBREADLINE) -rpath "$(libdir)"
+
+ mptester$(EXE): sqlite3.c $(TOP)/mptest/mptest.c
+ $(LTLINK) -o $@ -I. $(TOP)/mptest/mptest.c sqlite3.c \