summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index b86c7b4c..d7c1eeaf 100644
--- a/setup.py
+++ b/setup.py
@@ -28,7 +28,8 @@ from setuptools.command.develop import develop as _cmd_develop
isset = lambda var: os.environ.get(var, None)
-if isset('VIRTUAL_ENV') or isset('LEAP_SKIP_INIT'):
+skip = ['VIRTUAL_ENV', 'LEAP_SKIP_INIT', 'READTHEDOCS']
+if len(filter(isset, skip)):
data_files = None
else:
# XXX this should go only for linux/mac