summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py23
1 files changed, 18 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 2a6c9e74..340ebcd2 100644
--- a/setup.py
+++ b/setup.py
@@ -15,6 +15,7 @@
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
import os
from setuptools import (
setup,
@@ -26,7 +27,6 @@ install_requirements = [
'configparser',
'couchdb',
'leap.common',
- 'oauth',
'pysqlcipher',
'python-gnupg',
'simplejson',
@@ -53,7 +53,8 @@ install_requirements = [
dependency_links = [
#'git+git://git.futeisha.org/pysqlcipher.git@develop#egg=pysqlcipher',
#'git+ssh://code.leap.se/leap_pycommon.git@develop#egg=leap.common',
- 'http://twistedmatrix.com/Releases/Twisted/13.0/Twisted-13.0.0.tar.bz2#egg=twisted-13.0.0'
+ 'http://twistedmatrix.com/Releases/Twisted/13.0/Twisted-13.0.0.tar.bz2'
+ '#egg=twisted-13.0.0' # break the string to adhere to pep8 style.
]
@@ -63,17 +64,19 @@ tests_requirements = [
'testscenarios',
]
+
if os.environ.get('VIRTUAL_ENV', None):
data_files = None
else:
# XXX this should go only for linux/mac
data_files = [("/etc/init.d/", ["pkg/soledad"])]
+
setup(
name='leap.soledad',
# TODO: change version according to decisions regarding soledad versus
# leap client versions.
- version='0.0.2-dev',
+ version='0.1.0-dev',
url='https://leap.se/',
license='GPLv3+',
description='Synchronization of locally encrypted data among devices.',
@@ -85,11 +88,21 @@ setup(
"LEAP client, an API for data storage and sync."
),
namespace_packages=["leap"],
- packages=find_packages('src', exclude=['leap.soledad.tests']),
+ # For now, we do not exclude tests because of the circular dependency
+ # between leap.common and leap.soledad.
+ #packages=find_packages('src', exclude=['leap.soledad.tests']),
+ packages=find_packages('src'),
package_dir={'': 'src'},
test_suite='leap.soledad.tests',
install_requires=install_requirements,
tests_require=tests_requirements,
dependency_links=dependency_links,
- data_files = data_files
+ data_files=data_files,
+ # the following files are only used for testing, and might be removed if
+ # we manage or decide to not install tests in the future.
+ package_data={
+ 'leap.soledad.tests.u1db_tests.testing-certs': [
+ '*.pem', '*.cert', '*.key'
+ ]
+ }
)