summaryrefslogtreecommitdiff
path: root/scripts
diff options
context:
space:
mode:
Diffstat (limited to 'scripts')
-rw-r--r--scripts/docker/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/scripts/docker/Makefile b/scripts/docker/Makefile
index 6f30a341..6ad4cced 100644
--- a/scripts/docker/Makefile
+++ b/scripts/docker/Makefile
@@ -89,8 +89,15 @@ run-tox:
# Performance tests and graphic generation #
############################################
-run-perf-test:
- helper/run-test.sh perf
+run-perf:
+ docker run -d --name couchdb couchdb
+ docker run -t -i \
+ --memory="$(MEMORY)" \
+ --env="SOLEDAD_REMOTE=$(SOLEDAD_REMOTE)" \
+ --env="SOLEDAD_BRANCH=$(SOLEDAD_BRANCH)" \
+ --link couchdb \
+ $(IMAGE_NAME) \
+ /usr/local/soledad/run-tox-perf.sh
run-client-perf:
@if [ -z "$(CONTAINER_ID_FILE)" ]; then \