summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/__init__.py6
-rw-r--r--debian/changelog69
-rw-r--r--debian/clean1
-rw-r--r--debian/compat1
-rw-r--r--debian/control48
-rw-r--r--debian/copyright16
-rw-r--r--debian/pydist-overrides5
-rwxr-xr-xdebian/rules24
-rw-r--r--debian/soledad-client.pyremove1
-rw-r--r--debian/soledad-common.pyremove1
-rw-r--r--debian/soledad-server.init79
-rw-r--r--debian/soledad-server.pyremove1
-rw-r--r--debian/source/format1
13 files changed, 253 insertions, 0 deletions
diff --git a/debian/__init__.py b/debian/__init__.py
new file mode 100644
index 00000000..f48ad105
--- /dev/null
+++ b/debian/__init__.py
@@ -0,0 +1,6 @@
+# See http://peak.telecommunity.com/DevCenter/setuptools#namespace-packages
+try:
+ __import__('pkg_resources').declare_namespace(__name__)
+except ImportError:
+ from pkgutil import extend_path
+ __path__ = extend_path(__path__, __name__)
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 00000000..7745afa9
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,69 @@
+soledad (0.3.1.1) unstable; urgency=low
+
+ [ Ben Carrillo ]
+ * Fix installation of __init__ file on namespace module.
+ * Add LICENSE.
+
+ -- Micah Anderson <micah@debian.org> Mon, 26 Aug 2013 18:21:09 +0200
+
+soledad (0.3.1) unstable; urgency=low
+
+ [ Ben Carrillo ]
+ * Update to latest release.
+ * Fix pydist-overrides.
+
+ [ Micah Anderson ]
+ * Stop setup.py from installing initscript so packaging can
+
+ -- Micah Anderson <micah@debian.org> Mon, 26 Aug 2013 18:21:09 +0200
+
+soledad (0.3.1~pre) unstable; urgency=low
+
+ * Upgrade to latest code in develop
+ * Setup additional binary package
+ * Fix pydist-overrides for new package name
+
+ -- Micah Anderson <micah@debian.org> Thu, 22 Aug 2013 14:57:54 -0400
+
+soledad (0.3.0.3) unstable; urgency=low
+
+ * Fixed missing epoch on python-twisted-conch
+
+ -- Micah Anderson <micah@debian.org> Thu, 15 Aug 2013 13:16:54 -0400
+
+soledad (0.3.0.2) unstable; urgency=low
+
+ * Pin twisted version in Depends to get 13 or greater
+
+ -- Micah Anderson <micah@debian.org> Thu, 15 Aug 2013 11:31:57 -0400
+
+soledad (0.3.0.1) unstable; urgency=low
+
+ * Update initscript to require that START=yes is set
+ in /etc/default/soledad
+
+ -- Micah Anderson <micah@debian.org> Wed, 14 Aug 2013 11:18:01 -0400
+
+soledad (0.3.0) unstable; urgency=low
+
+ * Update to 0.3.0
+
+ -- Micah Anderson <micah@debian.org> Tue, 13 Aug 2013 14:42:06 -0400
+
+soledad (0.2.3) unstable; urgency=low
+
+ * Upgrade to new release
+
+ -- Micah Anderson <micah@debian.org> Mon, 29 Jul 2013 20:47:19 -0400
+
+soledad (0.2.2.1) unstable; urgency=low
+
+ * Fix installation of initscript
+
+ -- Micah Anderson <micah@debian.org> Thu, 18 Jul 2013 15:54:51 -0400
+
+soledad (0.2.2) unstable; urgency=low
+
+ * Initial debian package
+
+ -- Micah Anderson <micah@debian.org> Thu, 30 May 2013 15:11:11 -0400
diff --git a/debian/clean b/debian/clean
new file mode 100644
index 00000000..c9349d36
--- /dev/null
+++ b/debian/clean
@@ -0,0 +1 @@
+src/leap.soledad.egg-info/*
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 00000000..ec635144
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 00000000..d4cf04db
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,48 @@
+Source: soledad
+Section: python
+Priority: optional
+Maintainer: Micah Anderson <micah@debian.org>
+Build-Depends: python-setuptools (>= 0.6b3), python-all (>= 2.6.6-3), debhelper (>= 9)
+Standards-Version: 3.9.4
+
+Package: soledad-server
+Architecture: all
+Depends: ${misc:Depends}, ${python:Depends}, python-configparser, python-couchdb,
+ python-simplejson, python-oauth, python-u1db, python-routes, python-openssl,
+ soledad-common (>= 0.3.0-1),
+ python-six, python-twisted (>= 13.0.0-1~bpo70+1), python-twisted-bin (>= 13.0.0-1~bpo70+1),
+ python-twisted-conch (>= 1:13.0.0-1~bpo70+1), python-twisted-core (>= 13.0.0-1~bpo70+1),
+ python-twisted-lore (>= 13.0.0-1~bpo70+1), python-twisted-mail (>= 13.0.0-1~bpo70+1),
+ python-twisted-names (>= 13.0.0-1~bpo70+1), python-twisted-news (>= 13.0.0-1~bpo70+1),
+ python-twisted-runner (>= 13.0.0-1~bpo70+1), python-twisted-words (>= 13.0.0-1~bpo70+1),
+ python-twisted-web (>= 13.0.0-1~bpo70+1)
+Description: Synchronization of locally encrypted data among devices.
+ Soledad is the part of LEAP that allows application data to be securely
+ shared among devices. It provides, to other parts of the LEAP client, an
+ API for data storage and sync.
+ .
+ This package contains the server components.
+
+Package: soledad-common
+Architecture: all
+Depends: ${misc:Depends}, ${python:Depends}, python-simplejson, python-oauth, python-u1db,
+ python-six
+Description: Synchronization of locally encrypted data among devices.
+ Soledad is the part of LEAP that allows application data to be securely
+ shared among devices. It provides, to other parts of the LEAP client, an
+ API for data storage and sync.
+ .
+ This package contains the common soledad libraries. For the server, see the
+ soledad-server package
+
+Package: soledad-client
+Architecture: all
+Depends: ${misc:Depends}, ${python:Depends}, python-sqlcipher, python-pysqlite1.1,
+ python-simplejson, python-oauth, python-u1db, python-scrypt,
+ python-xdg, python-pycryptopp, soledad-common
+Description: Synchronization of locally encrypted data among devices.
+ Soledad is the part of LEAP that allows application data to be securely
+ shared among devices. It provides, to other parts of the LEAP client, an
+ API for data storage and sync.
+ .
+ This package contains the soledad client.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 00000000..d811209b
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,16 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: soledad
+Upstream-Contact: info@leap.se
+Source: <git://code.leap.se/soledad/>
+
+Files: *
+Copyright: Copyright (C) 2013 LEAP
+License: GPL-3+
+
+Files: debian/*
+Copyright: Copyright 2013 Micah Anderson <micah@leap.se>
+License: GPL-3+
+
+License: GPL-3+
+ On Debian systems, the complete text of the GNU General
+ Public License can be found in `/usr/share/common-licenses/GPL'.
diff --git a/debian/pydist-overrides b/debian/pydist-overrides
new file mode 100644
index 00000000..c1b27213
--- /dev/null
+++ b/debian/pydist-overrides
@@ -0,0 +1,5 @@
+pysqlcipher python-sqlcipher
+PyOpenSSL python-openssl
+leap.soledad.common soledad-common
+leap.soledad.server soledad-server
+leap.soledad.client soledad-client
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..a5f1aa27
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,24 @@
+#!/usr/bin/make -f
+
+# Uncomment this to turn on verbose mode.
+#DH_VERBOSE=1
+
+%:
+ dh $@ --with python2 --namespace=leap.soledad
+
+override_dh_auto_clean:
+ cd client && python setup.py clean -a
+ cd common && python setup.py clean -a
+ cd server && python setup.py clean -a
+
+override_dh_auto_install:
+ cd common && python setup.py install --root=../debian/soledad-common
+ cd server && python setup.py install --root=../debian/soledad-server
+ cd client && python setup.py install --root=../debian/soledad-client
+
+override_dh_install:
+ # leap.soledad provides the leap.soledad namespace __init__.py
+ for pv in $(shell pyversions -vr debian/control); do \
+ cp common/src/leap/__init__.py debian/soledad-common/usr/local/lib/python$$pv/*-packages/leap/; \
+ cp common/src/leap/__init__.py debian/soledad-common/usr/local/lib/python$$pv/*-packages/leap/soledad/; \
+ done
diff --git a/debian/soledad-client.pyremove b/debian/soledad-client.pyremove
new file mode 100644
index 00000000..936da7d3
--- /dev/null
+++ b/debian/soledad-client.pyremove
@@ -0,0 +1 @@
+*.pth
diff --git a/debian/soledad-common.pyremove b/debian/soledad-common.pyremove
new file mode 100644
index 00000000..936da7d3
--- /dev/null
+++ b/debian/soledad-common.pyremove
@@ -0,0 +1 @@
+*.pth
diff --git a/debian/soledad-server.init b/debian/soledad-server.init
new file mode 100644
index 00000000..1c3f1f71
--- /dev/null
+++ b/debian/soledad-server.init
@@ -0,0 +1,79 @@
+#!/bin/sh
+### BEGIN INIT INFO
+# Provides: soledad
+# Required-Start: $network $named $remote_fs $syslog $time
+# Required-Stop: $network $named $remote_fs $syslog
+# Default-Start: 2 3 4 5
+# Default-Stop: 0 1 6
+# Short-Description: Start soledad daemon at boot time
+# Description: Synchronization of locally encrypted data among devices
+### END INIT INFO
+
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+PIDFILE=/var/run/soledad.pid
+RUNDIR=/var/lib/soledad/
+OBJ=leap.soledad_server.application
+LOGFILE=/var/log/soledad.log
+HTTPS_PORT=2424
+CERT_PATH=/etc/leap/soledad-server.pem
+PRIVKEY_PATH=/etc/leap/soledad-server.pem
+TWISTD_PATH=/usr/bin/twistd
+HOME=/var/lib/soledad/
+
+[ -r /etc/default/soledad ] && . /etc/default/soledad
+
+test -r /etc/leap/ || exit 0
+
+. /lib/lsb/init-functions
+
+is_true() {
+ if [ "x$1" = "xtrue" -o "x$1" = "xyes" -o "x$1" = "x0" ] ; then
+ return 0
+ else
+ return 1
+ fi
+}
+
+case "$1" in
+ start)
+ if is_true "$START" ; then
+ echo -n "Starting soledad: twistd"
+ start-stop-daemon --start --quiet --exec $TWISTD_PATH -- \
+ --pidfile=$PIDFILE \
+ --logfile=$LOGFILE \
+ web \
+ --wsgi=$OBJ \
+ --port=ssl:$HTTPS_PORT:privateKey=$PRIVKEY_PATH:certKey=$CERT_PATH
+ echo "."
+ else
+ echo ""
+ echo "soledad-server is not configured to start, please edit /etc/default/soledad to enable"
+ fi
+ ;;
+ stop)
+ echo -n "Stopping soledad: twistd"
+ start-stop-daemon --stop --quiet \
+ --pidfile $PIDFILE
+ echo "."
+ ;;
+
+ restart)
+ $0 stop
+ $0 start
+ ;;
+
+ force-reload)
+ $0 restart
+ ;;
+
+ status)
+ status_of_proc -p $PIDFILE $TWISTD_PATH soledad && exit 0 || exit $?
+ ;;
+
+ *)
+ echo "Usage: /etc/init.d/soledad {start|stop|restart|force-reload|status}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/debian/soledad-server.pyremove b/debian/soledad-server.pyremove
new file mode 100644
index 00000000..936da7d3
--- /dev/null
+++ b/debian/soledad-server.pyremove
@@ -0,0 +1 @@
+*.pth
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 00000000..89ae9db8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)