summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 10 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index abe080c6..c66ed435 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,10 @@
#!/usr/bin/make -f
+# Uncomment this to turn on verbose mode.
+#DH_VERBOSE=1
+
%:
- dh $@ --with python2
+ dh $@ --with python2 --namespace=leap.soledad
override_dh_auto_clean:
cd client && python setup.py clean -a
@@ -13,5 +16,9 @@ override_dh_auto_install:
cd common && python setup.py install --root=../debian/soledad-common
cd server && LEAP_SKIP_INIT=1 python setup.py install --root=../debian/soledad-server
-
-
+override_dh_install:
+ # leap.soledad provides the leap.soledad namespace __init__.py
+ for pv in $(shell pyversions -vr debian/control); do \
+ cp common/src/leap/__init__.py debian/soledad-common/usr/local/lib/python$$pv/*-packages/leap/; \
+ cp common/src/leap/__init__.py debian/soledad-common/usr/local/lib/python$$pv/*-packages/leap/soledad/; \
+ done