summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 5 insertions, 7 deletions
diff --git a/debian/rules b/debian/rules
index 65863e7a..94e917c0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,11 +6,6 @@
%:
dh $@ --with systemd --with python2 --namespace=leap.soledad
-override_dh_auto_clean:
- cd client && python setup.py clean -a
- cd common && python setup.py clean -a
- cd server && python setup.py clean -a
-
override_dh_auto_install:
cd client && python setup.py install --root=../debian/soledad-client
cd common && python setup.py install --root=../debian/soledad-common
@@ -25,6 +20,9 @@ override_dh_install:
dh_install
override_dh_auto_clean:
- dh_auto_clean
+ cd client && python setup.py clean -a
+ cd common && python setup.py clean -a
+ cd server && python setup.py clean -a
find . -name "*.pyc" -delete
- find . -name ".tox" -exec rm -rf {} \;
+ rm -rf testing/.tox
+ dh_auto_clean