summaryrefslogtreecommitdiff
path: root/common
diff options
context:
space:
mode:
Diffstat (limited to 'common')
-rw-r--r--common/MANIFEST.in4
-rw-r--r--common/setup.py5
-rw-r--r--common/src/leap/soledad/common/couch.py8
3 files changed, 10 insertions, 7 deletions
diff --git a/common/MANIFEST.in b/common/MANIFEST.in
index 7f6148ef..a26a12a6 100644
--- a/common/MANIFEST.in
+++ b/common/MANIFEST.in
@@ -2,3 +2,7 @@ include pkg/*
include versioneer.py
include LICENSE
include CHANGELOG
+
+# What do we want the ddocs folder in the source package for? -- kali
+# it should be enough with having the compiled stuff.
+recursive-include src/leap/soledad/common/ddocs *
diff --git a/common/setup.py b/common/setup.py
index 6ee166ef..365006b2 100644
--- a/common/setup.py
+++ b/common/setup.py
@@ -155,6 +155,11 @@ def build_ddocs_py(basedir=None, with_src=True):
dest_prefix = join(basedir, *dest_common_path)
ddocs_prefix = join(prefix, 'ddocs')
+
+ if not isdir(ddocs_prefix):
+ print "No ddocs/ folder, bailing out..."
+ return
+
ddocs = {}
# design docs are represented by subdirectories of `ddocs_prefix`
diff --git a/common/src/leap/soledad/common/couch.py b/common/src/leap/soledad/common/couch.py
index 5658f4ce..b38b5b96 100644
--- a/common/src/leap/soledad/common/couch.py
+++ b/common/src/leap/soledad/common/couch.py
@@ -1529,20 +1529,14 @@ class CouchServerState(ServerState):
Inteface of the WSGI server with the CouchDB backend.
"""
- def __init__(self, couch_url, shared_db_name, tokens_db_name):
+ def __init__(self, couch_url):
"""
Initialize the couch server state.
:param couch_url: The URL for the couch database.
:type couch_url: str
- :param shared_db_name: The name of the shared database.
- :type shared_db_name: str
- :param tokens_db_name: The name of the tokens database.
- :type tokens_db_name: str
"""
self._couch_url = couch_url
- self._shared_db_name = shared_db_name
- self._tokens_db_name = tokens_db_name
def open_database(self, dbname):
"""