summaryrefslogtreecommitdiff
path: root/changes
diff options
context:
space:
mode:
Diffstat (limited to 'changes')
-rw-r--r--changes/bug_fix-deps1
-rw-r--r--changes/bug_fix-pip-install1
-rw-r--r--changes/feature_add-action-validation1
-rw-r--r--changes/feature_add-mac-authentication1
-rw-r--r--changes/feature_add-sqlcipher-api3
-rw-r--r--changes/feature_add-status-to-initscript1
-rw-r--r--changes/feature_blank-server1
-rw-r--r--changes/feature_change-symmetric-encryption-method-to-aes-256-ctr1
-rw-r--r--changes/feature_encode-all-u1db-data-in-couch-backend1
-rw-r--r--changes/feature_encrypt-storage-key-with-kdf6
10 files changed, 0 insertions, 17 deletions
diff --git a/changes/bug_fix-deps b/changes/bug_fix-deps
deleted file mode 100644
index 415386f8..00000000
--- a/changes/bug_fix-deps
+++ /dev/null
@@ -1 +0,0 @@
- o Fix bad dependencies in setup.py.
diff --git a/changes/bug_fix-pip-install b/changes/bug_fix-pip-install
deleted file mode 100644
index fcb58295..00000000
--- a/changes/bug_fix-pip-install
+++ /dev/null
@@ -1 +0,0 @@
- o Fix broken pip install
diff --git a/changes/feature_add-action-validation b/changes/feature_add-action-validation
deleted file mode 100644
index 57d5b90c..00000000
--- a/changes/feature_add-action-validation
+++ /dev/null
@@ -1 +0,0 @@
- o Add validation and authorization of actions upon interaction with server.
diff --git a/changes/feature_add-mac-authentication b/changes/feature_add-mac-authentication
deleted file mode 100644
index ce5a4789..00000000
--- a/changes/feature_add-mac-authentication
+++ /dev/null
@@ -1 +0,0 @@
- o Add MAC authentication to encrypted representation of documents.
diff --git a/changes/feature_add-sqlcipher-api b/changes/feature_add-sqlcipher-api
deleted file mode 100644
index 94c5aa57..00000000
--- a/changes/feature_add-sqlcipher-api
+++ /dev/null
@@ -1,3 +0,0 @@
- o Add SQLCipher API to SQLCipher backend (allow for use of raw keys, add
- better encrypted db assertion, add cipher, kdf_iter, cipher_page_size and
- rekey PRAGMAS).
diff --git a/changes/feature_add-status-to-initscript b/changes/feature_add-status-to-initscript
deleted file mode 100644
index ff264091..00000000
--- a/changes/feature_add-status-to-initscript
+++ /dev/null
@@ -1 +0,0 @@
- o Add a `status` option to Soledad init script.
diff --git a/changes/feature_blank-server b/changes/feature_blank-server
deleted file mode 100644
index 6e68c992..00000000
--- a/changes/feature_blank-server
+++ /dev/null
@@ -1 +0,0 @@
- o Allow to initialize soledad with a blank server
diff --git a/changes/feature_change-symmetric-encryption-method-to-aes-256-ctr b/changes/feature_change-symmetric-encryption-method-to-aes-256-ctr
deleted file mode 100644
index 8c44436a..00000000
--- a/changes/feature_change-symmetric-encryption-method-to-aes-256-ctr
+++ /dev/null
@@ -1 +0,0 @@
- o Change symmetric encryption method to AES-256 CTR mode.
diff --git a/changes/feature_encode-all-u1db-data-in-couch-backend b/changes/feature_encode-all-u1db-data-in-couch-backend
deleted file mode 100644
index 03660557..00000000
--- a/changes/feature_encode-all-u1db-data-in-couch-backend
+++ /dev/null
@@ -1 +0,0 @@
- o b64 encode all U1DB data in couch backend to avoid utf8 encoding problems.
diff --git a/changes/feature_encrypt-storage-key-with-kdf b/changes/feature_encrypt-storage-key-with-kdf
deleted file mode 100644
index f3ccf401..00000000
--- a/changes/feature_encrypt-storage-key-with-kdf
+++ /dev/null
@@ -1,6 +0,0 @@
- o Change the local storage of the storage secret:
- * Use scrypt to derive a key for the encryption of the storage secret.
- * Store secret in a file called 'soledad.json' by default.
- * Also store the salt and encryption details, as defined in the spec.
- * This change is not backwards compatible (i.e. all previously stored
- secrets are incompatible with this new encryption and storage scheme).