summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README.rst21
-rw-r--r--client/setup.py5
-rw-r--r--common/pkg/requirements-testing.pip4
-rw-r--r--common/pkg/requirements.pip1
-rw-r--r--common/setup.py5
-rw-r--r--server/setup.py5
6 files changed, 32 insertions, 9 deletions
diff --git a/README.rst b/README.rst
index c2a33234..8fa966c2 100644
--- a/README.rst
+++ b/README.rst
@@ -2,11 +2,28 @@ Soledad
==================================================================
*Synchronization Of Locally Encrypted Data Among Devices*
-.. image:: https://pypip.in/v/leap.soledad/badge.png
- :target: https://crate.io/packages/leap.soledad
+Soledad is the part of LEAP that allows application data to be
+securely shared among devices. It provides, to other parts of the
+LEAP project, an API for data storage and sync.
This software is under development.
+There are currently three python packages maintained under this
+repository:
+
+**leap.soledad.common** common pieces.
+.. image:: https://pypip.in/v/leap.soledad.common/badge.png
+ :target: https://crate.io/packages/leap.soledad.common
+
+**leap.soledad.client** where the soledad client lives.
+.. image:: https://pypip.in/v/leap.soledad.client/badge.png
+ :target: https://crate.io/packages/leap.soledad.client
+
+**leap.soledad.server** oh surprise! bits needed for the soledad server.
+.. image:: https://pypip.in/v/leap.soledad.server/badge.png
+ :target: https://crate.io/packages/leap.soledad.server
+
+
Library dependencies
--------------------
* ``libsqlite3-dev``
diff --git a/client/setup.py b/client/setup.py
index 142922a4..4f62809f 100644
--- a/client/setup.py
+++ b/client/setup.py
@@ -51,13 +51,14 @@ setup(
cmdclass=versioneer.get_cmdclass(),
url='https://leap.se/',
license='GPLv3+',
- description='Synchronization of locally encrypted data among devices.',
+ description='Synchronization of locally encrypted data among devices '
+ '(client components).',
author='The LEAP Encryption Access Project',
author_email='info@leap.se',
long_description=(
"Soledad is the part of LEAP that allows application data to be "
"securely shared among devices. It provides, to other parts of the "
- "LEAP client, an API for data storage and sync."
+ "LEAP project, an API for data storage and sync."
),
classifiers=trove_classifiers,
namespace_packages=["leap", "leap.soledad"],
diff --git a/common/pkg/requirements-testing.pip b/common/pkg/requirements-testing.pip
index 18040ea1..6ff52ff9 100644
--- a/common/pkg/requirements-testing.pip
+++ b/common/pkg/requirements-testing.pip
@@ -4,3 +4,7 @@ testscenarios
leap.common
leap.soledad.server
leap.soledad.client
+
+# Under quarantine...
+# I've been able to run all tests with six==1.3 -- kali
+# six==1.1.0 # some tests are incompatible with newer versions of six.
diff --git a/common/pkg/requirements.pip b/common/pkg/requirements.pip
index 8fd57c3f..5787114e 100644
--- a/common/pkg/requirements.pip
+++ b/common/pkg/requirements.pip
@@ -1,6 +1,5 @@
simplejson
u1db
-six==1.1.0 # some tests are incompatible with newer versions of six.
#this is not strictly needed by us, but we need it
#until u1db adds it to its release as a dep.
diff --git a/common/setup.py b/common/setup.py
index 22159a2a..0a2f138f 100644
--- a/common/setup.py
+++ b/common/setup.py
@@ -50,13 +50,14 @@ setup(
cmdclass=versioneer.get_cmdclass(),
url='https://leap.se/',
license='GPLv3+',
- description='Synchronization of locally encrypted data among devices.',
+ description='Synchronization of locally encrypted data among devices '
+ '(common files).',
author='The LEAP Encryption Access Project',
author_email='info@leap.se',
long_description=(
"Soledad is the part of LEAP that allows application data to be "
"securely shared among devices. It provides, to other parts of the "
- "LEAP client, an API for data storage and sync."
+ "LEAP project, an API for data storage and sync."
),
classifiers=trove_classifiers,
namespace_packages=["leap", "leap.soledad"],
diff --git a/server/setup.py b/server/setup.py
index 7dcd127c..e5c36278 100644
--- a/server/setup.py
+++ b/server/setup.py
@@ -57,13 +57,14 @@ setup(
cmdclass=versioneer.get_cmdclass(),
url='https://leap.se/',
license='GPLv3+',
- description='Synchronization of locally encrypted data among devices.',
+ description='Synchronization of locally encrypted data among devices '
+ '(server components)',
author='The LEAP Encryption Access Project',
author_email='info@leap.se',
long_description=(
"Soledad is the part of LEAP that allows application data to be "
"securely shared among devices. It provides, to other parts of the "
- "LEAP client, an API for data storage and sync."
+ "LEAP project, an API for data storage and sync."
),
classifiers=trove_classifiers,
namespace_packages=["leap", "leap.soledad"],