summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--client/pkg/requirements.pip4
-rw-r--r--client/src/leap/soledad/client/_version.py2
-rw-r--r--common/src/leap/soledad/common/_version.py2
-rw-r--r--debian/changelog11
-rw-r--r--debian/control6
-rw-r--r--server/pkg/requirements.pip10
-rw-r--r--server/src/leap/soledad/server/_version.py2
7 files changed, 17 insertions, 20 deletions
diff --git a/client/pkg/requirements.pip b/client/pkg/requirements.pip
index 5519d2f6..ec7d7699 100644
--- a/client/pkg/requirements.pip
+++ b/client/pkg/requirements.pip
@@ -1,6 +1,8 @@
#pysqlcipher>2.6.3
u1db
scrypt
-cchardet
+# cchardet not packaged, we need python-chardet from the
+# repos instead.
+chardet
zope.proxy
oauth
diff --git a/client/src/leap/soledad/client/_version.py b/client/src/leap/soledad/client/_version.py
index a72d4aa7..3c208ef4 100644
--- a/client/src/leap/soledad/client/_version.py
+++ b/client/src/leap/soledad/client/_version.py
@@ -6,7 +6,7 @@
# of this file.
version_version = '0.8.0'
-full_revisionid = '259d37b430564c03f27d0835e23769473034df6f'
+full_revisionid = 'f25d2e4fa3b51575f4989ac74eade7213966ce4b'
def get_versions(default={}, verbose=False):
diff --git a/common/src/leap/soledad/common/_version.py b/common/src/leap/soledad/common/_version.py
index a72d4aa7..3c208ef4 100644
--- a/common/src/leap/soledad/common/_version.py
+++ b/common/src/leap/soledad/common/_version.py
@@ -6,7 +6,7 @@
# of this file.
version_version = '0.8.0'
-full_revisionid = '259d37b430564c03f27d0835e23769473034df6f'
+full_revisionid = 'f25d2e4fa3b51575f4989ac74eade7213966ce4b'
def get_versions(default={}, verbose=False):
diff --git a/debian/changelog b/debian/changelog
index 99d1b94f..a164bda0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,15 +1,14 @@
soledad (0.8.0) unstable; urgency=medium
- * Release of soledad 0.8.0
+ * Update to 0.8.0 release
- -- Ben Carrillo <ben@futeisha.org> Wed, 04 May 2016 11:36:35 -0400
+ -- Ben Carrillo <ben@futeisha.org> Mon, 25 Apr 2016 21:08:20 -0400
-soledad (0.8.0~alpha+3) unstable; urgency=medium
+soledad (0.7.4) unstable; urgency=medium
- * Pre-release of soledad 0.8.0
- * Cherry-pick commits to create soledad user, add it to sudoers.
+ * Update to 0.7.4 release
- -- Ben Carrillo <ben@futeisha.org> Tue, 29 Sep 2015 10:43:00 -0400
+ -- Ben Carrillo <ben@futeisha.org> Thu, 29 Oct 2015 12:11:02 -0400
soledad (0.7.3) unstable; urgency=medium
diff --git a/debian/control b/debian/control
index 2b379093..ebdf492e 100644
--- a/debian/control
+++ b/debian/control
@@ -9,7 +9,7 @@ Package: soledad-server
Architecture: all
Depends: ${misc:Depends}, ${python:Depends}, python-configparser, python-couchdb,
python-simplejson, python-oauth, python-u1db, python-routes, python-openssl,
- soledad-common (>= 0.5.0), python-six, python-twisted-web (>= 13.0.0-1~bpo70+1)
+ soledad-common (>= 0.8.0), python-six, python-twisted-web (>= 13.0.0-1~bpo70+1)
Description: Synchronization of locally encrypted data among devices (server files)
Soledad is the part of LEAP that allows application data to be securely
shared among devices. It provides, to other parts of the LEAP client, an
@@ -33,8 +33,8 @@ Package: soledad-client
Architecture: all
Depends: ${misc:Depends}, ${python:Depends}, python-sqlcipher (>= 2.6.3.3+b1),
python-simplejson, python-oauth, python-u1db, python-scrypt,
- python-dirspec, python-pycryptopp (>= 0.6.0.20120313-1~), soledad-common,
- python-chardet, python-twisted-core (>= 13.0.0)
+ python-dirspec, soledad-common, python-chardet,
+ python-twisted-core (>= 13.0.0)
Description: Synchronization of locally encrypted data among devices (client files)
Soledad is the part of LEAP that allows application data to be securely
shared among devices. It provides, to other parts of the LEAP client, an
diff --git a/server/pkg/requirements.pip b/server/pkg/requirements.pip
index e7d474f9..d6430872 100644
--- a/server/pkg/requirements.pip
+++ b/server/pkg/requirements.pip
@@ -2,12 +2,8 @@ configparser
u1db
routes
PyOpenSSL
-#twisted # we don't want all twisted deps in deb!
-#pinned for wheezy compatibility
-Beaker==1.6.3 #wheezy
-couchdb==0.8 #wheezy
-# XXX -- fix me!
-# oauth is not strictly needed by us, but we need it until u1db adds it to its
-# release as a dep.
+Beaker
+couchdb
+
oauth
diff --git a/server/src/leap/soledad/server/_version.py b/server/src/leap/soledad/server/_version.py
index a72d4aa7..3c208ef4 100644
--- a/server/src/leap/soledad/server/_version.py
+++ b/server/src/leap/soledad/server/_version.py
@@ -6,7 +6,7 @@
# of this file.
version_version = '0.8.0'
-full_revisionid = '259d37b430564c03f27d0835e23769473034df6f'
+full_revisionid = 'f25d2e4fa3b51575f4989ac74eade7213966ce4b'
def get_versions(default={}, verbose=False):