diff options
-rw-r--r-- | README.rst | 10 | ||||
-rwxr-xr-x | run_tests.sh | 3 |
2 files changed, 5 insertions, 8 deletions
@@ -38,14 +38,8 @@ Tests Client and server tests are both included in leap.soledad.common. If you want to run tests in development mode you must do the following:: - cd common - python setup.py develop - cd ../client - python setup.py develop - cd ../server - python setup.py develop - cd ../common - python setup.py test + scripts/develop_mode.sh + ./run_tests.sh Note that to run CouchDB tests, be sure you have ``CouchDB`` installed on your system. diff --git a/run_tests.sh b/run_tests.sh new file mode 100755 index 00000000..e36466f8 --- /dev/null +++ b/run_tests.sh @@ -0,0 +1,3 @@ +#!/bin/sh +cd common +python setup.py test |