summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGELOG7
-rw-r--r--README.rst21
-rw-r--r--client/pkg/requirements.pip1
-rw-r--r--client/setup.py5
-rw-r--r--client/src/leap/soledad/client/__init__.py7
-rw-r--r--common/changes/feature_3487-split-soledad-into-common-client-and-server1
-rw-r--r--common/changes/feature_improve_packaging1
-rw-r--r--common/setup.py5
-rw-r--r--debian/changelog6
-rw-r--r--debian/control2
-rw-r--r--server/pkg/soledad2
-rw-r--r--server/setup.py5
-rw-r--r--server/src/leap/soledad/server/__init__.py2
13 files changed, 46 insertions, 19 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 2137aebd..6d797d89 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,10 @@
+0.3.2 Sep 6:
+Client:
+ o Use dirspec instead of plain xdg. Closes #3574.
+Server:
+ o Fix the init script for soledad server so that it uses the new
+ package namespace.
+
0.3.1 Aug 23:
Client:
o Add libsqlite3-dev requirement for soledad.
diff --git a/README.rst b/README.rst
index c2a33234..8fa966c2 100644
--- a/README.rst
+++ b/README.rst
@@ -2,11 +2,28 @@ Soledad
==================================================================
*Synchronization Of Locally Encrypted Data Among Devices*
-.. image:: https://pypip.in/v/leap.soledad/badge.png
- :target: https://crate.io/packages/leap.soledad
+Soledad is the part of LEAP that allows application data to be
+securely shared among devices. It provides, to other parts of the
+LEAP project, an API for data storage and sync.
This software is under development.
+There are currently three python packages maintained under this
+repository:
+
+**leap.soledad.common** common pieces.
+.. image:: https://pypip.in/v/leap.soledad.common/badge.png
+ :target: https://crate.io/packages/leap.soledad.common
+
+**leap.soledad.client** where the soledad client lives.
+.. image:: https://pypip.in/v/leap.soledad.client/badge.png
+ :target: https://crate.io/packages/leap.soledad.client
+
+**leap.soledad.server** oh surprise! bits needed for the soledad server.
+.. image:: https://pypip.in/v/leap.soledad.server/badge.png
+ :target: https://crate.io/packages/leap.soledad.server
+
+
Library dependencies
--------------------
* ``libsqlite3-dev``
diff --git a/client/pkg/requirements.pip b/client/pkg/requirements.pip
index 86b79bb2..df6ddb94 100644
--- a/client/pkg/requirements.pip
+++ b/client/pkg/requirements.pip
@@ -2,7 +2,6 @@ pysqlcipher
simplejson
u1db
scrypt
-pyxdg
pycryptopp
#
diff --git a/client/setup.py b/client/setup.py
index 142922a4..4f62809f 100644
--- a/client/setup.py
+++ b/client/setup.py
@@ -51,13 +51,14 @@ setup(
cmdclass=versioneer.get_cmdclass(),
url='https://leap.se/',
license='GPLv3+',
- description='Synchronization of locally encrypted data among devices.',
+ description='Synchronization of locally encrypted data among devices '
+ '(client components).',
author='The LEAP Encryption Access Project',
author_email='info@leap.se',
long_description=(
"Soledad is the part of LEAP that allows application data to be "
"securely shared among devices. It provides, to other parts of the "
- "LEAP client, an API for data storage and sync."
+ "LEAP project, an API for data storage and sync."
),
classifiers=trove_classifiers,
namespace_packages=["leap", "leap.soledad"],
diff --git a/client/src/leap/soledad/client/__init__.py b/client/src/leap/soledad/client/__init__.py
index df2b30c2..c6fbeac4 100644
--- a/client/src/leap/soledad/client/__init__.py
+++ b/client/src/leap/soledad/client/__init__.py
@@ -37,12 +37,11 @@ import socket
import ssl
import errno
-
-from xdg import BaseDirectory
from hashlib import sha256
from u1db.remote import http_client
from u1db.remote.ssl_match_hostname import match_hostname
+from leap.common.config import get_path_prefix
#
# Signaling function
@@ -218,9 +217,7 @@ class Soledad(object):
Keys used to access storage secrets in recovery documents.
"""
- DEFAULT_PREFIX = os.path.join(
- BaseDirectory.xdg_config_home,
- 'leap', 'soledad')
+ DEFAULT_PREFIX = os.path.join(get_path_prefix(), 'leap', 'soledad')
"""
Prefix for default values for path.
"""
diff --git a/common/changes/feature_3487-split-soledad-into-common-client-and-server b/common/changes/feature_3487-split-soledad-into-common-client-and-server
deleted file mode 100644
index 2eab6b56..00000000
--- a/common/changes/feature_3487-split-soledad-into-common-client-and-server
+++ /dev/null
@@ -1 +0,0 @@
- o Split soledad package into common, client and server. Closes #3487.
diff --git a/common/changes/feature_improve_packaging b/common/changes/feature_improve_packaging
deleted file mode 100644
index e6d3630a..00000000
--- a/common/changes/feature_improve_packaging
+++ /dev/null
@@ -1 +0,0 @@
- o Add versioneer, parse_requirements
diff --git a/common/setup.py b/common/setup.py
index 22159a2a..0a2f138f 100644
--- a/common/setup.py
+++ b/common/setup.py
@@ -50,13 +50,14 @@ setup(
cmdclass=versioneer.get_cmdclass(),
url='https://leap.se/',
license='GPLv3+',
- description='Synchronization of locally encrypted data among devices.',
+ description='Synchronization of locally encrypted data among devices '
+ '(common files).',
author='The LEAP Encryption Access Project',
author_email='info@leap.se',
long_description=(
"Soledad is the part of LEAP that allows application data to be "
"securely shared among devices. It provides, to other parts of the "
- "LEAP client, an API for data storage and sync."
+ "LEAP project, an API for data storage and sync."
),
classifiers=trove_classifiers,
namespace_packages=["leap", "leap.soledad"],
diff --git a/debian/changelog b/debian/changelog
index e68610c2..ee7382ed 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+soledad (0.3.2) unstable; urgency=low
+
+ * Update to 0.3.2
+
+ -- Micah Anderson <micah@debian.org> Thu, 12 Sep 2013 14:13:56 +0200
+
soledad (0.3.1.1) unstable; urgency=low
[ Ben Carrillo ]
diff --git a/debian/control b/debian/control
index d4cf04db..c5427347 100644
--- a/debian/control
+++ b/debian/control
@@ -39,7 +39,7 @@ Package: soledad-client
Architecture: all
Depends: ${misc:Depends}, ${python:Depends}, python-sqlcipher, python-pysqlite1.1,
python-simplejson, python-oauth, python-u1db, python-scrypt,
- python-xdg, python-pycryptopp, soledad-common
+ python-dirspec, python-pycryptopp, soledad-common
Description: Synchronization of locally encrypted data among devices.
Soledad is the part of LEAP that allows application data to be securely
shared among devices. It provides, to other parts of the LEAP client, an
diff --git a/server/pkg/soledad b/server/pkg/soledad
index c233731e..841233d1 100644
--- a/server/pkg/soledad
+++ b/server/pkg/soledad
@@ -12,7 +12,7 @@
PATH=/sbin:/bin:/usr/sbin:/usr/bin
PIDFILE=/var/run/soledad.pid
RUNDIR=/var/lib/soledad/
-OBJ=leap.soledad_server.application
+OBJ=leap.soledad.server.application
LOGFILE=/var/log/soledad.log
HTTPS_PORT=2424
CERT_PATH=/etc/leap/soledad-server.pem
diff --git a/server/setup.py b/server/setup.py
index 22be3fd3..348aa838 100644
--- a/server/setup.py
+++ b/server/setup.py
@@ -58,13 +58,14 @@ setup(
cmdclass=versioneer.get_cmdclass(),
url='https://leap.se/',
license='GPLv3+',
- description='Synchronization of locally encrypted data among devices.',
+ description='Synchronization of locally encrypted data among devices '
+ '(server components)',
author='The LEAP Encryption Access Project',
author_email='info@leap.se',
long_description=(
"Soledad is the part of LEAP that allows application data to be "
"securely shared among devices. It provides, to other parts of the "
- "LEAP client, an API for data storage and sync."
+ "LEAP project, an API for data storage and sync."
),
classifiers=trove_classifiers,
namespace_packages=["leap", "leap.soledad"],
diff --git a/server/src/leap/soledad/server/__init__.py b/server/src/leap/soledad/server/__init__.py
index 0c56acb9..67b0611d 100644
--- a/server/src/leap/soledad/server/__init__.py
+++ b/server/src/leap/soledad/server/__init__.py
@@ -20,7 +20,7 @@
A U1DB server that stores data using CouchDB as its persistence layer.
This should be run with:
- twistd -n web --wsgi=leap.soledad_server.application --port=2424
+ twistd -n web --wsgi=leap.soledad.server.application --port=2424
"""
import configparser