summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore15
-rw-r--r--client/changes/bug_4417_default-encoding-to-utf81
-rw-r--r--client/changes/bug_open-db-in-autocommit-mode2
-rw-r--r--client/changes/feature-use-chardet-as-fallback1
-rw-r--r--client/pkg/requirements.pip2
-rw-r--r--client/src/leap/soledad/client/_version.py222
-rw-r--r--common/src/leap/soledad/common/_version.py222
-rwxr-xr-xdeb_release.sh25
-rw-r--r--debian/__init__.py6
-rw-r--r--debian/changelog138
-rw-r--r--debian/clean1
-rw-r--r--debian/compat1
-rw-r--r--debian/control49
-rw-r--r--debian/copyright16
-rw-r--r--debian/pydist-overrides5
-rwxr-xr-xdebian/rules24
-rw-r--r--debian/soledad-client.pyremove1
-rw-r--r--debian/soledad-common.pyremove1
-rw-r--r--debian/soledad-server.init79
-rw-r--r--debian/soledad-server.pyremove1
-rw-r--r--debian/source/format1
-rw-r--r--server/src/leap/soledad/server/_version.py222
22 files changed, 395 insertions, 640 deletions
diff --git a/.gitignore b/.gitignore
index bd170f79..57836283 100644
--- a/.gitignore
+++ b/.gitignore
@@ -10,3 +10,18 @@ MANIFEST
*.pyc
*.log
*.*~
+
+debian/files
+debian/soledad-client.postinst.debhelper
+debian/soledad-client.prerm.debhelper
+debian/soledad-client.substvars
+debian/soledad-client/
+debian/soledad-common.postinst.debhelper
+debian/soledad-common.prerm.debhelper
+debian/soledad-common.substvars
+debian/soledad-common/
+debian/soledad-server.postinst.debhelper
+debian/soledad-server.postrm.debhelper
+debian/soledad-server.prerm.debhelper
+debian/soledad-server.substvars
+debian/soledad-server/
diff --git a/client/changes/bug_4417_default-encoding-to-utf8 b/client/changes/bug_4417_default-encoding-to-utf8
new file mode 100644
index 00000000..6801b766
--- /dev/null
+++ b/client/changes/bug_4417_default-encoding-to-utf8
@@ -0,0 +1 @@
+ o Defaults detected encoding to utf-8 to avoid bug if detected encoding is None. Closes: #4417
diff --git a/client/changes/bug_open-db-in-autocommit-mode b/client/changes/bug_open-db-in-autocommit-mode
new file mode 100644
index 00000000..26edd5a9
--- /dev/null
+++ b/client/changes/bug_open-db-in-autocommit-mode
@@ -0,0 +1,2 @@
+ o Open db in autocommit mode, to avoid nested transactions problems.
+ Closes: #4400
diff --git a/client/changes/feature-use-chardet-as-fallback b/client/changes/feature-use-chardet-as-fallback
new file mode 100644
index 00000000..f96a959c
--- /dev/null
+++ b/client/changes/feature-use-chardet-as-fallback
@@ -0,0 +1 @@
+ o Use chardet as fallback if cchardet not found.
diff --git a/client/pkg/requirements.pip b/client/pkg/requirements.pip
index 8733f320..7590aee5 100644
--- a/client/pkg/requirements.pip
+++ b/client/pkg/requirements.pip
@@ -21,4 +21,4 @@ oauth
# pysqlite should not be a dep, see #2945
pysqlite
-cchardet \ No newline at end of file
+chardet
diff --git a/client/src/leap/soledad/client/_version.py b/client/src/leap/soledad/client/_version.py
index 65efb714..094f825d 100644
--- a/client/src/leap/soledad/client/_version.py
+++ b/client/src/leap/soledad/client/_version.py
@@ -1,217 +1,13 @@
-IN_LONG_VERSION_PY = True
-# This file helps to compute a version number in source trees obtained from
-# git-archive tarball (such as those provided by githubs download-from-tag
-# feature). Distribution tarballs (build by setup.py sdist) and build
-# directories (produced by setup.py build) will contain a much shorter file
-# that just contains the computed version number.
+# This file was generated by the `freeze_debianver` command in setup.py
+# Using 'versioneer.py' (0.7+) from
+# revision-control system data, or from the parent directory name of an
+# unpacked source archive. Distribution tarballs contain a pre-generated copy
+# of this file.
-# This file is released into the public domain. Generated by
-# versioneer-0.7+ (https://github.com/warner/python-versioneer)
+version_version = '0.5.0-rc1'
+version_full = 'a8e6a6287519d66f93303698dd3ee25bd5b21b63'
-# these strings will be replaced by git during git-archive
-git_refnames = "$Format:%d$"
-git_full = "$Format:%H$"
-
-import subprocess
-import sys
-
-
-def run_command(args, cwd=None, verbose=False):
- try:
- # remember shell=False, so use git.cmd on windows, not just git
- p = subprocess.Popen(args, stdout=subprocess.PIPE, cwd=cwd)
- except EnvironmentError:
- e = sys.exc_info()[1]
- if verbose:
- print("unable to run %s" % args[0])
- print(e)
- return None
- stdout = p.communicate()[0].strip()
- if sys.version >= '3':
- stdout = stdout.decode()
- if p.returncode != 0:
- if verbose:
- print("unable to run %s (error)" % args[0])
- return None
- return stdout
-
-import re
-import os.path
-
-
-def get_expanded_variables(versionfile_source):
- # the code embedded in _version.py can just fetch the value of these
- # variables. When used from setup.py, we don't want to import
- # _version.py, so we do it with a regexp instead. This function is not
- # used from _version.py.
- variables = {}
- try:
- f = open(versionfile_source, "r")
- for line in f.readlines():
- if line.strip().startswith("git_refnames ="):
- mo = re.search(r'=\s*"(.*)"', line)
- if mo:
- variables["refnames"] = mo.group(1)
- if line.strip().startswith("git_full ="):
- mo = re.search(r'=\s*"(.*)"', line)
- if mo:
- variables["full"] = mo.group(1)
- f.close()
- except EnvironmentError:
- pass
- return variables
-
-
-def versions_from_expanded_variables(variables, tag_prefix, verbose=False):
- refnames = variables["refnames"].strip()
- if refnames.startswith("$Format"):
- if verbose:
- print("variables are unexpanded, not using")
- return {} # unexpanded, so not in an unpacked git-archive tarball
- refs = set([r.strip() for r in refnames.strip("()").split(",")])
- # starting in git-1.8.3, tags are listed as "tag: foo-1.0" instead of
- # just "foo-1.0". If we see a "tag: " prefix, prefer those.
- TAG = "tag: "
- tags = set([r[len(TAG):] for r in refs if r.startswith(TAG)])
- if not tags:
- # Either we're using git < 1.8.3, or there really are no tags. We use
- # a heuristic: assume all version tags have a digit. The old git %d
- # expansion behaves like git log --decorate=short and strips out the
- # refs/heads/ and refs/tags/ prefixes that would let us distinguish
- # between branches and tags. By ignoring refnames without digits, we
- # filter out many common branch names like "release" and
- # "stabilization", as well as "HEAD" and "master".
- tags = set([r for r in refs if re.search(r'\d', r)])
- if verbose:
- print("discarding '%s', no digits" % ",".join(refs-tags))
- if verbose:
- print("likely tags: %s" % ",".join(sorted(tags)))
- for ref in sorted(tags):
- # sorting will prefer e.g. "2.0" over "2.0rc1"
- if ref.startswith(tag_prefix):
- r = ref[len(tag_prefix):]
- if verbose:
- print("picking %s" % r)
- return {"version": r,
- "full": variables["full"].strip()}
- # no suitable tags, so we use the full revision id
- if verbose:
- print("no suitable tags, using full revision id")
- return {"version": variables["full"].strip(),
- "full": variables["full"].strip()}
-
-
-def versions_from_vcs(tag_prefix, versionfile_source, verbose=False):
- # this runs 'git' from the root of the source tree. That either means
- # someone ran a setup.py command (and this code is in versioneer.py, so
- # IN_LONG_VERSION_PY=False, thus the containing directory is the root of
- # the source tree), or someone ran a project-specific entry point (and
- # this code is in _version.py, so IN_LONG_VERSION_PY=True, thus the
- # containing directory is somewhere deeper in the source tree). This only
- # gets called if the git-archive 'subst' variables were *not* expanded,
- # and _version.py hasn't already been rewritten with a short version
- # string, meaning we're inside a checked out source tree.
-
- try:
- here = os.path.abspath(__file__)
- except NameError:
- # some py2exe/bbfreeze/non-CPython implementations don't do __file__
- return {} # not always correct
-
- # versionfile_source is the relative path from the top of the source tree
- # (where the .git directory might live) to this file. Invert this to find
- # the root from __file__.
- root = here
- if IN_LONG_VERSION_PY:
- for i in range(len(versionfile_source.split("/"))):
- root = os.path.dirname(root)
- else:
- root = os.path.dirname(
- os.path.join('..', here))
-
- ######################################################
- # XXX patch for our specific configuration with
- # the three projects leap.soledad.{common, client, server}
- # inside the same repo.
- ######################################################
- root = os.path.dirname(os.path.join('..', root))
-
- if not os.path.exists(os.path.join(root, ".git")):
- if verbose:
- print("no .git in %s" % root)
- return {}
-
- GIT = "git"
- if sys.platform == "win32":
- GIT = "git.cmd"
- stdout = run_command([GIT, "describe", "--tags", "--dirty", "--always"],
- cwd=root)
- if stdout is None:
- return {}
- if not stdout.startswith(tag_prefix):
- if verbose:
- print("tag '%s' doesn't start with prefix '%s'" %
- (stdout, tag_prefix))
- return {}
- tag = stdout[len(tag_prefix):]
- stdout = run_command([GIT, "rev-parse", "HEAD"], cwd=root)
- if stdout is None:
- return {}
- full = stdout.strip()
- if tag.endswith("-dirty"):
- full += "-dirty"
- return {"version": tag, "full": full}
-
-
-def versions_from_parentdir(parentdir_prefix, versionfile_source,
- verbose=False):
- if IN_LONG_VERSION_PY:
- # We're running from _version.py. If it's from a source tree
- # (execute-in-place), we can work upwards to find the root of the
- # tree, and then check the parent directory for a version string. If
- # it's in an installed application, there's no hope.
- try:
- here = os.path.abspath(__file__)
- except NameError:
- # py2exe/bbfreeze/non-CPython don't have __file__
- return {} # without __file__, we have no hope
- # versionfile_source is the relative path from the top of the source
- # tree to _version.py. Invert this to find the root from __file__.
- root = here
- for i in range(len(versionfile_source.split("/"))):
- root = os.path.dirname(root)
- else:
- # we're running from versioneer.py, which means we're running from
- # the setup.py in a source tree. sys.argv[0] is setup.py in the root.
- here = os.path.abspath(sys.argv[0])
- root = os.path.dirname(here)
-
- # Source tarballs conventionally unpack into a directory that includes
- # both the project name and a version string.
- dirname = os.path.basename(root)
- if not dirname.startswith(parentdir_prefix):
- if verbose:
- print("guessing rootdir is '%s', but '%s' doesn't start "
- "with prefix '%s'" %
- (root, dirname, parentdir_prefix))
- return None
- return {"version": dirname[len(parentdir_prefix):], "full": ""}
-
-tag_prefix = ""
-parentdir_prefix = "leap.soledad.client-"
-versionfile_source = "src/leap/soledad/client/_version.py"
-
-
-def get_versions(default={"version": "unknown", "full": ""}, verbose=False):
- variables = {"refnames": git_refnames, "full": git_full}
- ver = versions_from_expanded_variables(variables, tag_prefix, verbose)
- if not ver:
- ver = versions_from_vcs(tag_prefix, versionfile_source, verbose)
- if not ver:
- ver = versions_from_parentdir(parentdir_prefix, versionfile_source,
- verbose)
- if not ver:
- ver = default
- return ver
+def get_versions(default={}, verbose=False):
+ return {'version': version_version, 'full': version_full}
diff --git a/common/src/leap/soledad/common/_version.py b/common/src/leap/soledad/common/_version.py
index 7d4262b5..094f825d 100644
--- a/common/src/leap/soledad/common/_version.py
+++ b/common/src/leap/soledad/common/_version.py
@@ -1,217 +1,13 @@
-IN_LONG_VERSION_PY = True
-# This file helps to compute a version number in source trees obtained from
-# git-archive tarball (such as those provided by githubs download-from-tag
-# feature). Distribution tarballs (build by setup.py sdist) and build
-# directories (produced by setup.py build) will contain a much shorter file
-# that just contains the computed version number.
+# This file was generated by the `freeze_debianver` command in setup.py
+# Using 'versioneer.py' (0.7+) from
+# revision-control system data, or from the parent directory name of an
+# unpacked source archive. Distribution tarballs contain a pre-generated copy
+# of this file.
-# This file is released into the public domain. Generated by
-# versioneer-0.7+ (https://github.com/warner/python-versioneer)
+version_version = '0.5.0-rc1'
+version_full = 'a8e6a6287519d66f93303698dd3ee25bd5b21b63'
-# these strings will be replaced by git during git-archive
-git_refnames = "$Format:%d$"
-git_full = "$Format:%H$"
-
-import subprocess
-import sys
-
-
-def run_command(args, cwd=None, verbose=False):
- try:
- # remember shell=False, so use git.cmd on windows, not just git
- p = subprocess.Popen(args, stdout=subprocess.PIPE, cwd=cwd)
- except EnvironmentError:
- e = sys.exc_info()[1]
- if verbose:
- print("unable to run %s" % args[0])
- print(e)
- return None
- stdout = p.communicate()[0].strip()
- if sys.version >= '3':
- stdout = stdout.decode()
- if p.returncode != 0:
- if verbose:
- print("unable to run %s (error)" % args[0])
- return None
- return stdout
-
-import re
-import os.path
-
-
-def get_expanded_variables(versionfile_source):
- # the code embedded in _version.py can just fetch the value of these
- # variables. When used from setup.py, we don't want to import
- # _version.py, so we do it with a regexp instead. This function is not
- # used from _version.py.
- variables = {}
- try:
- f = open(versionfile_source, "r")
- for line in f.readlines():
- if line.strip().startswith("git_refnames ="):
- mo = re.search(r'=\s*"(.*)"', line)
- if mo:
- variables["refnames"] = mo.group(1)
- if line.strip().startswith("git_full ="):
- mo = re.search(r'=\s*"(.*)"', line)
- if mo:
- variables["full"] = mo.group(1)
- f.close()
- except EnvironmentError:
- pass
- return variables
-
-
-def versions_from_expanded_variables(variables, tag_prefix, verbose=False):
- refnames = variables["refnames"].strip()
- if refnames.startswith("$Format"):
- if verbose:
- print("variables are unexpanded, not using")
- return {} # unexpanded, so not in an unpacked git-archive tarball
- refs = set([r.strip() for r in refnames.strip("()").split(",")])
- # starting in git-1.8.3, tags are listed as "tag: foo-1.0" instead of
- # just "foo-1.0". If we see a "tag: " prefix, prefer those.
- TAG = "tag: "
- tags = set([r[len(TAG):] for r in refs if r.startswith(TAG)])
- if not tags:
- # Either we're using git < 1.8.3, or there really are no tags. We use
- # a heuristic: assume all version tags have a digit. The old git %d
- # expansion behaves like git log --decorate=short and strips out the
- # refs/heads/ and refs/tags/ prefixes that would let us distinguish
- # between branches and tags. By ignoring refnames without digits, we
- # filter out many common branch names like "release" and
- # "stabilization", as well as "HEAD" and "master".
- tags = set([r for r in refs if re.search(r'\d', r)])
- if verbose:
- print("discarding '%s', no digits" % ",".join(refs-tags))
- if verbose:
- print("likely tags: %s" % ",".join(sorted(tags)))
- for ref in sorted(tags):
- # sorting will prefer e.g. "2.0" over "2.0rc1"
- if ref.startswith(tag_prefix):
- r = ref[len(tag_prefix):]
- if verbose:
- print("picking %s" % r)
- return {"version": r,
- "full": variables["full"].strip()}
- # no suitable tags, so we use the full revision id
- if verbose:
- print("no suitable tags, using full revision id")
- return {"version": variables["full"].strip(),
- "full": variables["full"].strip()}
-
-
-def versions_from_vcs(tag_prefix, versionfile_source, verbose=False):
- # this runs 'git' from the root of the source tree. That either means
- # someone ran a setup.py command (and this code is in versioneer.py, so
- # IN_LONG_VERSION_PY=False, thus the containing directory is the root of
- # the source tree), or someone ran a project-specific entry point (and
- # this code is in _version.py, so IN_LONG_VERSION_PY=True, thus the
- # containing directory is somewhere deeper in the source tree). This only
- # gets called if the git-archive 'subst' variables were *not* expanded,
- # and _version.py hasn't already been rewritten with a short version
- # string, meaning we're inside a checked out source tree.
-
- try:
- here = os.path.abspath(__file__)
- except NameError:
- # some py2exe/bbfreeze/non-CPython implementations don't do __file__
- return {} # not always correct
-
- # versionfile_source is the relative path from the top of the source tree
- # (where the .git directory might live) to this file. Invert this to find
- # the root from __file__.
- root = here
- if IN_LONG_VERSION_PY:
- for i in range(len(versionfile_source.split("/"))):
- root = os.path.dirname(root)
- else:
- root = os.path.dirname(
- os.path.join('..', here))
-
- ######################################################
- # XXX patch for our specific configuration with
- # the three projects leap.soledad.{common, client, server}
- # inside the same repo.
- ######################################################
- root = os.path.dirname(os.path.join('..', root))
-
- if not os.path.exists(os.path.join(root, ".git")):
- if verbose:
- print("no .git in %s" % root)
- return {}
-
- GIT = "git"
- if sys.platform == "win32":
- GIT = "git.cmd"
- stdout = run_command([GIT, "describe", "--tags", "--dirty", "--always"],
- cwd=root)
- if stdout is None:
- return {}
- if not stdout.startswith(tag_prefix):
- if verbose:
- print("tag '%s' doesn't start with prefix '%s'" % (
- stdout, tag_prefix))
- return {}
- tag = stdout[len(tag_prefix):]
- stdout = run_command([GIT, "rev-parse", "HEAD"], cwd=root)
- if stdout is None:
- return {}
- full = stdout.strip()
- if tag.endswith("-dirty"):
- full += "-dirty"
- return {"version": tag, "full": full}
-
-
-def versions_from_parentdir(parentdir_prefix, versionfile_source,
- verbose=False):
- if IN_LONG_VERSION_PY:
- # We're running from _version.py. If it's from a source tree
- # (execute-in-place), we can work upwards to find the root of the
- # tree, and then check the parent directory for a version string. If
- # it's in an installed application, there's no hope.
- try:
- here = os.path.abspath(__file__)
- except NameError:
- # py2exe/bbfreeze/non-CPython don't have __file__
- return {} # without __file__, we have no hope
- # versionfile_source is the relative path from the top of the source
- # tree to _version.py. Invert this to find the root from __file__.
- root = here
- for i in range(len(versionfile_source.split("/"))):
- root = os.path.dirname(root)
- else:
- # we're running from versioneer.py, which means we're running from
- # the setup.py in a source tree. sys.argv[0] is setup.py in the root.
- here = os.path.abspath(sys.argv[0])
- root = os.path.dirname(here)
-
- # Source tarballs conventionally unpack into a directory that includes
- # both the project name and a version string.
- dirname = os.path.basename(root)
- if not dirname.startswith(parentdir_prefix):
- if verbose:
- print("guessing rootdir is '%s', but '%s' doesn't start with "
- "prefix '%s'" %
- (root, dirname, parentdir_prefix))
- return None
- return {"version": dirname[len(parentdir_prefix):], "full": ""}
-
-tag_prefix = ""
-parentdir_prefix = "leap.soledad.common-"
-versionfile_source = "src/leap/soledad/common/_version.py"
-
-
-def get_versions(default={"version": "unknown", "full": ""}, verbose=False):
- variables = {"refnames": git_refnames, "full": git_full}
- ver = versions_from_expanded_variables(variables, tag_prefix, verbose)
- if not ver:
- ver = versions_from_vcs(tag_prefix, versionfile_source, verbose)
- if not ver:
- ver = versions_from_parentdir(parentdir_prefix, versionfile_source,
- verbose)
- if not ver:
- ver = default
- return ver
+def get_versions(default={}, verbose=False):
+ return {'version': version_version, 'full': version_full}
diff --git a/deb_release.sh b/deb_release.sh
new file mode 100755
index 00000000..384af0e8
--- /dev/null
+++ b/deb_release.sh
@@ -0,0 +1,25 @@
+#!/bin/zsh
+
+cd common
+echo `pwd`
+rm src/leap/soledad/common/_version.py
+python setup.py freeze_debianver
+sed -i 's/-dirty//g' src/leap/soledad/common/_version.py
+cd ..
+
+cd client
+rm src/leap/soledad/client/_version.py
+python setup.py freeze_debianver
+sed -i 's/-dirty//g' src/leap/soledad/client/_version.py
+cd ..
+
+cd server
+rm src/leap/soledad/server/_version.py
+python setup.py freeze_debianver
+sed -i 's/-dirty//g' src/leap/soledad/server/_version.py
+cd ..
+
+git add common/src/leap/soledad/common/_version.py
+git add client/src/leap/soledad/client/_version.py
+git add server/src/leap/soledad/server/_version.py
+git ci -m "freeze debian version"
diff --git a/debian/__init__.py b/debian/__init__.py
new file mode 100644
index 00000000..f48ad105
--- /dev/null
+++ b/debian/__init__.py
@@ -0,0 +1,6 @@
+# See http://peak.telecommunity.com/DevCenter/setuptools#namespace-packages
+try:
+ __import__('pkg_resources').declare_namespace(__name__)
+except ImportError:
+ from pkgutil import extend_path
+ __path__ = extend_path(__path__, __name__)
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 00000000..c04bb151
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,138 @@
+soledad (0.5.0~rc) unstable; urgency=low
+
+ * Update to 0.5.0 release: couchdb consistency release.
+
+ -- Ben Carrillo <ben@futeisha.org> Mon, 23 Dec 2013 01:57:06 -0400
+
+soledad (0.4.4.1) unstable; urgency=medium
+
+ * Set version dependency of python-pycryptopp for soledad-client
+
+ -- Micah Anderson <micah@debian.org> Tue, 10 Dec 2013 21:10:27 -0500
+
+soledad (0.4.4) unstable; urgency=low
+
+ * Update to 0.4.4 release.
+
+ -- Ben Carrillo <ben@futeisha.org> Tue, 10 Dec 2013 17:06:28 -0400
+
+soledad (0.4.3) unstable; urgency=low
+
+ * Update to 0.4.3 release
+
+ -- Ben Carrillo <ben@futeisha.org> Fri, 15 Nov 2013 23:37:55 -0200
+
+soledad (0.4.2.2) unstable; urgency=low
+
+ * soledad-client: Cherry-pick change for autocommit mode, which fixes
+ a "cannot start a transaction within a transaction" that was
+ rendering the client unusable.
+ * soledad-client: Cherry-pick for default encoding, which fixes a bug
+ that was rendering the client unusable.
+
+ -- Ben Carrillo <ben@futeisha.org> Thu, 07 Nov 2013 20:09:29 -0200
+
+soledad (0.4.2.1) unstable; urgency=low
+
+ * Change cchardet dependency for chardet explicitly.
+
+ -- Ben Carrillo <ben@futeisha.org> Wed, 06 Nov 2013 17:46:03 -0200
+
+soledad (0.4.2) unstable; urgency=low
+
+ * Update to 0.4.2
+
+ -- Ben Carrillo <ben@futeisha.org> Tue, 05 Nov 2013 11:18:39 -0200
+
+soledad (0.4.1) unstable; urgency=low
+
+ * Update to 0.4.1.
+ * Freeze version to 0.4.1 using freeze_debianver command.
+ * Use python-chardet as a fallback.
+
+ -- Micah Anderson <micah@debian.org> Tue, 15 Oct 2013 15:27:19 -0300
+
+soledad (0.4.0) unstable; urgency=low
+
+ * Update to 0.4.0.
+
+ -- Micah Anderson <micah@debian.org> Tue, 24 Sep 2013 16:50:19 -0400
+
+soledad (0.3.2) unstable; urgency=low
+
+ * Update to 0.3.2
+
+ -- Micah Anderson <micah@debian.org> Thu, 12 Sep 2013 14:13:56 +0200
+
+soledad (0.3.1.1) unstable; urgency=low
+
+ [ Ben Carrillo ]
+ * Fix installation of __init__ file on namespace module.
+ * Add LICENSE.
+
+ [ Micah Anderson ]
+ * Add fix to initscript so it uses the new namespace
+
+ -- Micah Anderson <micah@debian.org> Thu, 29 Aug 2013 14:46:23 -0400
+
+soledad (0.3.1) unstable; urgency=low
+
+ [ Ben Carrillo ]
+ * Update to latest release.
+ * Fix pydist-overrides.
+
+ [ Micah Anderson ]
+ * Stop setup.py from installing initscript so packaging can
+
+ -- Micah Anderson <micah@debian.org> Mon, 26 Aug 2013 18:21:09 +0200
+
+soledad (0.3.1~pre) unstable; urgency=low
+
+ * Upgrade to latest code in develop
+ * Setup additional binary package
+ * Fix pydist-overrides for new package name
+
+ -- Micah Anderson <micah@debian.org> Thu, 22 Aug 2013 14:57:54 -0400
+
+soledad (0.3.0.3) unstable; urgency=low
+
+ * Fixed missing epoch on python-twisted-conch
+
+ -- Micah Anderson <micah@debian.org> Thu, 15 Aug 2013 13:16:54 -0400
+
+soledad (0.3.0.2) unstable; urgency=low
+
+ * Pin twisted version in Depends to get 13 or greater
+
+ -- Micah Anderson <micah@debian.org> Thu, 15 Aug 2013 11:31:57 -0400
+
+soledad (0.3.0.1) unstable; urgency=low
+
+ * Update initscript to require that START=yes is set
+ in /etc/default/soledad
+
+ -- Micah Anderson <micah@debian.org> Wed, 14 Aug 2013 11:18:01 -0400
+
+soledad (0.3.0) unstable; urgency=low
+
+ * Update to 0.3.0
+
+ -- Micah Anderson <micah@debian.org> Tue, 13 Aug 2013 14:42:06 -0400
+
+soledad (0.2.3) unstable; urgency=low
+
+ * Upgrade to new release
+
+ -- Micah Anderson <micah@debian.org> Mon, 29 Jul 2013 20:47:19 -0400
+
+soledad (0.2.2.1) unstable; urgency=low
+
+ * Fix installation of initscript
+
+ -- Micah Anderson <micah@debian.org> Thu, 18 Jul 2013 15:54:51 -0400
+
+soledad (0.2.2) unstable; urgency=low
+
+ * Initial debian package
+
+ -- Micah Anderson <micah@debian.org> Thu, 30 May 2013 15:11:11 -0400
diff --git a/debian/clean b/debian/clean
new file mode 100644
index 00000000..c9349d36
--- /dev/null
+++ b/debian/clean
@@ -0,0 +1 @@
+src/leap.soledad.egg-info/*
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 00000000..ec635144
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 00000000..71c52c6c
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,49 @@
+Source: soledad
+Section: python
+Priority: optional
+Maintainer: Micah Anderson <micah@debian.org>
+Build-Depends: python-setuptools (>= 0.6b3), python-all (>= 2.6.6-3), debhelper (>= 9)
+Standards-Version: 3.9.4
+
+Package: soledad-server
+Architecture: all
+Depends: ${misc:Depends}, ${python:Depends}, python-configparser, python-couchdb,
+ python-simplejson, python-oauth, python-u1db, python-routes, python-openssl,
+ soledad-common (>= 0.3.0-1),
+ python-six, python-twisted (>= 13.0.0-1~bpo70+1), python-twisted-bin (>= 13.0.0-1~bpo70+1),
+ python-twisted-conch (>= 1:13.0.0-1~bpo70+1), python-twisted-core (>= 13.0.0-1~bpo70+1),
+ python-twisted-lore (>= 13.0.0-1~bpo70+1), python-twisted-mail (>= 13.0.0-1~bpo70+1),
+ python-twisted-names (>= 13.0.0-1~bpo70+1), python-twisted-news (>= 13.0.0-1~bpo70+1),
+ python-twisted-runner (>= 13.0.0-1~bpo70+1), python-twisted-words (>= 13.0.0-1~bpo70+1),
+ python-twisted-web (>= 13.0.0-1~bpo70+1)
+Description: Synchronization of locally encrypted data among devices.
+ Soledad is the part of LEAP that allows application data to be securely
+ shared among devices. It provides, to other parts of the LEAP client, an
+ API for data storage and sync.
+ .
+ This package contains the server components.
+
+Package: soledad-common
+Architecture: all
+Depends: ${misc:Depends}, ${python:Depends}, python-simplejson, python-oauth, python-u1db,
+ python-six
+Description: Synchronization of locally encrypted data among devices.
+ Soledad is the part of LEAP that allows application data to be securely
+ shared among devices. It provides, to other parts of the LEAP client, an
+ API for data storage and sync.
+ .
+ This package contains the common soledad libraries. For the server, see the
+ soledad-server package
+
+Package: soledad-client
+Architecture: all
+Depends: ${misc:Depends}, ${python:Depends}, python-sqlcipher (>= 2.6.3.1), python-pysqlite1.1,
+ python-simplejson, python-oauth, python-u1db, python-scrypt,
+ python-dirspec, python-pycryptopp (>= 0.6.0.20120313-1), soledad-common,
+ python-chardet
+Description: Synchronization of locally encrypted data among devices.
+ Soledad is the part of LEAP that allows application data to be securely
+ shared among devices. It provides, to other parts of the LEAP client, an
+ API for data storage and sync.
+ .
+ This package contains the soledad client.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 00000000..d811209b
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,16 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: soledad
+Upstream-Contact: info@leap.se
+Source: <git://code.leap.se/soledad/>
+
+Files: *
+Copyright: Copyright (C) 2013 LEAP
+License: GPL-3+
+
+Files: debian/*
+Copyright: Copyright 2013 Micah Anderson <micah@leap.se>
+License: GPL-3+
+
+License: GPL-3+
+ On Debian systems, the complete text of the GNU General
+ Public License can be found in `/usr/share/common-licenses/GPL'.
diff --git a/debian/pydist-overrides b/debian/pydist-overrides
new file mode 100644
index 00000000..c1b27213
--- /dev/null
+++ b/debian/pydist-overrides
@@ -0,0 +1,5 @@
+pysqlcipher python-sqlcipher
+PyOpenSSL python-openssl
+leap.soledad.common soledad-common
+leap.soledad.server soledad-server
+leap.soledad.client soledad-client
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..c66ed435
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,24 @@
+#!/usr/bin/make -f
+
+# Uncomment this to turn on verbose mode.
+#DH_VERBOSE=1
+
+%:
+ dh $@ --with python2 --namespace=leap.soledad
+
+override_dh_auto_clean:
+ cd client && python setup.py clean -a
+ cd common && python setup.py clean -a
+ cd server && python setup.py clean -a
+
+override_dh_auto_install:
+ cd client && python setup.py install --root=../debian/soledad-client
+ cd common && python setup.py install --root=../debian/soledad-common
+ cd server && LEAP_SKIP_INIT=1 python setup.py install --root=../debian/soledad-server
+
+override_dh_install:
+ # leap.soledad provides the leap.soledad namespace __init__.py
+ for pv in $(shell pyversions -vr debian/control); do \
+ cp common/src/leap/__init__.py debian/soledad-common/usr/local/lib/python$$pv/*-packages/leap/; \
+ cp common/src/leap/__init__.py debian/soledad-common/usr/local/lib/python$$pv/*-packages/leap/soledad/; \
+ done
diff --git a/debian/soledad-client.pyremove b/debian/soledad-client.pyremove
new file mode 100644
index 00000000..936da7d3
--- /dev/null
+++ b/debian/soledad-client.pyremove
@@ -0,0 +1 @@
+*.pth
diff --git a/debian/soledad-common.pyremove b/debian/soledad-common.pyremove
new file mode 100644
index 00000000..936da7d3
--- /dev/null
+++ b/debian/soledad-common.pyremove
@@ -0,0 +1 @@
+*.pth
diff --git a/debian/soledad-server.init b/debian/soledad-server.init
new file mode 100644
index 00000000..58c10c3a
--- /dev/null
+++ b/debian/soledad-server.init
@@ -0,0 +1,79 @@
+#!/bin/sh
+### BEGIN INIT INFO
+# Provides: soledad
+# Required-Start: $network $named $remote_fs $syslog $time
+# Required-Stop: $network $named $remote_fs $syslog
+# Default-Start: 2 3 4 5
+# Default-Stop: 0 1 6
+# Short-Description: Start soledad daemon at boot time
+# Description: Synchronization of locally encrypted data among devices
+### END INIT INFO
+
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+PIDFILE=/var/run/soledad.pid
+RUNDIR=/var/lib/soledad/
+OBJ=leap.soledad.server.application
+LOGFILE=/var/log/soledad.log
+HTTPS_PORT=2424
+CERT_PATH=/etc/leap/soledad-server.pem
+PRIVKEY_PATH=/etc/leap/soledad-server.pem
+TWISTD_PATH=/usr/bin/twistd
+HOME=/var/lib/soledad/
+
+[ -r /etc/default/soledad ] && . /etc/default/soledad
+
+test -r /etc/leap/ || exit 0
+
+. /lib/lsb/init-functions
+
+is_true() {
+ if [ "x$1" = "xtrue" -o "x$1" = "xyes" -o "x$1" = "x0" ] ; then
+ return 0
+ else
+ return 1
+ fi
+}
+
+case "$1" in
+ start)
+ if is_true "$START" ; then
+ echo -n "Starting soledad: twistd"
+ start-stop-daemon --start --quiet --exec $TWISTD_PATH -- \
+ --pidfile=$PIDFILE \
+ --logfile=$LOGFILE \
+ web \
+ --wsgi=$OBJ \
+ --port=ssl:$HTTPS_PORT:privateKey=$PRIVKEY_PATH:certKey=$CERT_PATH
+ echo "."
+ else
+ echo ""
+ echo "soledad-server is not configured to start, please edit /etc/default/soledad to enable"
+ fi
+ ;;
+ stop)
+ echo -n "Stopping soledad: twistd"
+ start-stop-daemon --stop --quiet \
+ --pidfile $PIDFILE
+ echo "."
+ ;;
+
+ restart)
+ $0 stop
+ $0 start
+ ;;
+
+ force-reload)
+ $0 restart
+ ;;
+
+ status)
+ status_of_proc -p $PIDFILE $TWISTD_PATH soledad && exit 0 || exit $?
+ ;;
+
+ *)
+ echo "Usage: /etc/init.d/soledad {start|stop|restart|force-reload|status}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/debian/soledad-server.pyremove b/debian/soledad-server.pyremove
new file mode 100644
index 00000000..936da7d3
--- /dev/null
+++ b/debian/soledad-server.pyremove
@@ -0,0 +1 @@
+*.pth
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 00000000..89ae9db8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/server/src/leap/soledad/server/_version.py b/server/src/leap/soledad/server/_version.py
index ec611c39..094f825d 100644
--- a/server/src/leap/soledad/server/_version.py
+++ b/server/src/leap/soledad/server/_version.py
@@ -1,217 +1,13 @@
-IN_LONG_VERSION_PY = True
-# This file helps to compute a version number in source trees obtained from
-# git-archive tarball (such as those provided by githubs download-from-tag
-# feature). Distribution tarballs (build by setup.py sdist) and build
-# directories (produced by setup.py build) will contain a much shorter file
-# that just contains the computed version number.
+# This file was generated by the `freeze_debianver` command in setup.py
+# Using 'versioneer.py' (0.7+) from
+# revision-control system data, or from the parent directory name of an
+# unpacked source archive. Distribution tarballs contain a pre-generated copy
+# of this file.
-# This file is released into the public domain. Generated by
-# versioneer-0.7+ (https://github.com/warner/python-versioneer)
+version_version = '0.5.0-rc1'
+version_full = 'a8e6a6287519d66f93303698dd3ee25bd5b21b63'
-# these strings will be replaced by git during git-archive
-git_refnames = "$Format:%d$"
-git_full = "$Format:%H$"
-
-import subprocess
-import sys
-
-
-def run_command(args, cwd=None, verbose=False):
- try:
- # remember shell=False, so use git.cmd on windows, not just git
- p = subprocess.Popen(args, stdout=subprocess.PIPE, cwd=cwd)
- except EnvironmentError:
- e = sys.exc_info()[1]
- if verbose:
- print("unable to run %s" % args[0])
- print(e)
- return None
- stdout = p.communicate()[0].strip()
- if sys.version >= '3':
- stdout = stdout.decode()
- if p.returncode != 0:
- if verbose:
- print("unable to run %s (error)" % args[0])
- return None
- return stdout
-
-import re
-import os.path
-
-
-def get_expanded_variables(versionfile_source):
- # the code embedded in _version.py can just fetch the value of these
- # variables. When used from setup.py, we don't want to import
- # _version.py, so we do it with a regexp instead. This function is not
- # used from _version.py.
- variables = {}
- try:
- f = open(versionfile_source, "r")
- for line in f.readlines():
- if line.strip().startswith("git_refnames ="):
- mo = re.search(r'=\s*"(.*)"', line)
- if mo:
- variables["refnames"] = mo.group(1)
- if line.strip().startswith("git_full ="):
- mo = re.search(r'=\s*"(.*)"', line)
- if mo:
- variables["full"] = mo.group(1)
- f.close()
- except EnvironmentError:
- pass
- return variables
-
-
-def versions_from_expanded_variables(variables, tag_prefix, verbose=False):
- refnames = variables["refnames"].strip()
- if refnames.startswith("$Format"):
- if verbose:
- print("variables are unexpanded, not using")
- return {} # unexpanded, so not in an unpacked git-archive tarball
- refs = set([r.strip() for r in refnames.strip("()").split(",")])
- # starting in git-1.8.3, tags are listed as "tag: foo-1.0" instead of
- # just "foo-1.0". If we see a "tag: " prefix, prefer those.
- TAG = "tag: "
- tags = set([r[len(TAG):] for r in refs if r.startswith(TAG)])
- if not tags:
- # Either we're using git < 1.8.3, or there really are no tags. We use
- # a heuristic: assume all version tags have a digit. The old git %d
- # expansion behaves like git log --decorate=short and strips out the
- # refs/heads/ and refs/tags/ prefixes that would let us distinguish
- # between branches and tags. By ignoring refnames without digits, we
- # filter out many common branch names like "release" and
- # "stabilization", as well as "HEAD" and "master".
- tags = set([r for r in refs if re.search(r'\d', r)])
- if verbose:
- print("discarding '%s', no digits" % ",".join(refs-tags))
- if verbose:
- print("likely tags: %s" % ",".join(sorted(tags)))
- for ref in sorted(tags):
- # sorting will prefer e.g. "2.0" over "2.0rc1"
- if ref.startswith(tag_prefix):
- r = ref[len(tag_prefix):]
- if verbose:
- print("picking %s" % r)
- return {"version": r,
- "full": variables["full"].strip()}
- # no suitable tags, so we use the full revision id
- if verbose:
- print("no suitable tags, using full revision id")
- return {"version": variables["full"].strip(),
- "full": variables["full"].strip()}
-
-
-def versions_from_vcs(tag_prefix, versionfile_source, verbose=False):
- # this runs 'git' from the root of the source tree. That either means
- # someone ran a setup.py command (and this code is in versioneer.py, so
- # IN_LONG_VERSION_PY=False, thus the containing directory is the root of
- # the source tree), or someone ran a project-specific entry point (and
- # this code is in _version.py, so IN_LONG_VERSION_PY=True, thus the
- # containing directory is somewhere deeper in the source tree). This only
- # gets called if the git-archive 'subst' variables were *not* expanded,
- # and _version.py hasn't already been rewritten with a short version
- # string, meaning we're inside a checked out source tree.
-
- try:
- here = os.path.abspath(__file__)
- except NameError:
- # some py2exe/bbfreeze/non-CPython implementations don't do __file__
- return {} # not always correct
-
- # versionfile_source is the relative path from the top of the source tree
- # (where the .git directory might live) to this file. Invert this to find
- # the root from __file__.
- root = here
- if IN_LONG_VERSION_PY:
- for i in range(len(versionfile_source.split("/"))):
- root = os.path.dirname(root)
- else:
- root = os.path.dirname(
- os.path.join('..', here))
-
- ######################################################
- # XXX patch for our specific configuration with
- # the three projects leap.soledad.{common, client, server}
- # inside the same repo.
- ######################################################
- root = os.path.dirname(os.path.join('..', root))
-
- if not os.path.exists(os.path.join(root, ".git")):
- if verbose:
- print("no .git in %s" % root)
- return {}
-
- GIT = "git"
- if sys.platform == "win32":
- GIT = "git.cmd"
- stdout = run_command([GIT, "describe", "--tags", "--dirty", "--always"],
- cwd=root)
- if stdout is None:
- return {}
- if not stdout.startswith(tag_prefix):
- if verbose:
- print("tag '%s' doesn't start with prefix '%s'" %
- (stdout, tag_prefix))
- return {}
- tag = stdout[len(tag_prefix):]
- stdout = run_command([GIT, "rev-parse", "HEAD"], cwd=root)
- if stdout is None:
- return {}
- full = stdout.strip()
- if tag.endswith("-dirty"):
- full += "-dirty"
- return {"version": tag, "full": full}
-
-
-def versions_from_parentdir(parentdir_prefix, versionfile_source,
- verbose=False):
- if IN_LONG_VERSION_PY:
- # We're running from _version.py. If it's from a source tree
- # (execute-in-place), we can work upwards to find the root of the
- # tree, and then check the parent directory for a version string. If
- # it's in an installed application, there's no hope.
- try:
- here = os.path.abspath(__file__)
- except NameError:
- # py2exe/bbfreeze/non-CPython don't have __file__
- return {} # without __file__, we have no hope
- # versionfile_source is the relative path from the top of the source
- # tree to _version.py. Invert this to find the root from __file__.
- root = here
- for i in range(len(versionfile_source.split("/"))):
- root = os.path.dirname(root)
- else:
- # we're running from versioneer.py, which means we're running from
- # the setup.py in a source tree. sys.argv[0] is setup.py in the root.
- here = os.path.abspath(sys.argv[0])
- root = os.path.dirname(here)
-
- # Source tarballs conventionally unpack into a directory that includes
- # both the project name and a version string.
- dirname = os.path.basename(root)
- if not dirname.startswith(parentdir_prefix):
- if verbose:
- print("guessing rootdir is '%s', but '%s' doesn't start "
- "with prefix '%s'" %
- (root, dirname, parentdir_prefix))
- return None
- return {"version": dirname[len(parentdir_prefix):], "full": ""}
-
-tag_prefix = ""
-parentdir_prefix = "leap.soledad.server-"
-versionfile_source = "src/leap/soledad/server/_version.py"
-
-
-def get_versions(default={"version": "unknown", "full": ""}, verbose=False):
- variables = {"refnames": git_refnames, "full": git_full}
- ver = versions_from_expanded_variables(variables, tag_prefix, verbose)
- if not ver:
- ver = versions_from_vcs(tag_prefix, versionfile_source, verbose)
- if not ver:
- ver = versions_from_parentdir(parentdir_prefix, versionfile_source,
- verbose)
- if not ver:
- ver = default
- return ver
+def get_versions(default={}, verbose=False):
+ return {'version': version_version, 'full': version_full}