diff options
author | Kali Kaneko <kali@leap.se> | 2013-05-31 01:54:57 +0900 |
---|---|---|
committer | Kali Kaneko <kali@leap.se> | 2013-05-31 01:54:57 +0900 |
commit | eb1f487dc762e17331967365477d58932b7656db (patch) | |
tree | 50a51aa9f8b38f0343fbc8c0475ddd437c62dce1 /setup.py | |
parent | c2b0e9dab4cad4f86a3790d2394ecdf4852e67be (diff) |
version bump for pypi upload
* add comment about oauth version
* add pypi badge in README
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 21 |
1 files changed, 17 insertions, 4 deletions
@@ -30,7 +30,8 @@ install_requirements = [ 'pysqlcipher', 'simplejson', 'twisted>=12.0.0', # TODO: maybe we just want twisted-web? - 'oauth', + 'oauth', # this is not strictly needed by us, but we need it + # until u1db adds it to its release as a dep. 'u1db', 'requests', 'six==1.1.0', @@ -53,12 +54,23 @@ else: # XXX this should go only for linux/mac data_files = [("/etc/init.d/", ["pkg/soledad"])] +trove_classifiers = ( + "Development Status :: 3 - Alpha", + "Intended Audience :: Developers", + "License :: OSI Approved :: " + "GNU General Public License v3 or later (GPLv3+)", + "Environment :: Console", + "Operating System :: OS Independent", + "Operating System :: POSIX", + "Programming Language :: Python :: 2.6", + "Programming Language :: Python :: 2.7", + "Topic :: Database :: Front-Ends", + "Topic :: Software Development :: Libraries :: Python Modules" +) setup( name='leap.soledad', - # TODO: change version according to decisions regarding soledad versus - # leap client versions. - version='0.1.0', + version='0.1.1', url='https://leap.se/', license='GPLv3+', description='Synchronization of locally encrypted data among devices.', @@ -79,6 +91,7 @@ setup( install_requires=install_requirements, tests_require=tests_requirements, data_files=data_files, + classifiers=trove_classifiers, # the following files are only used for testing, and might be removed if # we manage or decide to not install tests in the future. package_data={ |