diff options
author | Tomás Touceda <chiiph@leap.se> | 2013-05-17 13:57:39 -0300 |
---|---|---|
committer | Tomás Touceda <chiiph@leap.se> | 2013-05-17 13:57:39 -0300 |
commit | 8db98c3871fb7632cb0c29b219d7a1abed32f280 (patch) | |
tree | dc2a37a49d9c5a8a121228978f68a3f594b6df51 /setup.py | |
parent | a55bcd926f94cd52d5a41cdd528672cdb8696f4b (diff) | |
parent | 1a2a3c6d72e173425885caa2342138c4615a69a3 (diff) |
Merge remote-tracking branch 'drebs/feature/2529-use-pycrypto-for-symmetric-encryption' into develop
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 20 |
1 files changed, 17 insertions, 3 deletions
@@ -15,6 +15,7 @@ # You should have received a copy of the GNU General Public License # along with this program. If not, see <http://www.gnu.org/licenses/>. + import os from setuptools import ( setup, @@ -52,7 +53,8 @@ install_requirements = [ dependency_links = [ #'git+git://git.futeisha.org/pysqlcipher.git@develop#egg=pysqlcipher', #'git+ssh://code.leap.se/leap_pycommon.git@develop#egg=leap.common', - 'http://twistedmatrix.com/Releases/Twisted/13.0/Twisted-13.0.0.tar.bz2#egg=twisted-13.0.0' + 'http://twistedmatrix.com/Releases/Twisted/13.0/Twisted-13.0.0.tar.bz2' + '#egg=twisted-13.0.0' # break the string to adhere to pep8 style. ] @@ -62,12 +64,14 @@ tests_requirements = [ 'testscenarios', ] + if os.environ.get('VIRTUAL_ENV', None): data_files = None else: # XXX this should go only for linux/mac data_files = [("/etc/init.d/", ["pkg/soledad"])] + setup( name='leap.soledad', # TODO: change version according to decisions regarding soledad versus @@ -84,11 +88,21 @@ setup( "LEAP client, an API for data storage and sync." ), namespace_packages=["leap"], - packages=find_packages('src', exclude=['leap.soledad.tests']), + # For now, we do not exclude tests because of the circular dependency + # between leap.common and leap.soledad. + #packages=find_packages('src', exclude=['leap.soledad.tests']), + packages=find_packages('src'), package_dir={'': 'src'}, test_suite='leap.soledad.tests', install_requires=install_requirements, tests_require=tests_requirements, dependency_links=dependency_links, - data_files = data_files + data_files=data_files, + # the following files are only used for testing, and might be removed if + # we manage or decide to not install tests in the future. + package_data={ + 'leap.soledad.tests.u1db_tests.testing-certs': [ + '*.pem', '*.cert', '*.key' + ] + } ) |