summaryrefslogtreecommitdiff
path: root/server
diff options
context:
space:
mode:
authorKali Kaneko <kali@leap.se>2013-09-12 14:10:19 +0200
committerKali Kaneko <kali@leap.se>2013-09-12 14:10:19 +0200
commit5889d7e20995f83ab7e8723b595081b573675164 (patch)
tree23541fb6acdd75bdd7af110e0322838785766282 /server
parent2e0b170edd8dd59215d588b570c315cebdbabcfa (diff)
parent6a72835b3fa7267ffcf30ae0e5b5fa948e296390 (diff)
Merge tag '0.3.2' into debian
Tag leap.soledad version 0.3.2
Diffstat (limited to 'server')
-rw-r--r--server/pkg/soledad2
-rw-r--r--server/setup.py5
-rw-r--r--server/src/leap/soledad/server/__init__.py2
3 files changed, 5 insertions, 4 deletions
diff --git a/server/pkg/soledad b/server/pkg/soledad
index c233731e..841233d1 100644
--- a/server/pkg/soledad
+++ b/server/pkg/soledad
@@ -12,7 +12,7 @@
PATH=/sbin:/bin:/usr/sbin:/usr/bin
PIDFILE=/var/run/soledad.pid
RUNDIR=/var/lib/soledad/
-OBJ=leap.soledad_server.application
+OBJ=leap.soledad.server.application
LOGFILE=/var/log/soledad.log
HTTPS_PORT=2424
CERT_PATH=/etc/leap/soledad-server.pem
diff --git a/server/setup.py b/server/setup.py
index 22be3fd3..348aa838 100644
--- a/server/setup.py
+++ b/server/setup.py
@@ -58,13 +58,14 @@ setup(
cmdclass=versioneer.get_cmdclass(),
url='https://leap.se/',
license='GPLv3+',
- description='Synchronization of locally encrypted data among devices.',
+ description='Synchronization of locally encrypted data among devices '
+ '(server components)',
author='The LEAP Encryption Access Project',
author_email='info@leap.se',
long_description=(
"Soledad is the part of LEAP that allows application data to be "
"securely shared among devices. It provides, to other parts of the "
- "LEAP client, an API for data storage and sync."
+ "LEAP project, an API for data storage and sync."
),
classifiers=trove_classifiers,
namespace_packages=["leap", "leap.soledad"],
diff --git a/server/src/leap/soledad/server/__init__.py b/server/src/leap/soledad/server/__init__.py
index 0c56acb9..67b0611d 100644
--- a/server/src/leap/soledad/server/__init__.py
+++ b/server/src/leap/soledad/server/__init__.py
@@ -20,7 +20,7 @@
A U1DB server that stores data using CouchDB as its persistence layer.
This should be run with:
- twistd -n web --wsgi=leap.soledad_server.application --port=2424
+ twistd -n web --wsgi=leap.soledad.server.application --port=2424
"""
import configparser