summaryrefslogtreecommitdiff
path: root/scripts/docker/Makefile
diff options
context:
space:
mode:
authordrebs <drebs@leap.se>2016-07-25 11:38:19 -0300
committerdrebs <drebs@leap.se>2016-08-01 21:09:03 -0300
commit8d08016b6e5985569ca5d04ef3e2690e78809f54 (patch)
treea1f46c7709226f554659a740c81d151513b5ff67 /scripts/docker/Makefile
parentbf9355077c2f190c82d660ad9b7059a1c3f32a8d (diff)
[test] use tox and couchdb image to run tests
Diffstat (limited to 'scripts/docker/Makefile')
-rw-r--r--scripts/docker/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/scripts/docker/Makefile b/scripts/docker/Makefile
index 4fa2e264..6f30a341 100644
--- a/scripts/docker/Makefile
+++ b/scripts/docker/Makefile
@@ -27,11 +27,14 @@ MEMORY ?= 512m
# Docker image generation (main make target) #
##############################################
-all: image
+all: soledad-image couchdb-image
-image:
+soledad-image:
docker build -t $(IMAGE_NAME) .
+couchdb-image:
+ docker pull couchdb
+
##################################################
# Run a Soledad Server inside a docker container #
##################################################
@@ -69,16 +72,18 @@ run-client-bootstrap:
/usr/local/soledad/run-client-bootstrap.sh
#################################################
-# Run all trial tests inside a docker container #
+# Run all tests inside a docker container #
#################################################
-run-trial:
+run-tox:
+ docker run -d --name couchdb couchdb
docker run -t -i \
--memory="$(MEMORY)" \
--env="SOLEDAD_REMOTE=$(SOLEDAD_REMOTE)" \
--env="SOLEDAD_BRANCH=$(SOLEDAD_BRANCH)" \
+ --link couchdb \
$(IMAGE_NAME) \
- /usr/local/soledad/run-trial.sh
+ /usr/local/soledad/run-tox.sh
############################################
# Performance tests and graphic generation #
@@ -123,7 +128,7 @@ cp-perf-result:
# Other helper targets #
########################
-run-shell: image
+run-shell: soledad-image
docker run -t -i \
--memory="$(MEMORY)" \
$(IMAGE_NAME) \