summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMicah Anderson <micah@riseup.net>2013-08-22 14:57:34 -0400
committerMicah Anderson <micah@riseup.net>2013-08-22 15:08:14 -0400
commit60eb02d82ea787d72ca8f8ff100e82ccadebc997 (patch)
tree0c2c3cc2131e043e46e23312b03f854fd6ebbf25 /debian
parent74e3e8ce861d20edc19ac7f858ba0f016f73b1b2 (diff)
update dependencies and create new binary package
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rw-r--r--debian/control26
-rw-r--r--debian/pydist-overrides2
-rwxr-xr-xdebian/rules10
4 files changed, 33 insertions, 13 deletions
diff --git a/debian/changelog b/debian/changelog
index 13551521..7553fc52 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+soledad (0.3.1pre) unstable; urgency=low
+
+ * Upgrade to latest code in develop
+ * Setup additional binary package
+ * Fix pydist-overrides for new package name
+
+ -- Micah Anderson <micah@debian.org> Thu, 22 Aug 2013 14:57:54 -0400
+
soledad (0.3.0.3) unstable; urgency=low
* Fixed missing epoch on python-twisted-conch
diff --git a/debian/control b/debian/control
index 3d198447..d4cf04db 100644
--- a/debian/control
+++ b/debian/control
@@ -2,21 +2,20 @@ Source: soledad
Section: python
Priority: optional
Maintainer: Micah Anderson <micah@debian.org>
-Build-Depends: python-setuptools (>= 0.6b3), python-all (>= 2.6.6-3), debhelper (>= 9),
- python-configparser, python-couchdb, python-leap-common, python-scrypt, python-mock,
- python-nose, python-testscenarios
+Build-Depends: python-setuptools (>= 0.6b3), python-all (>= 2.6.6-3), debhelper (>= 9)
Standards-Version: 3.9.4
Package: soledad-server
Architecture: all
Depends: ${misc:Depends}, ${python:Depends}, python-configparser, python-couchdb,
- python-leap-common, python-scrypt, python-gnupg, python-simplejson, python-requests,
+ python-simplejson, python-oauth, python-u1db, python-routes, python-openssl,
+ soledad-common (>= 0.3.0-1),
python-six, python-twisted (>= 13.0.0-1~bpo70+1), python-twisted-bin (>= 13.0.0-1~bpo70+1),
python-twisted-conch (>= 1:13.0.0-1~bpo70+1), python-twisted-core (>= 13.0.0-1~bpo70+1),
python-twisted-lore (>= 13.0.0-1~bpo70+1), python-twisted-mail (>= 13.0.0-1~bpo70+1),
python-twisted-names (>= 13.0.0-1~bpo70+1), python-twisted-news (>= 13.0.0-1~bpo70+1),
python-twisted-runner (>= 13.0.0-1~bpo70+1), python-twisted-words (>= 13.0.0-1~bpo70+1),
- python-twisted-web (>= 13.0.0-1~bpo70+1), python-sqlcipher, soledad-common
+ python-twisted-web (>= 13.0.0-1~bpo70+1)
Description: Synchronization of locally encrypted data among devices.
Soledad is the part of LEAP that allows application data to be securely
shared among devices. It provides, to other parts of the LEAP client, an
@@ -26,9 +25,8 @@ Description: Synchronization of locally encrypted data among devices.
Package: soledad-common
Architecture: all
-Depends: ${misc:Depends}, ${python:Depends}, python-sqlcipher, python-pysqlite1.1,
- python-simplejson, python-oauth, python-u1db, python-six, python-scrypt,
- python-xdg, python-pycryptopp, python-openssl
+Depends: ${misc:Depends}, ${python:Depends}, python-simplejson, python-oauth, python-u1db,
+ python-six
Description: Synchronization of locally encrypted data among devices.
Soledad is the part of LEAP that allows application data to be securely
shared among devices. It provides, to other parts of the LEAP client, an
@@ -36,3 +34,15 @@ Description: Synchronization of locally encrypted data among devices.
.
This package contains the common soledad libraries. For the server, see the
soledad-server package
+
+Package: soledad-client
+Architecture: all
+Depends: ${misc:Depends}, ${python:Depends}, python-sqlcipher, python-pysqlite1.1,
+ python-simplejson, python-oauth, python-u1db, python-scrypt,
+ python-xdg, python-pycryptopp, soledad-common
+Description: Synchronization of locally encrypted data among devices.
+ Soledad is the part of LEAP that allows application data to be securely
+ shared among devices. It provides, to other parts of the LEAP client, an
+ API for data storage and sync.
+ .
+ This package contains the soledad client.
diff --git a/debian/pydist-overrides b/debian/pydist-overrides
index 59e30938..e089c871 100644
--- a/debian/pydist-overrides
+++ b/debian/pydist-overrides
@@ -1,2 +1,2 @@
pysqlcipher python-sqlcipher
-leap.soledad soledad-common \ No newline at end of file
+python-leap.soledad.common soledad-common \ No newline at end of file
diff --git a/debian/rules b/debian/rules
index a09475c0..b1301dde 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,12 +4,14 @@
dh $@ --with python2
override_dh_auto_clean:
- cd soledad && python setup.py clean -a
- cd soledad_server && python setup.py clean -a
+ cd client && python setup.py clean -a
+ cd common && python setup.py clean -a
+ cd server && python setup.py clean -a
override_dh_auto_install:
- cd soledad && python setup.py install --root=../debian/soledad-common
- cd soledad_server && python setup.py install --root=../debian/soledad-server
+ cd common && python setup.py install --root=../debian/soledad-common
+ cd server && python setup.py install --root=../debian/soledad-server
+ cd client && python setup.py install --root=../debian/soledad-client