summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMicah Anderson <micah@riseup.net>2013-07-04 14:55:08 -0400
committerMicah Anderson <micah@riseup.net>2013-07-15 11:30:51 +0100
commit4ee69b253ad378b18d168c3082025be0c9e1a1a0 (patch)
treeaa5b7efcbdc037ae7b265e4c9266ff1a8116cbbe /debian
parente7abf1080661b9795e012307d6134c4f5db24315 (diff)
rename package to be soledad-server
Diffstat (limited to 'debian')
-rw-r--r--debian/control24
-rwxr-xr-xdebian/rules11
2 files changed, 30 insertions, 5 deletions
diff --git a/debian/control b/debian/control
index ca558a7a..be3c1861 100644
--- a/debian/control
+++ b/debian/control
@@ -1,17 +1,33 @@
Source: soledad
-Maintainer: Micah Anderson <micah@debian.org>
Section: python
Priority: optional
+Maintainer: Micah Anderson <micah@debian.org>
Build-Depends: python-setuptools (>= 0.6b3), python-all (>= 2.6.6-3), debhelper (>= 9),
- python-configparser, python-couchdb, python-leap-common, python-scrypt
+ python-configparser, python-couchdb, python-leap-common, python-scrypt, python-mock,
+ python-nose, python-testscenarios
Standards-Version: 3.9.4
-Package: python-soledad
+Package: soledad-server
Architecture: all
Depends: ${misc:Depends}, ${python:Depends}, python-configparser, python-couchdb,
python-leap-common, python-scrypt, python-gnupg, python-simplejson, python-requests,
- python-six, python-twisted-web, python-sqlcipher
+ python-six, python-twisted-web, python-sqlcipher, soledad-common
+Description: Synchronization of locally encrypted data among devices.
+ Soledad is the part of LEAP that allows application data to be securely
+ shared among devices. It provides, to other parts of the LEAP client, an
+ API for data storage and sync.
+ .
+ This package contains the server components.
+
+Package: soledad-common
+Architecture: all
+Depends: ${misc:Depends}, ${python:Depends}, python-sqlcipher, python-pysqlite1.1,
+ python-simplejson, python-oauth, python-u1db, python-six, python-scrypt,
+ python-xdg, python-pycryptopp, python-openssl
Description: Synchronization of locally encrypted data among devices.
Soledad is the part of LEAP that allows application data to be securely
shared among devices. It provides, to other parts of the LEAP client, an
API for data storage and sync.
+ .
+ This package contains the common soledad libraries. For the server, see the
+ soledad-server package
diff --git a/debian/rules b/debian/rules
index bcebae9f..a09475c0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,6 +1,15 @@
#!/usr/bin/make -f
%:
- dh $@ --with python2 --buildsystem=python_distutils
+ dh $@ --with python2
+
+override_dh_auto_clean:
+ cd soledad && python setup.py clean -a
+ cd soledad_server && python setup.py clean -a
+
+override_dh_auto_install:
+ cd soledad && python setup.py install --root=../debian/soledad-common
+ cd soledad_server && python setup.py install --root=../debian/soledad-server
+