summaryrefslogtreecommitdiff
path: root/client
diff options
context:
space:
mode:
authorIvan Alejandro <ivanalejandro0@gmail.com>2013-09-06 15:52:06 -0300
committerIvan Alejandro <ivanalejandro0@gmail.com>2013-09-06 15:52:06 -0300
commit86578e5e48fb394297da33f5f93ca07aed9e1af3 (patch)
tree70ffb63227d8b93224339267589a08297f3d58fb /client
parent21f58ccc9a29ee82faf0924ea03f39b3c91e43ee (diff)
parent6a72835b3fa7267ffcf30ae0e5b5fa948e296390 (diff)
Merge branch 'release-0.3.2'
Diffstat (limited to 'client')
-rw-r--r--client/pkg/requirements.pip1
-rw-r--r--client/setup.py5
-rw-r--r--client/src/leap/soledad/client/__init__.py7
3 files changed, 5 insertions, 8 deletions
diff --git a/client/pkg/requirements.pip b/client/pkg/requirements.pip
index 86b79bb2..df6ddb94 100644
--- a/client/pkg/requirements.pip
+++ b/client/pkg/requirements.pip
@@ -2,7 +2,6 @@ pysqlcipher
simplejson
u1db
scrypt
-pyxdg
pycryptopp
#
diff --git a/client/setup.py b/client/setup.py
index 142922a4..4f62809f 100644
--- a/client/setup.py
+++ b/client/setup.py
@@ -51,13 +51,14 @@ setup(
cmdclass=versioneer.get_cmdclass(),
url='https://leap.se/',
license='GPLv3+',
- description='Synchronization of locally encrypted data among devices.',
+ description='Synchronization of locally encrypted data among devices '
+ '(client components).',
author='The LEAP Encryption Access Project',
author_email='info@leap.se',
long_description=(
"Soledad is the part of LEAP that allows application data to be "
"securely shared among devices. It provides, to other parts of the "
- "LEAP client, an API for data storage and sync."
+ "LEAP project, an API for data storage and sync."
),
classifiers=trove_classifiers,
namespace_packages=["leap", "leap.soledad"],
diff --git a/client/src/leap/soledad/client/__init__.py b/client/src/leap/soledad/client/__init__.py
index df2b30c2..c6fbeac4 100644
--- a/client/src/leap/soledad/client/__init__.py
+++ b/client/src/leap/soledad/client/__init__.py
@@ -37,12 +37,11 @@ import socket
import ssl
import errno
-
-from xdg import BaseDirectory
from hashlib import sha256
from u1db.remote import http_client
from u1db.remote.ssl_match_hostname import match_hostname
+from leap.common.config import get_path_prefix
#
# Signaling function
@@ -218,9 +217,7 @@ class Soledad(object):
Keys used to access storage secrets in recovery documents.
"""
- DEFAULT_PREFIX = os.path.join(
- BaseDirectory.xdg_config_home,
- 'leap', 'soledad')
+ DEFAULT_PREFIX = os.path.join(get_path_prefix(), 'leap', 'soledad')
"""
Prefix for default values for path.
"""