summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authordrebs <drebs@leap.se>2017-06-23 22:32:44 -0300
committerdrebs <drebs@leap.se>2017-06-23 22:32:44 -0300
commitef59174956aef2173cc0a7fa444def3b7841f1e0 (patch)
tree4332f470de03d7524ad84decf1ec95e5148a29f5
parent1f71dca7faf9e612ccbb0f91facc710395ef8fd0 (diff)
[pkg] skip init.d if building in readthedocs
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index b86c7b4c..d7c1eeaf 100644
--- a/setup.py
+++ b/setup.py
@@ -28,7 +28,8 @@ from setuptools.command.develop import develop as _cmd_develop
isset = lambda var: os.environ.get(var, None)
-if isset('VIRTUAL_ENV') or isset('LEAP_SKIP_INIT'):
+skip = ['VIRTUAL_ENV', 'LEAP_SKIP_INIT', 'READTHEDOCS']
+if len(filter(isset, skip)):
data_files = None
else:
# XXX this should go only for linux/mac