summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKali Kaneko <kali@leap.se>2017-06-26 11:58:45 +0200
committerKali Kaneko <kali@leap.se>2017-06-26 12:22:24 +0200
commitb5eeb5da51192e6653c23bfcd1d8e756a129215f (patch)
tree81d502875b3956d8a11a742c7eb8b7faf40cbae6
parent2082cab5c8ac8e29d4267d77f8ef9aad3200b71b (diff)
[pkg] split the binary packages
-rw-r--r--debian/changelog6
-rw-r--r--debian/control13
-rwxr-xr-xdebian/rules23
-rw-r--r--debian/soledad-client.install1
-rw-r--r--debian/soledad-common.install1
-rw-r--r--debian/soledad-server.install3
6 files changed, 23 insertions, 24 deletions
diff --git a/debian/changelog b/debian/changelog
index bfcfab1c..0d6415ad 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+soledad (0.9.6) UNRELEASED; urgency=medium
+
+ * Update to 0.9.6 release.
+
+ -- Ben Carrillo <ben@futeisha.org> Mon, 26 Jun 2017 11:36:23 +0200
+
soledad (0.8.1+nmu1) unstable; urgency=medium
* Update do 0.8.1 release (NMU).
diff --git a/debian/control b/debian/control
index 9aba9185..fb33d653 100644
--- a/debian/control
+++ b/debian/control
@@ -8,9 +8,9 @@ Standards-Version: 3.9.8
Package: soledad-server
Architecture: all
+Provides: leap.soledad.server, ${python:Provides}
Depends: ${misc:Depends}, ${python:Depends}, lsb-base (>= 3.0-6), python-configparser, python-couchdb,
- python-simplejson, python-oauth, python-u1db, python-routes, python-openssl,
- soledad-common (>= 0.8.0), python-six, python-twisted-web (>= 13.0.0-1~bpo70+1),
+ python-simplejson, python-oauth, python-routes, python-six, python-twisted-web (>= 13.0.0-1~bpo70+1),
sudo
Description: Synchronization of locally encrypted data among devices (server files)
Soledad is the part of LEAP that allows application data to be securely
@@ -21,7 +21,8 @@ Description: Synchronization of locally encrypted data among devices (server fil
Package: soledad-common
Architecture: all
-Depends: ${misc:Depends}, ${python:Depends}, python-simplejson, python-oauth, python-u1db, python-six
+Provides: leap.soledad.common, ${python:Provides}
+Depends: ${misc:Depends}, ${python:Depends}, python-simplejson, python-six, python-twisted-core (>= 13.0.0)
Description: Synchronization of locally encrypted data among devices (common files)
Soledad is the part of LEAP that allows application data to be securely
shared among devices. It provides, to other parts of the LEAP client, an
@@ -32,10 +33,10 @@ Description: Synchronization of locally encrypted data among devices (common fil
Package: soledad-client
Architecture: all
+Provides: leap.soledad.client, ${python:Provides}
Depends: ${misc:Depends}, ${python:Depends}, python-sqlcipher (>= 2.6.3.3+b1),
- python-simplejson, python-oauth, python-u1db, python-scrypt,
- python-dirspec, soledad-common, python-chardet,
- python-twisted-core (>= 13.0.0)
+ python-simplejson, python-scrypt,
+ python-dirspec, python-chardet,
Description: Synchronization of locally encrypted data among devices (client files)
Soledad is the part of LEAP that allows application data to be securely
shared among devices. It provides, to other parts of the LEAP client, an
diff --git a/debian/rules b/debian/rules
index 1ffc91e7..21511556 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,23 +6,12 @@
%:
dh $@ --with python2 --namespace=leap.soledad
-override_dh_auto_clean:
- cd client && python setup.py clean -a
- cd common && python setup.py clean -a
- cd server && python setup.py clean -a
-
-override_dh_auto_install:
- cd client && python setup.py install --root=../debian/soledad-client
- cd common && python setup.py install --root=../debian/soledad-common
- cd server && LEAP_SKIP_INIT=1 python setup.py install --root=../debian/soledad-server
-
-override_dh_install:
- # leap.soledad provides the leap.soledad namespace __init__.py
- for pv in $(shell pyversions -vr debian/control); do \
- cp common/src/leap/__init__.py debian/soledad-common/usr/local/lib/python$$pv/*-packages/leap/; \
- cp common/src/leap/__init__.py debian/soledad-common/usr/local/lib/python$$pv/*-packages/leap/soledad/; \
- done
- dh_install
+#override_dh_auto_install:
+ #cd client && python setup.py install --root=../debian/soledad-client
+ #cd common && python setup.py install --root=../debian/soledad-common
+ #cd server &&
+ # --root=../debian/soledad-server
+ #LEAP_SKIP_INIT=1 python setup.py install
override_dh_auto_clean:
dh_auto_clean
diff --git a/debian/soledad-client.install b/debian/soledad-client.install
new file mode 100644
index 00000000..6773f066
--- /dev/null
+++ b/debian/soledad-client.install
@@ -0,0 +1 @@
+src/leap/soledad/client /usr/lib/python2.7/dist-packages/leap/soledad/
diff --git a/debian/soledad-common.install b/debian/soledad-common.install
new file mode 100644
index 00000000..af959ed8
--- /dev/null
+++ b/debian/soledad-common.install
@@ -0,0 +1 @@
+src/leap/soledad/common /usr/lib/python2.7/dist-packages/leap/soledad/
diff --git a/debian/soledad-server.install b/debian/soledad-server.install
index 01342c4b..91a4426b 100644
--- a/debian/soledad-server.install
+++ b/debian/soledad-server.install
@@ -1,2 +1,3 @@
-server/pkg/create-user-db usr/bin/
+pkg/server/soledad-create-userdb usr/bin/
debian/soledad-sudoers etc/sudoers.d/
+src/leap/soledad/server usr/lib/python2.7/dist-packages/leap/soledad/