summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authordrebs <drebs@leap.se>2015-03-19 10:32:34 -0300
committerdrebs <drebs@leap.se>2015-03-19 11:52:48 -0300
commit22adcae07584773a100bf304162113a9326a3866 (patch)
tree2fb2d20e66c13ca7e1249248d3136c1bdca9ebe2
parent4b78cf9da0874501fa123a02b53d7650e8dfcdf1 (diff)
[fix] exclude all tests from package
Previous to this modification, leap.soledad.common.tests.u1db_tests was being installed and its files were being included in the debian package. By excluding *.tests and *.tests.* from find_packages() in setup.py, we make sure that no test file will be installed not included in the final debian package.
-rw-r--r--common/setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/common/setup.py b/common/setup.py
index b0ab8352..f4d8bc65 100644
--- a/common/setup.py
+++ b/common/setup.py
@@ -270,7 +270,7 @@ setup(
),
classifiers=trove_classifiers,
namespace_packages=["leap", "leap.soledad"],
- packages=find_packages('src', exclude=['leap.soledad.common.tests']),
+ packages=find_packages('src', exclude=['*.tests', '*.tests.*']),
package_dir={'': 'src'},
test_suite='leap.soledad.common.tests',
install_requires=utils.parse_requirements(),