diff options
author | drebs <drebs@leap.se> | 2013-04-04 14:14:41 -0300 |
---|---|---|
committer | drebs <drebs@leap.se> | 2013-04-04 14:15:12 -0300 |
commit | d2d35a449beb05799bd68a7679f58382f8599152 (patch) | |
tree | 90cb2724da73640101bd28b9a76060972ec32d30 | |
parent | d547d8e465d28838249e2576b598f009d0000333 (diff) |
Add Twisted as dependency.
-rw-r--r-- | setup.py | 25 |
1 files changed, 18 insertions, 7 deletions
@@ -5,14 +5,24 @@ from setuptools import ( install_requirements = [ - 'python-gnupg', - 'u1db', - 'oauth', - 'couchdb', 'configparser', - 'simplejson', - 'pysqlcipher', + 'couchdb', 'leap.common', + 'oauth', + 'pysqlcipher', + 'python-gnupg', + 'simplejson', + # "Installation of Twisted using easy_install with a local source directory + # is supported. In the past there have been problems using these tools to + # upgrade an existing version of Twisted, and these problems likely still + # exist. Similarly, there are often problems when Twisted is declared as a + # dependency by another project using the setuptools distutils extensions. + # You should probably not rely on this functionality. Instead, install a + # platform-supplied package, or install Twisted by downloading a tarball, + # unpacking it, and running setup.py." + # - https://twistedmatrix.com/trac/wiki/FrequentlyAskedQuestions + 'twisted==13.0.0', # TODO: maybe we just want twisted-web? + 'u1db', ] @@ -20,6 +30,7 @@ install_requirements = [ dependency_links = [ 'git+git://git.futeisha.org/pysqlcipher.git@develop#egg=pysqlcipher', 'git+ssh://code.leap.se/leap_pycommon.git@develop#egg=leap_pycommon', + 'http://twistedmatrix.com/Releases/Twisted/13.0/Twisted-13.0.0.tar.bz2#egg=twisted-13.0.0' ] @@ -46,7 +57,7 @@ setup( ), namespace_packages=["leap"], packages=find_packages('src', exclude=['leap.soledad.tests']), - package_dir = {'': 'src'}, + package_dir={'': 'src'}, test_suite='nose2.collector.collector', install_requires=install_requirements, tests_require=tests_requirements, |