diff options
author | Kali Kaneko <kali@leap.se> | 2013-11-15 23:37:47 -0200 |
---|---|---|
committer | Kali Kaneko <kali@leap.se> | 2013-11-15 23:37:47 -0200 |
commit | 250f721c46dd096afcfbcd362886ca87de828c65 (patch) | |
tree | f65476b5c115321aeb63eb90b4d7be4d14027933 | |
parent | 6b66be2eb6592da120b1a6799747b87b5733ced7 (diff) | |
parent | 0ade4a7e3a323df631c9772e4db5173a20979d46 (diff) |
Merge tag '0.4.3' into debian
Tag leap.soledad version 0.4.3
-rw-r--r-- | CHANGELOG | 6 | ||||
-rw-r--r-- | docs/debian-repackaging.rst | 41 |
2 files changed, 47 insertions, 0 deletions
@@ -1,3 +1,9 @@ +0.4.3 Nov 15: + o Defaults detected encoding to utf-8 to avoid bug if detected + encoding is None. Closes: #4417 + o Open db in autocommit mode, to avoid nested transactions problems. + Closes: #4400 + 0.4.2 Nov 1: Client: o Support non-ascii passwords. Closes #4001. diff --git a/docs/debian-repackaging.rst b/docs/debian-repackaging.rst new file mode 100644 index 00000000..a7488a84 --- /dev/null +++ b/docs/debian-repackaging.rst @@ -0,0 +1,41 @@ +repackaging howto +================= + +How to repackage latest code +---------------------------- + +Enter debian branch:: + + git checkout debian + +Merge your latest and greatest:: + + git merge develop + +Bump the changelog:: + + vim debian/changelog + +dch should also get you there, adding a new entry. + +Edit the changelog so you get a new version (this is the version +that apt will report). For example, change:: + + soledad-common (0.3.4) unstable; urgency=low + +to:: + + soledad-common (0.3.4-1~testing_frobnication) unstable; urgency=low + + +Last, but not least, freeze the debian version:: + + python setup.py freeze_debianver + +It might be a good idea to edit by hand the version string +under _version too, so it's clear that you're packaging some bleeding +edge not to be confused with latest stable packages. + +And now you can happily repackage for your own deploys:: + + debuild -us -uc |