diff options
author | Tomás Touceda <chiiph@leap.se> | 2013-05-30 13:56:16 -0300 |
---|---|---|
committer | Tomás Touceda <chiiph@leap.se> | 2013-05-30 13:56:16 -0300 |
commit | aa36b326842be61a3063185e28a25a6fbf8270c9 (patch) | |
tree | 50a51aa9f8b38f0343fbc8c0475ddd437c62dce1 | |
parent | c2b0e9dab4cad4f86a3790d2394ecdf4852e67be (diff) | |
parent | eb1f487dc762e17331967365477d58932b7656db (diff) |
Merge remote-tracking branch 'kali/feature/version-bump' into develop
-rw-r--r-- | README.rst | 10 | ||||
-rw-r--r-- | setup.py | 21 |
2 files changed, 24 insertions, 7 deletions
@@ -1,12 +1,16 @@ -Soledad -- Synchronization Of Locally Encrypted Data Among Devices +Soledad ================================================================== +*Synchronization Of Locally Encrypted Data Among Devices* + +.. image:: https://pypip.in/v/leap.soledad/badge.png + :target: https://crate.io/packages/leap.soledad This software is under development. Tests ----- -To run CouchDB tests, be sure you have CouchDB installed on your system. -Tests can be run with: +To run CouchDB tests, be sure you have ``CouchDB`` installed on your system. +Tests can be run with:: python setup.py test @@ -30,7 +30,8 @@ install_requirements = [ 'pysqlcipher', 'simplejson', 'twisted>=12.0.0', # TODO: maybe we just want twisted-web? - 'oauth', + 'oauth', # this is not strictly needed by us, but we need it + # until u1db adds it to its release as a dep. 'u1db', 'requests', 'six==1.1.0', @@ -53,12 +54,23 @@ else: # XXX this should go only for linux/mac data_files = [("/etc/init.d/", ["pkg/soledad"])] +trove_classifiers = ( + "Development Status :: 3 - Alpha", + "Intended Audience :: Developers", + "License :: OSI Approved :: " + "GNU General Public License v3 or later (GPLv3+)", + "Environment :: Console", + "Operating System :: OS Independent", + "Operating System :: POSIX", + "Programming Language :: Python :: 2.6", + "Programming Language :: Python :: 2.7", + "Topic :: Database :: Front-Ends", + "Topic :: Software Development :: Libraries :: Python Modules" +) setup( name='leap.soledad', - # TODO: change version according to decisions regarding soledad versus - # leap client versions. - version='0.1.0', + version='0.1.1', url='https://leap.se/', license='GPLv3+', description='Synchronization of locally encrypted data among devices.', @@ -79,6 +91,7 @@ setup( install_requires=install_requirements, tests_require=tests_requirements, data_files=data_files, + classifiers=trove_classifiers, # the following files are only used for testing, and might be removed if # we manage or decide to not install tests in the future. package_data={ |