Dont default to unpriv. user
[scripts.git] / docker / ruby / Dockerfile
1 FROM leapcode/jessie
2
3 MAINTAINER LEAP Encryption Access Project <info@leap.se>
4 LABEL Description="Ruby 2.1 build tools to build leap_cli etc" Vendor="LEAP" Version="3.x"
5
6 # install leap_cli prerequisites, see https://0xacab.org/leap/leap_cli
7 # and tools needed for ci (moreutils and expect)
8 RUN apt-get update \
9   && apt-get install -y --no-install-recommends \
10     ruby \
11     ruby-dev \
12     build-essential \
13     rsync \
14     openssh-client \
15     openssl \
16     rake \
17     gcc \
18     make \
19     zlib1g-dev \
20     moreutils \
21     tcl \
22     expect \
23     jq \
24     netcat \
25   && apt-get clean \
26   && rm -rf /var/lib/apt/lists/*
27
28 RUN echo '---\n:sources:\n  - https://rubygems.org/\ninstall: --no-document\nupdate: --no-document\n' > /etc/gemrc
29 RUN gem install bundler