Added Dockerfile for leapcode/ruby
[scripts.git] / docker / ruby / Dockerfile
1 # start with a fresh official ruby image
2 # https://hub.docker.com/_/ruby/
3 FROM ruby:2.1-slim
4
5 MAINTAINER LEAP Encryption Access Project <info@leap.se>
6 LABEL Description="Ruby 2.1 including sudo and build tools to build leap_cli etc" Vendor="LEAP" Version="1.0"
7
8 # for unknown reason, "rake install" fails in docker, even if the userid is 0
9 # so we need to install sudo to use "sudo rake install"
10 RUN apt-get update
11 RUN apt-get -y install sudo
12
13 # install leap_cli prerequisites, see https://0xacab.org/leap/leap_cli
14 RUN apt-get -y install git ruby ruby-dev rsync openssh-client openssl rake gcc make zlib1g-dev
15