added authenticate! which raises SRP::WrongPassword if it fails, version 0.0.2
-rw-r--r-- 110 .gitmodules
-rw-r--r-- 281 Readme.md
drwxr-xr-x - example
drwxr-xr-x - lib
-rw-r--r-- 972 ruby-srp.gemspec
drwxr-xr-x - test