summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rwxr-xr-xMakefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 1142e21..3700872 100755
--- a/Makefile
+++ b/Makefile
@@ -2,7 +2,15 @@ SYSTRAY := 0xacab.org/leap/bitmask-systray
STAGING := staging
deps_win:
- choco install -y golang python upx nssm nsis
+ choco install -y golang python upx nssm nsis wget 7zip
+openvpn_win:
+ mkdir staging\openvpn
+ wget https://downloads.leap.se/thirdparty/windows/openvpn-x86_64-w64-mingw32.tar.bz2 -O staging/openvpn/openvpn.tar.bz2
+ 7z e -y -ostaging/openvpn/ staging/openvpn/openvpn.tar.bz2
+ 7z e -y -r -ostaging/openvpn/ staging/openvpn/openvpn.tar *.dll
+ 7z e -y -r -ostaging/openvpn/ staging/openvpn/openvpn.tar *.exe
+ copy .\staging\openvpn\openvpn.exe .\staging
+ copy .\staging\openvpn\*.dll .\staging
helper_win:
go build -ldflags "-s -w" -o $(STAGING)/bitmask_helper.exe .\helper
upx $(STAGING)/bitmask_helper.exe