summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkali <kali@win>2018-06-27 20:27:18 +0200
committerKali Kaneko (leap communications) <kali@leap.se>2018-06-27 20:34:15 +0200
commite6a04e5a7b7c669a03e6d782c795e40fedce526c (patch)
treeaa4d1ce1cd17c5bf33351f8844a140933cd8cef1
parent8b0ad0c146015cfeef6abd4373ca99a3b4e57826 (diff)
[pkg] compile and pack helper
-rwxr-xr-xMakefile26
-rw-r--r--README.txt50
-rwxr-xr-xwin/template.nsi6
3 files changed, 50 insertions, 32 deletions
diff --git a/Makefile b/Makefile
index e12223d..99ffb4d 100755
--- a/Makefile
+++ b/Makefile
@@ -1,10 +1,20 @@
-
-build_osx:
- echo "[+] building osx"
-build_win:
+SYSTRAY := 0xacab.org/leap/bitmask-systray
+STAGING := staging
+
+deps_win:
+ choco install -y golang python upx nssm nsis
+helper_win:
+ go build -ldflags "-s -w" -o $(STAGING)/bitmask_helper.exe .\helper
+ upx $(STAGING)/bitmask_helper.exe
+systray_win:
+ go get -u $(SYSTRAY)
+ go build -tags "standalone" -ldflags "-H windowsgui -s -w" -o $(STAGING)/bitmask-systray.exe $(SYSTRAY)
+build_win: helper_win
+ echo "[+] building windows"
if not exist dist mkdir dist
make -C win
- echo "[+] building windows"
- "C:\Program Files (x86)\NSIS\makensis.exe" win/RiseupVPN-installer.nsi
-build_snap:
- echo "[+] building snap"
+ "C:\Program Files (x86)\NSIS\makensis.exe" win/RiseupVPN-installer.nsi
+build_osx:
+ echo "[+] building osx"
+build_snap:
+ echo "[+] building snap"
diff --git a/README.txt b/README.txt
index c13680c..a03338f 100644
--- a/README.txt
+++ b/README.txt
@@ -1,23 +1,29 @@
-RiseupVPN
------------------------
-
-Anonymous VPN. Easy, fast, secure.
-
-This repo has everything needed to build RiseupVPN on different platforms
-(windows, mac, linux).
-
-RiseupVPN is a branded build of Bitmask Lite, written in go.
-
-
-Dependencies
-------------------------
-
-* golang
-* make
+RiseupVPN
+-----------------------
+
+Anonymous VPN. Easy, fast, secure.
+
+This repo has everything needed to build RiseupVPN on different platforms
+(windows, mac, linux).
+
+RiseupVPN is a branded build of Bitmask Lite, written in go.
+
+
+Dependencies
+------------------------
+
+* golang
+* make
* python (python3, for building scripts)
-
-Dependencies (Windows)
-------------------------
-
-* nsis
-* nssm
+
+Dependencies (Windows)
+------------------------
+
+* nsis
+* nssm
+
+Building (Windows)
+------------------------
+
+make deps_win
+make build_win
diff --git a/win/template.nsi b/win/template.nsi
index 009be7b..7870606 100755
--- a/win/template.nsi
+++ b/win/template.nsi
@@ -1,11 +1,10 @@
!include "MUI.nsh"
Name "$app_name"
-RequestExecutionLevel admin
-
Outfile "..\dist\$app_name-installer.exe"
;TODO make the installdir configurable - and set it in the registry.
InstallDir "C:\Program Files\$app_name\"
+RequestExecutionLevel admin
!define BITMAP_FILE riseupvpn.bmp
@@ -78,6 +77,9 @@ Section "InstallService"
ExecWait '"$INSTDIR\nssm.exe" set $app_name_lower-helper AppDirectory "$INSTDIR"'
ExecWait '"$INSTDIR\nssm.exe" start $app_name_lower-helper'
+ ; why are these here?
+ Delete "C:\$app_name_lower.ico"
+ Delete "C:\$app_name_lower.png"
SectionEnd
Section "Uninstall"