summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkali <kali@win>2018-06-28 21:59:11 +0200
committerKali Kaneko (leap communications) <kali@leap.se>2018-07-03 01:59:35 +0200
commitade90be44d10cad7f43fd89130bb99b019f6545e (patch)
tree8467eda4d373a8264606c3b6fd2a5365dde3212e
parent6b375cb6b0620fc7005e4181631e52297149b59f (diff)
[pkg] get openvpn from leap
-rwxr-xr-xMakefile10
-rwxr-xr-xwin/RiseupVPN-installer.nsi6
-rwxr-xr-xwin/payload/install8
3 files changed, 17 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index 1142e21..3700872 100755
--- a/Makefile
+++ b/Makefile
@@ -2,7 +2,15 @@ SYSTRAY := 0xacab.org/leap/bitmask-systray
STAGING := staging
deps_win:
- choco install -y golang python upx nssm nsis
+ choco install -y golang python upx nssm nsis wget 7zip
+openvpn_win:
+ mkdir staging\openvpn
+ wget https://downloads.leap.se/thirdparty/windows/openvpn-x86_64-w64-mingw32.tar.bz2 -O staging/openvpn/openvpn.tar.bz2
+ 7z e -y -ostaging/openvpn/ staging/openvpn/openvpn.tar.bz2
+ 7z e -y -r -ostaging/openvpn/ staging/openvpn/openvpn.tar *.dll
+ 7z e -y -r -ostaging/openvpn/ staging/openvpn/openvpn.tar *.exe
+ copy .\staging\openvpn\openvpn.exe .\staging
+ copy .\staging\openvpn\*.dll .\staging
helper_win:
go build -ldflags "-s -w" -o $(STAGING)/bitmask_helper.exe .\helper
upx $(STAGING)/bitmask_helper.exe
diff --git a/win/RiseupVPN-installer.nsi b/win/RiseupVPN-installer.nsi
index 3561c57..e1fc135 100755
--- a/win/RiseupVPN-installer.nsi
+++ b/win/RiseupVPN-installer.nsi
@@ -1,11 +1,10 @@
!include "MUI.nsh"
Name "RiseupVPN"
-RequestExecutionLevel admin
-
Outfile "..\dist\RiseupVPN-installer.exe"
;TODO make the installdir configurable - and set it in the registry.
InstallDir "C:\Program Files\RiseupVPN\"
+RequestExecutionLevel admin
!define BITMAP_FILE riseupvpn.bmp
@@ -87,6 +86,9 @@ Section "InstallService"
ExecWait '"$INSTDIR\nssm.exe" set riseupvpn-helper AppDirectory "$INSTDIR"'
ExecWait '"$INSTDIR\nssm.exe" start riseupvpn-helper'
+ ; why are these here?
+ Delete "C:\riseupvpn.ico"
+ Delete "C:\riseupvpn.png"
SectionEnd
Section "Uninstall"
diff --git a/win/payload/install b/win/payload/install
index 2ce1159..465491d 100755
--- a/win/payload/install
+++ b/win/payload/install
@@ -1,8 +1,8 @@
..\staging\bitmask_helper.exe
..\staging\bitmask-systray.exe
-..\staging\openssl.exe
-..\staging\openvpn.exe
-..\staging\ssleay32.dll
-..\staging\libeay32.dll
+..\staging\libcrypto-1_1-x64.dll
..\staging\liblzo2-2.dll
..\staging\libpkcs11-helper-1.dll
+..\staging\libssl-1_1-x64.dll
+..\staging\openvpn.exe
+..\staging\padlock.dll