summaryrefslogtreecommitdiff
path: root/setupegg.py
diff options
context:
space:
mode:
Diffstat (limited to 'setupegg.py')
-rw-r--r--setupegg.py11
1 files changed, 11 insertions, 0 deletions
diff --git a/setupegg.py b/setupegg.py
new file mode 100644
index 0000000..2c2c9aa
--- /dev/null
+++ b/setupegg.py
@@ -0,0 +1,11 @@
+#!/usr/bin/env python
+"""Wrapper to run setup.py using setuptools."""
+
+import os, sys
+
+# now, import setuptools and call the actual setup
+import setuptools
+try:
+ execfile('setup.py')
+except NameError:
+ exec( open('setup.py','rb').read() )