summaryrefslogtreecommitdiff
path: root/setupegg.py
diff options
context:
space:
mode:
authorMicah Anderson <micah@riseup.net>2014-08-11 16:33:29 -0400
committerMicah Anderson <micah@riseup.net>2014-08-11 16:33:29 -0400
commitcce638a8adf4e045ca5505afea4bda57753c31dd (patch)
treeb5e139d3359ac5b8c7b1afa8acbb1b5b6051c626 /setupegg.py
initial import of debian package
Diffstat (limited to 'setupegg.py')
-rw-r--r--setupegg.py11
1 files changed, 11 insertions, 0 deletions
diff --git a/setupegg.py b/setupegg.py
new file mode 100644
index 0000000..2c2c9aa
--- /dev/null
+++ b/setupegg.py
@@ -0,0 +1,11 @@
+#!/usr/bin/env python
+"""Wrapper to run setup.py using setuptools."""
+
+import os, sys
+
+# now, import setuptools and call the actual setup
+import setuptools
+try:
+ execfile('setup.py')
+except NameError:
+ exec( open('setup.py','rb').read() )