summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
authorMicah Anderson <micah@riseup.net>2014-11-11 11:53:55 -0500
committerMicah Anderson <micah@riseup.net>2014-11-11 11:53:55 -0500
commit7d5c3dcd969161322deed6c43f8a6a3cb92c3369 (patch)
tree109b05c88c7252d7609ef324d62ef9dd7f06123f /.travis.yml
parent44be832c5708baadd146cb954befbc3dcad8d463 (diff)
upgrade to 14.4.1upstream/14.4.1
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml48
1 files changed, 48 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..d16b810
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,48 @@
+language: python
+
+cache:
+ apt
+ pip
+python:
+ - 2.6
+ - 2.7
+ - 3.2
+ - 3.3
+ - 3.4
+ - pypy
+env:
+ - ZMQ=
+ - ZMQ=bundled
+ - ZMQ=master
+before_install:
+ - sudo add-apt-repository -y ppa:shnatsel/dnscrypt
+ - sudo apt-get update
+ - if [[ $ZMQ != 'bundled' ]]; then sudo apt-get install -qq libzmq3-dev libsodium-dev; fi
+ - if [[ $TRAVIS_PYTHON_VERSION != 'pypy' ]]; then pip install -q cython --install-option='--no-cython-compile'; fi
+
+ - if [[ $ZMQ == 'master' ]]; then git clone --depth 1 https://github.com/zeromq/libzmq; fi
+ - if [[ $ZMQ == 'master' ]]; then sh -c 'cd libzmq; sh autogen.sh; ./configure; make -j; sudo make install; sudo ldconfig'; fi
+ - pip install -q --use-mirrors nose
+
+install:
+ - if [[ $ZMQ == 'master' ]]; then export ZMQ=/usr/local; fi
+ - python setup.py build_ext --inplace --zmq=$ZMQ
+
+matrix:
+ exclude:
+ - python: 2.6
+ env: ZMQ=bundled
+ - python: 2.6
+ env: ZMQ=master
+ - python: 3.2
+ env: ZMQ=bundled
+ - python: 3.2
+ env: ZMQ=master
+ - python: 3.3
+ env: ZMQ=bundled
+ - python: 3.3
+ env: ZMQ=master
+ allow_failures:
+ - env: ZMQ=master
+
+script: python setup.py test