summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control43
-rw-r--r--debian/copyright56
-rw-r--r--debian/docs2
-rwxr-xr-xdebian/rules46
-rw-r--r--debian/source/format1
-rw-r--r--debian/watch3
8 files changed, 157 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..e726b0b
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+python-srp (1.0.2-1) unstable; urgency=low
+
+ * Initial release. Closes: 699122
+
+ -- Ben Carrillo <ben@futeisha.org> Mon, 28 Jan 2013 06:37:21 +0900
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..7acbcd9
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,43 @@
+Source: python-srp
+Maintainer: Ben Carrillo <ben@futeisha.org>
+Section: python
+Priority: optional
+Build-Depends:
+ python-all-dev (>= 2.6.6-3),
+ debhelper (>= 9),
+ python-sphinx (>= 1.0.7+dfsg),
+Standards-Version: 3.9.4
+X-Python-Version: >= 2.6
+Vcs-Hg: https://code.google.com/p/pysrp/
+Vcs-Browser: http://code.google.com/p/pysrp/source/browse/
+Homepage: http://code.google.com/p/pysrp/
+
+Package: python-srp
+Architecture: any
+Depends:
+ ${misc:Depends},
+ ${python:Depends},
+ ${shlibs:Depends},
+ ${sphinxdoc:Depends}
+Description: Secure Remote Password protocol implementation
+ This package provides an implementation of the Secure Remote Password
+ protocol (SRP). SRP is a cryptographically strong authentication
+ protocol for password-based, mutual authentication over an insecure
+ network connection.
+ .
+ Unlike other common challenge-response autentication protocols, such
+ as Kereros and SSL, SRP does not rely on an external infrastructure
+ of trusted key servers or certificate management. Instead, SRP server
+ applications use verification keys derived from each user's password
+ to determine the authenticity of a network connection.
+ .
+ SRP provides mutual-authentication in that successful authentication
+ requires both sides of the connection to have knowledge of the
+ user's password. If the client side lacks the user's password or the
+ server side lacks the proper verification key, the authentication will
+ fail.
+ .
+ Unlike SSL, SRP does not directly encrypt all data flowing through
+ the authenticated connection. However, successful authentication does
+ result in a cryptographically strong shared key that can be used
+ for symmetric-key encryption.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..33bc8d5
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,56 @@
+Format: http://dep.debian.net/deps/dep5
+Upstream-Name: srp
+Source: http://pypi.python.org/pypi/srp/
+
+Files: *
+Copyright: 2010, Tom Cocagne
+License: New BSD
+ All rights reserved.
+ Redistribution and use in source and binary forms, with or without
+ modification, are permitted provided that the following conditions are met:
+ .
+ * Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+ * Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ * Neither the name of the Python Software Foundation nor the
+ names of its contributors may be used to endorse or promote products
+ derived from this software without specific prior written permission.
+ .
+ THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+ ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+ WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+ DISCLAIMED. IN NO EVENT SHALL TOM COCAGNE BE LIABLE FOR ANY
+ DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+ (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+ LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+ ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+ (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+ SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+Files: debian/*
+Copyright: 2013 Ben Carrillo <ben@futeisha.org>
+License: BSD-3-clause
+ Redistribution and use in source and binary forms, with or without
+ modification, are permitted provided that the following conditions
+ are met:
+ .
+ 1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+ 2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ 3. The name of the author may not be used to endorse or promote products
+ derived from this software without specific prior written permission.
+ .
+ THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR
+ IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
+ OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
+ IN NO EVENT SHALL THE AUTOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+ SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
+ TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
+ PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
+ LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+ NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+ SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..45f302f
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1,2 @@
+README.txt
+LICENSE
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..706fc3e
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,46 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+PYVERS := $(shell pyversions -r)
+
+export DEB_CFLAGS_MAINT_APPEND = -Wl,-z,relro
+
+package=python-srp
+
+%:
+ dh $@ --with python2,sphinxdoc --buildsystem=python_distutils
+
+override_dh_auto_build:
+ sphinx-build $(CURDIR)/srp/doc $(CURDIR)/srp/doc/build
+
+ set -ex; \
+ for python in $(PYVERS); do \
+ $$python setup.py build; \
+ done
+
+override_dh_auto_install:
+ set -ex; \
+ for python in $(PYVERS); do \
+ $$python setup.py install --skip-build \
+ --root debian/$(package)\
+ --install-layout deb; \
+ done
+
+override_dh_install:
+ dh_install -Xsrp/doc/
+
+override_dh_installdocs:
+ mkdir -p debian/$(package)/usr/share/doc/$(package)
+ cp debian/copyright debian/$(package)/usr/share/doc/$(package)/
+
+override_dh_sphinxdoc:
+ cp -r srp/doc/build/* debian/$(package)/usr/share/doc/$(package)/
+ dh_sphinxdoc usr/share/doc/$(package)/
+
+override_dh_auto_clean:
+ dh_auto_clean
+ rm -rf srp/doc/build
+ rm -rf build
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..e9f6561
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,3 @@
+version=3
+
+http://pypi.python.org/packages/source/s/srp/srp-(.*)\.tar\.gz