summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/move_testvectors_outside_site-packages.patch38
-rw-r--r--debian/patches/noextraversion.patch34
-rw-r--r--debian/patches/series2
3 files changed, 74 insertions, 0 deletions
diff --git a/debian/patches/move_testvectors_outside_site-packages.patch b/debian/patches/move_testvectors_outside_site-packages.patch
new file mode 100644
index 0000000..7055927
--- /dev/null
+++ b/debian/patches/move_testvectors_outside_site-packages.patch
@@ -0,0 +1,38 @@
+Index: pycryptopp/src/pycryptopp/test/__init__.py
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ pycryptopp/src/pycryptopp/test/__init__.py 2013-08-22 16:45:30.747903892 -0400
+@@ -0,0 +1,7 @@
++import os
++
++def resource_string(package_or_requirement, resource_name):
++ return file(os.path.join("/usr/share/python-pycryptopp/%s" % resource_name)).read()
++
++def resource_listdir(package_or_requirement, resource_name):
++ return os.listdir("/usr/share/python-pycryptopp/%s" % resource_name)
+Index: pycryptopp/src/pycryptopp/test/test_aes.py
+===================================================================
+--- pycryptopp.orig/src/pycryptopp/test/test_aes.py 2013-08-22 16:39:52.488938601 -0400
++++ pycryptopp/src/pycryptopp/test/test_aes.py 2013-08-22 16:46:22.438522135 -0400
+@@ -11,7 +11,7 @@
+
+ from pycryptopp.cipher import aes
+
+-from pkg_resources import resource_string, resource_listdir
++from pycryptopp.test import resource_string, resource_listdir
+
+ from base64 import b32encode
+ def ab(x): # debuggery
+Index: pycryptopp/src/pycryptopp/test/test_sha256.py
+===================================================================
+--- pycryptopp.orig/src/pycryptopp/test/test_sha256.py 2013-08-22 16:39:52.488938601 -0400
++++ pycryptopp/src/pycryptopp/test/test_sha256.py 2013-08-22 16:46:40.282045087 -0400
+@@ -11,7 +11,7 @@
+
+ from pycryptopp.hash import sha256
+
+-from pkg_resources import resource_string
++from pycryptopp.test import resource_string
+
+ def resource_string_lines(pkgname, resname):
+ return split_on_newlines(resource_string(pkgname, resname))
diff --git a/debian/patches/noextraversion.patch b/debian/patches/noextraversion.patch
new file mode 100644
index 0000000..f88c476
--- /dev/null
+++ b/debian/patches/noextraversion.patch
@@ -0,0 +1,34 @@
+Index: pycryptopp/setup.py
+===================================================================
+--- pycryptopp.orig/setup.py 2013-08-22 16:56:10.818783603 -0400
++++ pycryptopp/setup.py 2013-08-22 16:56:44.165896373 -0400
+@@ -304,7 +304,7 @@
+ if mo:
+ return mo.group(1)
+
+-EXTRAVERSION_H_FNAME = os.path.join(EMBEDDED_CRYPTOPP_DIR, 'extraversion.h')
++#EXTRAVERSION_H_FNAME = os.path.join(EMBEDDED_CRYPTOPP_DIR, 'extraversion.h')
+
+ VERSION_BODY = '''
+ # This is the version of this tree, as created by %(versiontool)s from the
+@@ -335,13 +335,13 @@
+ # Let's avoid touching the change time (ctime) on the files unless
+ # they actually need to be updated.
+
+- if self.read_extraversion_h(EXTRAVERSION_H_FNAME) != version:
+- self.write_extraversion_h(
+- PKG,
+- version,
+- EXTRAVERSION_H_FNAME,
+- CPP_GIT_VERSION_BODY
+- )
++# if self.read_extraversion_h(EXTRAVERSION_H_FNAME) != version:
++# self.write_extraversion_h(
++# PKG,
++# version,
++# EXTRAVERSION_H_FNAME,
++# CPP_GIT_VERSION_BODY
++# )
+
+ if read_version_py(VERSION_PY_FNAME) != version:
+ self.write_version_py(
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..37f33e6
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,2 @@
+move_testvectors_outside_site-packages.patch
+noextraversion.patch