summaryrefslogtreecommitdiff
path: root/README-Debian
diff options
context:
space:
mode:
authork clair <kclair@riseup.net>2012-10-09 13:09:39 -0700
committerk clair <kclair@riseup.net>2012-10-09 13:10:20 -0700
commitd19a322e115378c78468a120974e15405482b5c7 (patch)
tree8d7c7e6ee97fdfa3c959802acfedfdd6e63254f9 /README-Debian
parentd74ffa03dc9cb7e87a70fe5205ea829327137cdb (diff)
rename README to README-Debian; minor fixes in the README-Debian filedebian
Diffstat (limited to 'README-Debian')
-rw-r--r--README-Debian44
1 files changed, 44 insertions, 0 deletions
diff --git a/README-Debian b/README-Debian
new file mode 100644
index 0000000..0e2cd50
--- /dev/null
+++ b/README-Debian
@@ -0,0 +1,44 @@
+This repository is used for building the python-jsonschema .deb package for debian and ubuntu.
+
+The debian packaging files are located in the debian branch.
+
+Building the package
+-------------------------
+
+1. set up environment variables, making sure the full name and email exactly match the GPG key used to sign:
+$ export DEBFULLNAME="Your Name"
+$ export DEBEMAIL="Your.Email@address.here"
+
+2. Download the tarball from http://pypi.python.org/pypi/jsonschema
+
+3. Unpack the tarball
+
+4. cd into the source directory
+
+5. run dh_make:
+$ dh_make -s -f ../jsonschema-0.6.tar.gz -e <Your.Email@address.here> -p python-jsonschema
+
+6. edit the debian/control file using the following fields:
+
+ Source: python-jsonschema
+ Section: python
+ Priority: optional
+ Maintainer: Your Name <Your.Email@address.here>
+ Build-Depends: debhelper (>= 7.0.50~), python-support, python (>=2.6)
+ Standards-Version: 3.9.4.0
+ Homepage: http://pypi.python.org/pypi/jsonschema
+
+ Package: python-jsonschema
+ Architecture: all
+ Depends: ${misc:Depends}, ${python:Depends}
+ Description: Provides the jsonschema python package
+
+7. edit the debian/copyright file, using the COPYING file in the source tree for the copyright text.
+
+8. specify supported python versions:
+$ echo "2.6-" > debian/pyversions
+
+9. [TODO] edit the debian/changelog file
+
+10. run debuild
+$ debuild