summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authork clair <kclair@riseup.net>2012-10-09 12:52:06 -0700
committerk clair <kclair@riseup.net>2012-10-09 12:52:06 -0700
commitd74ffa03dc9cb7e87a70fe5205ea829327137cdb (patch)
tree5ca4a7be84ce4774c68ad951ab103ebad5456fe3
parent01cbb318e1a94aa4ecfdf73f8265371b39972a52 (diff)
add README file
-rw-r--r--README43
1 files changed, 43 insertions, 0 deletions
diff --git a/README b/README
new file mode 100644
index 0000000..e954e7b
--- /dev/null
+++ b/README
@@ -0,0 +1,43 @@
+This repository is used for building the python-jsonschema .deb package for debian and ubuntu.
+
+Building the package
+-------------------------
+
+1. set up environment variables, making sure the full name and email exactly match the GPG key used to sign:
+$ export DEBFULLNAME="Your Name"
+$ export DEBEMAIL="Your.Email@address.here"
+
+2. Download the tarball from http://pypi.python.org/pypi/jsonschema
+
+3. Unpack the tarball
+
+4. cd into the source directory
+
+5. run dh_make:
+$ dh_make -s -f ../jsonschema-0.6.tar.gz -e <Your.Email@address.here> -p python-jsonschema
+
+6. edit the debian/control file using the description from the PKG-INFO file in the source tree,
+ and the following fields:
+
+ Source: python-jsonschema
+ Section: python
+ Priority: optional
+ Maintainer: Kristina Clair <kclair@leap.se>
+ Build-Depends: debhelper (>= 7.0.50~), python-support, python (>=2.6)
+ Standards-Version: 3.9.4.0
+ Homepage: http://pypi.python.org/pypi/jsonschema
+
+ Package: python-jsonschema
+ Architecture: all
+ Depends: ${misc:Depends}, ${python:Depends}
+ Description: Provides the jsonschema python package
+
+7. edit the debian/copyright file, using the COPYING file in the source tree for the copyright text.
+
+8. specify supported python versions:
+$ echo "2.6-" > debian/pyversions
+
+9. [TODO] edit the debian/changelog file
+
+10. run debuild
+$ debuild