Update Standards-Version to 4.1.1
authorVarac <varac@leap.se>
Thu, 26 Oct 2017 11:57:15 +0000 (13:57 +0200)
committerVarac <varac@leap.se>
Thu, 26 Oct 2017 11:57:15 +0000 (13:57 +0200)
.gitlab-ci.yml
debian/control

index fe640c4..f8ca281 100644 (file)
@@ -32,8 +32,8 @@ package:amd64_jessie:
     DIST: "jessie"
     REPONAMES: "platform,client"
     # Default is to fail on warnings, we disable it here
-    # unless the lintian warnings are fixed (see #2)
-    LINTIAN_OPTS: "-X filename-length"
+    # Standard-Version is higher than available for this release
+    LINTIAN_OPTS: "--fail-on-warnings -X filename-length,standards-version"
   <<: *job_definition
 
 package:amd64_stretch:
@@ -42,8 +42,8 @@ package:amd64_stretch:
     DIST: "stretch"
     REPONAMES: "platform,client"
     # Default is to fail on warnings, we disable it here
-    # unless the lintian warnings are fixed (see #2)
-    LINTIAN_OPTS: "-X filename-length"
+    # Standard-Version is higher than available for this release
+    LINTIAN_OPTS: "--fail-on-warnings -X filename-length,standards-version"
   <<: *job_definition
 
 package:amd64_buster:
@@ -51,9 +51,6 @@ package:amd64_buster:
     ARCH: "amd64"
     DIST: "buster"
     REPONAMES: "platform,client"
-    # Default is to fail on warnings, we disable it here
-    # unless the lintian warnings are fixed (see #2)
-    LINTIAN_OPTS: "-X filename-length"
   <<: *job_definition
 
 
@@ -63,8 +60,8 @@ package:amd64_zesty:
     DIST: "zesty"
     REPONAMES: "platform,client"
     # Default is to fail on warnings, we disable it here
-    # unless the lintian warnings are fixed (see #2)
-    LINTIAN_OPTS: "-X filename-length"
+    # Standard-Version is higher than available for this release
+    LINTIAN_OPTS: "--fail-on-warnings -X filename-length,standards-version"
   <<: *job_definition
 
 package:amd64_artful:
index 7c547f4..3216ccf 100644 (file)
@@ -3,7 +3,7 @@ Maintainer: Kali Kaneko <kali@leap.se>
 Section: python
 Priority: optional
 Build-Depends: python-all-dev (>= 2.6.6), libsqlcipher-dev (>=3.2.0), debhelper (>= 9), dh-python
-Standards-Version: 3.9.8
+Standards-Version: 4.1.1
 Uploaders: LEAP automated build <sysdev@leap.se>
 X-Python-Version: >= 2.5