summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRuben Pollan <meskio@sindominio.net>2017-02-02 20:25:20 +0100
committerRuben Pollan <meskio@sindominio.net>2017-02-02 23:58:37 +0100
commitbb9cc1216873604459724860d606283c398ea06b (patch)
tree877eb31a32e52619092e90ab83241986bdd475ef /setup.py
parenta55df58db59d38d7d320f51fa760f20cf1f69312 (diff)
[feat] add support for the blob interfacedevelop
Pysqlcipher support for the sqlite blob interface: https://sqlite.org/c3ref/blob_open.html Copying the code from the PR in pysqlite: https://github.com/ghaering/pysqlite/pull/93
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 86c43b4..1b3993e 100644
--- a/setup.py
+++ b/setup.py
@@ -52,7 +52,7 @@ PATCH_VERSION = None
sources = ["src/module.c", "src/connection.c", "src/cursor.c", "src/cache.c",
"src/microprotocols.c", "src/prepare_protocol.c", "src/statement.c",
- "src/util.c", "src/row.c"]
+ "src/util.c", "src/row.c", "src/blob.c"]
if PYSQLITE_EXPERIMENTAL:
sources.append("src/backup.c")